CVE-2025-59034
Indico may disclose unauthorized user details access via legacy API
Indico is an event management system that uses Flask-Multipass, a multi-backend authentication system for Flask. Prior to version 3.3.8, a legacy API to retrieve user details could be misused to retrieve profile details of other users without having admin permissions due to a broken access check. Users should to update to Indico 3.3.8 as soon as possible. As a workaround, it is possible to restrict access to the affected API (e.g. in the webserver config).
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- Low
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
4.3
Indico may disclose unauthorized user details access via legacy API
Indico is an event management system that uses Flask-Multipass, a multi-backend authentication system for Flask. Prior to version 3.3.8, a legacy API to retrieve user details could be misused to retrieve profile details of other users without having admin permissions due to a broken access check. Users should to update to Indico 3.3.8 as soon as possible. As a workaround, it is possible to restrict access to the affected API (e.g. in the webserver config).
- Record
CVE-2025-59034- CVSS 3.1
- 4.3 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N - Weakness
- CWE-639
- Updated
- 2026-11-02
EUVDEUVD-2025-27579
4.3
Indico is an event management system that uses Flask-Multipass, a multi-backend authentication system for Flask. Prior to version 3.3.8, a legacy API to retrieve user details could be misused to retrieve profile details of other users without having admin permissions due to a broken access check. Users should to update to Indico 3.3.8 as soon as possible. As a workaround, it is possible to restrict access to the affected API (e.g. in the webserver config).
- Record
EUVD-2025-27579- CVSS 3.1
- 4.3 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-4269-mcfh-cp7q
4.3
Indico may disclose unauthorized user details access via legacy API
Impact
A legacy API to retrieve user details could be misused to retrieve profile details of other users without having admin permissions due to a broken access check.
Patches
You should to update to Indico 3.3.8 as soon as possible. See the docs for instructions on how to update.
Workarounds
It is possible to restrict access to the affected API (e.g. in the webserver config) which is most likely unused anyway and thus will not break anything.
For more information
If you have any questions or comments about this advisory:
- Open a thread in our forum
- Email us privately at [email protected]
- Record
GHSA-4269-mcfh-cp7q- CVSS 3.1
- 4.3 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N - Weakness
- CWE-639
- Updated
- 2026-11-02
NVD
4.3
Indico is an event management system that uses Flask-Multipass, a multi-backend authentication system for Flask. Prior to version 3.3.8, a legacy API to retrieve user details could be misused to retrieve profile details of other users without having admin permissions due to a broken access check. Users should to update to Indico 3.3.8 as soon as possible. As a workaround, it is possible to restrict access to the affected API (e.g. in the webserver config).
- Record
CVE-2025-59034- CVSS 3.1
- 4.3 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N - Weakness
- CWE-639
- Updated
- 2026-11-02
OSV
4.3
Indico may disclose unauthorized user details access via legacy API
Indico is an event management system that uses Flask-Multipass, a multi-backend authentication system for Flask. Prior to version 3.3.8, a legacy API to retrieve user details could be misused to retrieve profile details of other users without having admin permissions due to a broken access check. Users should to update to Indico 3.3.8 as soon as possible. As a workaround, it is possible to restrict access to the affected API (e.g. in the webserver config).
- Record
CVE-2025-59034- CVSS 3.1
- 4.3 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N - Weakness
- CWE-639
- Updated
- 2026-11-02
OSVGHSA-4269-mcfh-cp7q
4.3
Indico may disclose unauthorized user details access via legacy API
Impact
A legacy API to retrieve user details could be misused to retrieve profile details of other users without having admin permissions due to a broken access check.
Patches
You should to update to Indico 3.3.8 as soon as possible. See the docs for instructions on how to update.
Workarounds
It is possible to restrict access to the affected API (e.g. in the webserver config) which is most likely unused anyway and thus will not break anything.
For more information
If you have any questions or comments about this advisory:
- Open a thread in our forum
- Email us privately at [email protected]
- Record
GHSA-4269-mcfh-cp7q- CVSS 3.1
- 4.3 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N - Weakness
- CWE-639
- Updated
- 2026-11-02
OSVPYSEC-2026-1460
4.3
Indico may disclose unauthorized user details access via legacy API
Impact
A legacy API to retrieve user details could be misused to retrieve profile details of other users without having admin permissions due to a broken access check.
Patches
You should to update to Indico 3.3.8 as soon as possible. See the docs for instructions on how to update.
Workarounds
It is possible to restrict access to the affected API (e.g. in the webserver config) which is most likely unused anyway and thus will not break anything.
For more information
If you have any questions or comments about this advisory:
- Open a thread in our forum
- Email us privately at [email protected]
- Record
PYSEC-2026-1460- CVSS 3.1
- 4.3 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
indicoPyPI |
through 3.3.7 | 3.3.8 |
indicoPyPI |
before 3.3.8, plus listed versions 0.98-rc10.98.00.98.10.98.20.99 Show 45 moreShow less1.01.11.1.11.1.21.21.2.11.2.1rc101.2.1rc111.2.1rc21.2.1rc41.2.1rc51.2.1rc61.2.1rc71.2.1rc91.2.21.2.2rc11.9.11.dev101.9.11.dev111.9.11.dev121.9.11.dev131.9.11.dev141.9.11.dev151.9.11.dev161.9.11.dev171.9.11.dev31.9.11.dev41.9.11.dev61.9.11.dev71.9.11.dev81.9.11.dev92.02.0.12.0.22.0.32.0a12.0rc12.0rc22.12.1.12.1.102.1.112.1.22.1.32.1.42.1.5 |
3.3.8 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2025-59034 is a medium vulnerability (CVSS 4.3) in Cern Indico, published September 10, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.26%, the 17th percentile. Fixed in indico 3.3.8.
References
github.com/indico/indico/security/advisories/GHSA-4269-mcfh-cp7q
github.com/indico/indico/releases/tag/v3.3.8
nvd.nist.gov/vuln/detail/CVE-2025-59034
github.com/advisories/GHSA-4269-mcfh-cp7q
github.com/CVEProject/cvelistV5/tree/main/cves/2025/59xxx/CVE-2025-59034.json
github.com/indico/indico
pypi.org/project/indico
Left out here: 45 versions. The JSON record has them.