CVE-2025-59431
MapServer - WFS XML Filter Query SQL injection
MapServer is a system for developing web-based GIS applications. Prior to 8.4.1, the XML Filter Query directive PropertyName is vulnerably to Boolean-based SQL injection. It seems like expression checking is bypassed by introducing double quote characters in the PropertyName. Allowing to manipulate backend database queries. This vulnerability is fixed in 8.4.1.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
8.9
MapServer - WFS XML Filter Query SQL injection
MapServer is a system for developing web-based GIS applications. Prior to 8.4.1, the XML Filter Query directive PropertyName is vulnerably to Boolean-based SQL injection. It seems like expression checking is bypassed by introducing double quote characters in the PropertyName. Allowing to manipulate backend database queries. This vulnerability is fixed in 8.4.1.
- Record
CVE-2025-59431- CVSS 4.0
- 8.9 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P - Weakness
- CWE-89
- Updated
- 2026-11-02
EUVDEUVD-2025-30323
8.9
MapServer is a system for developing web-based GIS applications. Prior to 8.4.1, the XML Filter Query directive PropertyName is vulnerably to Boolean-based SQL injection. It seems like expression checking is bypassed by introducing double quote characters in the PropertyName. Allowing to manipulate backend database queries. This vulnerability is fixed in 8.4.1.
- Record
EUVD-2025-30323- CVSS 4.0
- 8.9 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P - Updated
- 2026-11-02
NVD
8.9
MapServer is a system for developing web-based GIS applications. Prior to 8.4.1, the XML Filter Query directive PropertyName is vulnerably to Boolean-based SQL injection. It seems like expression checking is bypassed by introducing double quote characters in the PropertyName. Allowing to manipulate backend database queries. This vulnerability is fixed in 8.4.1.
- Record
CVE-2025-59431- CVSS 4.0
- 8.9 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X - CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-89
- Updated
- 2026-11-02
OSV
8.9
MapServer - WFS XML Filter Query SQL injection
MapServer is a system for developing web-based GIS applications. Prior to 8.4.1, the XML Filter Query directive PropertyName is vulnerably to Boolean-based SQL injection. It seems like expression checking is bypassed by introducing double quote characters in the PropertyName. Allowing to manipulate backend database queries. This vulnerability is fixed in 8.4.1.
- Record
CVE-2025-59431- CVSS 4.0
- 8.9 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P - Weakness
- CWE-89
- Updated
- 2026-11-02
OSVDEBIAN-CVE-2025-59431
9.8
MapServer is a system for developing web-based GIS applications. Prior to 8.4.1, the XML Filter Query directive PropertyName is vulnerably to Boolean-based SQL injection. It seems like expression checking is bypassed by introducing double quote characters in the PropertyName. Allowing to manipulate backend database queries. This vulnerability is fixed in 8.4.1.
- Record
DEBIAN-CVE-2025-59431- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2025-59431
8.9
MapServer is a system for developing web-based GIS applications. Prior to 8.4.1, the XML Filter Query directive PropertyName is vulnerably to Boolean-based SQL injection. It seems like expression checking is bypassed by introducing double quote characters in the PropertyName. Allowing to manipulate backend database queries. This vulnerability is fixed in 8.4.1.
- Record
UBUNTU-CVE-2025-59431- CVSS 4.0
- 8.9 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P - CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
mapserverDebian:12 |
before 8.0.0-3+deb12u1, plus listed versions 8.0.0-3 |
8.0.0-3+deb12u1 |
mapserverDebian:13 |
before 8.4.0-4+deb13u1, plus listed versions 8.4.0-4 |
8.4.0-4+deb13u1 |
mapserverDebian:14 |
before 8.4.1-1, plus listed versions 8.4.0-48.4.1-1~bpo13+1 |
8.4.1-1 |
mapserverDebian:11 From an advisory covering 2 CVEs |
before 7.6.2-1+deb11u1, plus listed versions 7.6.2-1 |
7.6.2-1+deb11u1 |
mapserverUbuntu:16.04:LTS |
All versions, plus listed versions 7.0.0-4build17.0.0-5ubuntu17.0.0-77.0.0-87.0.0-8build1 Show 5 moreShow less7.0.0-97.0.0-9ubuntu17.0.0-9ubuntu27.0.0-9ubuntu37.0.0-9ubuntu3.1 |
None known |
mapserverUbuntu:18.04:LTS |
All versions, plus listed versions 7.0.6-2build17.0.7-17.0.7-1build17.0.7-1build2 |
None known |
mapserverUbuntu:20.04:LTS |
All versions, plus listed versions 7.4.1-1build17.4.1-1build37.4.2-17.4.2-1build17.4.3-17.4.3-1build27.4.3-27.4.3-2build1 |
None known |
mapserverUbuntu:22.04:LTS |
All versions, plus listed versions 7.6.3-1~exp1ubuntu17.6.4-27.6.4-2build2 |
None known |
mapserverUbuntu:24.04:LTS |
All versions, plus listed versions 8.0.1-2build18.0.1-2build28.0.1-2build38.0.1-2build58.0.1-4ubuntu18.0.1-4ubuntu2 |
None known |
mapserverUbuntu:25.10 |
All versions, plus listed versions 8.4.0-1build18.4.0-48.4.0-4build1 |
None known |
mapserverUbuntu:26.10 |
All versions, plus listed versions 8.6.0-1build18.6.4-18.6.5-18.6.5-1build1 |
None known |
mapserverUbuntu:26.04:LTS |
All versions, plus listed versions 8.4.0-4build18.4.1-18.4.1-1build18.4.1-28.4.1-2build18.6.0-18.6.0-1build1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| first indexed | CVE List, EUVD, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2025-59431 is a high vulnerability (CVSS 8.9) in Mapserver, published September 19, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.41%, the 36th percentile. Fixed in mapserver 8.0.0-3+deb12u1.
References
github.com/MapServer/MapServer/security/advisories/GHSA-256m-rx4h-r55w
github.com/CVEProject/cvelistV5/tree/main/cves/2025/59xxx/CVE-2025-59431.json
nvd.nist.gov/vuln/detail/CVE-2025-59431
security-tracker.debian.org/tracker/CVE-2025-59431
ubuntu.com/security/CVE-2025-59431
cve.org/CVERecord?id=CVE-2025-59431