CVE-2025-60360
radare2 v5.9.8 and before contains a memory leak in the function r2r_subprocess_init.
radare2 v5.9.8 and before contains a memory leak in the function r2r_subprocess_init.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
5.5
radare2 v5.9.8 and before contains a memory leak in the function r2r_subprocess_init.
- Record
CVE-2025-60360- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-401
- Updated
- 2026-11-02
EUVDEUVD-2025-34880
5.5
radare2 v5.9.8 and before contains a memory leak in the function r2r_subprocess_init.
- Record
EUVD-2025-34880- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-c49h-4wfg-mh2v
3.3
radare2 v5.9.8 and before contains a memory leak in the function r2r_subprocess_init.
radare2 v5.9.8 and before contains a memory leak in the function r2r_subprocess_init.
- Record
GHSA-c49h-4wfg-mh2v- CVSS 3.1
- 3.3 Low
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L - Weakness
- CWE-401
- Updated
- 2026-11-02
NVD
5.5
radare2 v5.9.8 and before contains a memory leak in the function r2r_subprocess_init.
- Record
CVE-2025-60360- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-401
- Updated
- 2026-11-05
OSV
5.5
radare2 v5.9.8 and before contains a memory leak in the function r2r_subprocess_init.
- Record
CVE-2025-60360- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2025-60360
5.5
radare2 v5.9.8 and before contains a memory leak in the function r2r_subprocess_init.
- Record
UBUNTU-CVE-2025-60360- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUSN-7915-1 No score
radare2 vulnerabilities
It was discovered that Radare2 contained several memory leaks. An attacker could possibly use these issues to cause a denial of service.
- Record
USN-7915-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
radare2Ubuntu:16.04:LTS |
All versions, plus listed versions 0.9.6-3.1ubuntu1 |
None known |
radare2Ubuntu:Pro:18.04:LTS |
before 2.3.0+dfsg-2ubuntu0.1~esm1, plus listed versions 1.6.0+dfsg-12.0.0+dfsg-12.1.0+dfsg-12.3.0+dfsg-12.3.0+dfsg-2 |
2.3.0+dfsg-2ubuntu0.1~esm1 |
radare2Ubuntu:Pro:20.04:LTS |
before 4.2.1+dfsg-2ubuntu0.1~esm1, plus listed versions 3.2.1+dfsg-5build14.0.0+dfsg-14.2.1+dfsg-14.2.1+dfsg-2 |
4.2.1+dfsg-2ubuntu0.1~esm1 |
radare2Ubuntu:Pro:24.04:LTS |
before 5.5.0+dfsg-1.1ubuntu3+esm1, plus listed versions 5.5.0+dfsg-1ubuntu15.5.0+dfsg-1.1ubuntu25.5.0+dfsg-1.1ubuntu3 |
5.5.0+dfsg-1.1ubuntu3+esm1 |
radare2Ubuntu:25.10 |
before 5.9.8+dfsg-2ubuntu0.25.10.2, plus listed versions 5.9.8+dfsg-25.9.8+dfsg-2ubuntu0.25.10.1 |
5.9.8+dfsg-2ubuntu0.25.10.2 |
History
| Recorded | Changed | Sources |
|---|---|---|
| facts | NVD | |
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2025-60360 is a medium vulnerability (CVSS 5.5) in Radare Radare2, published October 17, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.17%, the 6th percentile. Fixed in radare2 2.3.0+dfsg-2ubuntu0.1~esm1.