CVE-2025-61656
XSS when pasting into VE
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Wikimedia Foundation VisualEditor. This vulnerability is associated with program files src/ce/ve.Ce.ClipboardHandler.Js.
This issue affects VisualEditor: from * before 1.39.14, 1.43.4, 1.44.1.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
0.0
XSS when pasting into VE
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Wikimedia Foundation VisualEditor. This vulnerability is associated with program files src/ce/ve.Ce.ClipboardHandler.Js.
This issue affects VisualEditor: from * before 1.39.14, 1.43.4, 1.44.1.
- Record
CVE-2025-61656- CVSS 4.0
- 0.0 None
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:N/SI:N/SA:N/E:U - Weakness
- CWE-79
- Updated
- 2026-11-02
EUVDEUVD-2025-206652 No score
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Wikimedia Foundation VisualEditor. This vulnerability is associated with program files src/ce/ve.Ce.ClipboardHandler.Js.
This issue affects VisualEditor: from * before 1.39.14, 1.43.4, 1.44.1.
- Record
EUVD-2025-206652- Updated
- 2026-11-02
GitHub AdvisoriesGHSA-5499-9jhv-ccm9
0.0
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting')...
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Wikimedia Foundation VisualEditor. This vulnerability is associated with program files src/ce/ve.Ce.ClipboardHandler.Js.
This issue affects VisualEditor: from * before 1.39.14, 1.43.4, 1.44.1.
- Record
GHSA-5499-9jhv-ccm9- CVSS 4.0
- 0.0 None
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:N/SI:N/SA:N/E:U/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X - CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
NVD
0.0
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Wikimedia Foundation VisualEditor. This vulnerability is associated with program files src/ce/ve.Ce.ClipboardHandler.Js.
This issue affects VisualEditor: from * before 1.39.14, 1.43.4, 1.44.1.
- Record
CVE-2025-61656- CVSS 4.0
- 0.0 None
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:N/SI:N/SA:N/E:U/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X - CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVDEBIAN-CVE-2025-61656
6.1
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Wikimedia Foundation VisualEditor. This vulnerability is associated with program files src/ce/ve.Ce.ClipboardHandler.Js. This issue affects VisualEditor: from * before 1.39.14, 1.43.4, 1.44.1.
- Record
DEBIAN-CVE-2025-61656- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVUBUNTU-CVE-2025-61656
0.0
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Wikimedia Foundation VisualEditor. This vulnerability is associated with program files src/ce/ve.Ce.ClipboardHandler.Js. This issue affects VisualEditor: from * before 1.39.14, 1.43.4, 1.44.1.
- Record
UBUNTU-CVE-2025-61656- CVSS 4.0
- 0.0 None
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:N/SI:N/SA:N/E:U - CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
mediawikiDebian:12 |
before 1:1.39.17-1~deb12u1, plus listed versions 1:1.39.10-11:1.39.10-1~deb12u11:1.39.12-1~deb12u11:1.39.13-1~deb12u11:1.39.2-1 Show 9 moreShow less1:1.39.4-11:1.39.4-1~deb12u11:1.39.4-21:1.39.5-11:1.39.5-1~deb12u11:1.39.6-11:1.39.7-11:1.39.7-1~deb12u11:1.39.8-1 |
1:1.39.17-1~deb12u1 |
mediawikiDebian:13 |
before 1:1.43.6+dfsg-1~deb13u1, plus listed versions 1:1.43.3+dfsg-11:1.43.5+dfsg-1 |
1:1.43.6+dfsg-1~deb13u1 |
mediawikiDebian:14 |
before 1:1.43.5+dfsg-1, plus listed versions 1:1.43.3+dfsg-1 |
1:1.43.5+dfsg-1 |
mediawikiDebian:11 From an advisory covering 12 CVEs |
before 1:1.35.13-1+deb11u5, plus listed versions 1:1.35.11-1~deb11u11:1.35.13-1+deb11u21:1.35.13-1+deb11u31:1.35.13-1+deb11u41:1.35.13-1~deb11u1 Show 12 moreShow less1:1.35.2-11:1.35.3-11:1.35.4-11:1.35.4-1+deb11u21:1.35.4-1~deb11u11:1.35.5-11:1.35.5-21:1.35.6-11:1.35.7-11:1.35.8-11:1.35.8-1.11:1.35.8-1~deb11u1 |
1:1.35.13-1+deb11u5 |
mediawikiDebian:12 From an advisory covering 19 CVEs |
before 1:1.39.17-1~deb12u1, plus listed versions 1:1.39.10-11:1.39.10-1~deb12u11:1.39.12-1~deb12u11:1.39.13-1~deb12u11:1.39.2-1 Show 9 moreShow less1:1.39.4-11:1.39.4-1~deb12u11:1.39.4-21:1.39.5-11:1.39.5-1~deb12u11:1.39.6-11:1.39.7-11:1.39.7-1~deb12u11:1.39.8-1 |
1:1.39.17-1~deb12u1 |
mediawikiDebian:13 From an advisory covering 19 CVEs |
before 1:1.43.6+dfsg-1~deb13u1, plus listed versions 1:1.43.3+dfsg-11:1.43.5+dfsg-1 |
1:1.43.6+dfsg-1~deb13u1 |
mediawikiUbuntu:18.04:LTS |
All versions, plus listed versions 1:1.27.3-11:1.27.4-11:1.27.4-21:1.27.4-3 |
None known |
mediawikiUbuntu:Pro:20.04:LTS |
All versions, plus listed versions 1:1.31.2-1ubuntu11:1.31.5-11:1.31.5-1ubuntu11:1.31.5-21:1.31.5-3 Show 4 moreShow less1:1.31.5-3ubuntu11:1.31.6-11:1.31.7-11:1.31.7-1ubuntu0.1~esm1 |
None known |
mediawikiUbuntu:Pro:22.04:LTS |
All versions, plus listed versions 1:1.35.3-11:1.35.4-11:1.35.5-11:1.35.5-1ubuntu11:1.35.5-1ubuntu21:1.35.5-1ubuntu31:1.35.6-11:1.35.6-1ubuntu0.1~esm1 |
None known |
mediawikiUbuntu:Pro:24.04:LTS |
All versions, plus listed versions 1:1.39.4-21:1.39.5-11:1.39.6-11:1.39.7-11:1.39.7-1ubuntu0.1~esm1 |
None known |
mediawikiUbuntu:25.10 |
All versions, plus listed versions 1:1.43.1+dfsg-11:1.43.1+dfsg-21:1.43.3+dfsg-1 |
None known |
mediawikiUbuntu:26.10 |
All versions, plus listed versions 1:1.43.8+dfsg-21:1.43.9+dfsg-11:1.43.9+dfsg-1ubuntu1 |
None known |
mediawikiUbuntu:26.04:LTS |
All versions, plus listed versions 1:1.43.3+dfsg-11:1.43.5+dfsg-11:1.43.6+dfsg-21:1.43.8+dfsg-11:1.43.8+dfsg-2 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2025-61656 is a none vulnerability (CVSS 0.0) in Wikimedia Foundation Visualeditor, published October 31, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.18%, the 7th percentile. Fixed in mediawiki 1:1.39.17-1~deb12u1.