Every CVE Search/ Get API key

CVE-2025-61733

Apache Kylin: Authentication bypass

7.5 HighFix available

Authentication Bypass Using an Alternate Path or Channel vulnerability in Apache Kylin.

This issue affects Apache Kylin: from 4.0.0 through 5.0.2.

Users are recommended to upgrade to version 5.0.3, which fixes the issue.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
None
Availability
None

Exploit likelihood

1.30%Up 1.3 points since Oct 2, 2025
90%50%10%1%

What each source reports

CVE List Score used 7.5

Apache Kylin: Authentication bypass

Authentication Bypass Using an Alternate Path or Channel vulnerability in Apache Kylin.

This issue affects Apache Kylin: from 4.0.0 through 5.0.2.

Users are recommended to upgrade to version 5.0.3, which fixes the issue.

Record
CVE-2025-61733
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-288
Updated
2026-11-02
EUVDEUVD-2025-32642 7.5

Authentication Bypass Using an Alternate Path or Channel vulnerability in Apache Kylin.

This issue affects Apache Kylin: from 4.0.0 through 5.0.2.

Users are recommended to upgrade to version 5.0.3, which fixes the issue.

Record
EUVD-2025-32642
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
GitHub AdvisoriesGHSA-mr9j-4j48-xcm2 7.5

Apache Kylin Authentication Bypass Vulnerability

Authentication Bypass Using an Alternate Path or Channel vulnerability in Apache Kylin.

This issue affects Apache Kylin: from 4.0.0 through 5.0.2.

Users are recommended to upgrade to version 5.0.3, which fixes the issue.

Record
GHSA-mr9j-4j48-xcm2
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-288
Updated
2026-11-02
NVD 7.5

Authentication Bypass Using an Alternate Path or Channel vulnerability in Apache Kylin.

This issue affects Apache Kylin: from 4.0.0 through 5.0.2.

Users are recommended to upgrade to version 5.0.3, which fixes the issue.

Record
CVE-2025-61733
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-288
Updated
2026-11-02
OSV 7.5

Apache Kylin: Authentication bypass

Authentication Bypass Using an Alternate Path or Channel vulnerability in Apache Kylin.

This issue affects Apache Kylin: from 4.0.0 through 5.0.2.

Users are recommended to upgrade to version 5.0.3, which fixes the issue.

Record
CVE-2025-61733
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-288
Updated
2026-11-02
OSVGHSA-mr9j-4j48-xcm2 7.5

Apache Kylin Authentication Bypass Vulnerability

Authentication Bypass Using an Alternate Path or Channel vulnerability in Apache Kylin.

This issue affects Apache Kylin: from 4.0.0 through 5.0.2.

Users are recommended to upgrade to version 5.0.3, which fixes the issue.

Record
GHSA-mr9j-4j48-xcm2
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-288
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.apache.kylin:kylin
Maven
4.0.0 up to 5.0.3
5.0.3
org.apache.kylin:kylin-core-common
Maven
4.0.0 up to 5.0.3
5.0.3
org.apache.kylin:kylin
Maven
4.0.0 up to 5.0.3, plus listed versions
4.0.14.0.24.0.34.0.45.0.05.0.0-alpha5.0.0-beta5.0.2
5.0.3
org.apache.kylin:kylin-core-common
Maven
4.0.0 up to 5.0.3, plus listed versions
4.0.14.0.24.0.34.0.45.0.05.0.0-alpha5.0.0-beta5.0.2
5.0.3

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2025-61733 is a high vulnerability (CVSS 7.5) in Apache Kylin, published October 2, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.30%, the 70th percentile. Fixed in org.apache.kylin:kylin 5.0.3.

References

MoveEnter Open