Every CVE Search/ Get API key

CVE-2025-61734

Apache Kylin: improper restriction of file read

7.5 HighFix available

Files or Directories Accessible to External Parties vulnerability in Apache Kylin. You are fine as long as the Kylin's system and project admin access is well protected.

This issue affects Apache Kylin: from 4.0.0 through 5.0.2.

Users are recommended to upgrade to version 5.0.3, which fixes the issue.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
None
Availability
None

Exploit likelihood

26.1%Up 26.1 points since Oct 2, 2025
90%50%10%1%

What each source reports

CVE List Score used 7.5

Apache Kylin: improper restriction of file read

Files or Directories Accessible to External Parties vulnerability in Apache Kylin. You are fine as long as the Kylin's system and project admin access is well protected.

This issue affects Apache Kylin: from 4.0.0 through 5.0.2.

Users are recommended to upgrade to version 5.0.3, which fixes the issue.

Record
CVE-2025-61734
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-552
Updated
2026-11-02
EUVDEUVD-2025-32643 7.5

Files or Directories Accessible to External Parties vulnerability in Apache Kylin. You are fine as long as the Kylin's system and project admin access is well protected.

This issue affects Apache Kylin: from 4.0.0 through 5.0.2.

Users are recommended to upgrade to version 5.0.3, which fixes the issue.

Record
EUVD-2025-32643
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
GitHub AdvisoriesGHSA-p86w-w5rh-m3hx 7.5

Apache Kylin Files or Directories Accessible to External Parties

Files or Directories Accessible to External Parties vulnerability in Apache Kylin. You are fine as long as the Kylin's system and project admin access is well protected.

This issue affects Apache Kylin: from 4.0.0 through 5.0.2.

Users are recommended to upgrade to version 5.0.3, which fixes the issue.

Record
GHSA-p86w-w5rh-m3hx
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-552
Updated
2026-11-02
NVD 7.5

Files or Directories Accessible to External Parties vulnerability in Apache Kylin. You are fine as long as the Kylin's system and project admin access is well protected.

This issue affects Apache Kylin: from 4.0.0 through 5.0.2.

Users are recommended to upgrade to version 5.0.3, which fixes the issue.

Record
CVE-2025-61734
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-552
Updated
2026-11-02
OSV 7.5

Apache Kylin: improper restriction of file read

Files or Directories Accessible to External Parties vulnerability in Apache Kylin. You are fine as long as the Kylin's system and project admin access is well protected.

This issue affects Apache Kylin: from 4.0.0 through 5.0.2.

Users are recommended to upgrade to version 5.0.3, which fixes the issue.

Record
CVE-2025-61734
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-552
Updated
2026-11-02
OSVGHSA-p86w-w5rh-m3hx 7.5

Apache Kylin Files or Directories Accessible to External Parties

Files or Directories Accessible to External Parties vulnerability in Apache Kylin. You are fine as long as the Kylin's system and project admin access is well protected.

This issue affects Apache Kylin: from 4.0.0 through 5.0.2.

Users are recommended to upgrade to version 5.0.3, which fixes the issue.

Record
GHSA-p86w-w5rh-m3hx
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-552
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.apache.kylin:kylin
Maven
4.0.0 up to 5.0.3
5.0.3
org.apache.kylin:kylin-common-server
Maven
4.0.0 up to 5.0.3
5.0.3
org.apache.kylin:kylin-common-service
Maven
4.0.0 up to 5.0.3
5.0.3
org.apache.kylin:kylin-core-common
Maven
4.0.0 up to 5.0.3
5.0.3
org.apache.kylin:kylin-core-metadata
Maven
4.0.0 up to 5.0.3
5.0.3
org.apache.kylin:kylin-ops-server
Maven
4.0.0 up to 5.0.3
5.0.3
org.apache.kylin:kylin-server
Maven
4.0.0 up to 5.0.3
5.0.3
org.apache.kylin:kylin
Maven
4.0.0 up to 5.0.3, plus listed versions
4.0.14.0.24.0.34.0.45.0.05.0.0-alpha5.0.0-beta5.0.2
5.0.3
org.apache.kylin:kylin-common-server
Maven
4.0.0 up to 5.0.3, plus listed versions
5.0.05.0.0-alpha5.0.0-beta5.0.2
5.0.3
org.apache.kylin:kylin-common-service
Maven
4.0.0 up to 5.0.3, plus listed versions
5.0.05.0.0-alpha5.0.0-beta5.0.2
5.0.3
Show 4 moreShow less
Affected packages
PackageAffectedFixed
org.apache.kylin:kylin-core-common
Maven
4.0.0 up to 5.0.3, plus listed versions
4.0.14.0.24.0.34.0.45.0.05.0.0-alpha5.0.0-beta5.0.2
5.0.3
org.apache.kylin:kylin-core-metadata
Maven
4.0.0 up to 5.0.3, plus listed versions
4.0.14.0.24.0.34.0.45.0.05.0.0-alpha5.0.0-beta5.0.2
5.0.3
org.apache.kylin:kylin-ops-server
Maven
4.0.0 up to 5.0.3, plus listed versions
5.0.05.0.2
5.0.3
org.apache.kylin:kylin-server
Maven
4.0.0 up to 5.0.3, plus listed versions
4.0.14.0.24.0.34.0.45.0.05.0.0-alpha5.0.0-beta5.0.2
5.0.3

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2025-61734 is a high vulnerability (CVSS 7.5) in Apache Kylin, published October 2, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 26.1%, the 98th percentile. Fixed in org.apache.kylin:kylin 5.0.3.

References

MoveEnter Open