Every CVE Search/ Get API key

CVE-2025-61735

Apache Kylin: Server-Side Request Forgery

7.3 HighFix available

Server-Side Request Forgery (SSRF) vulnerability in Apache Kylin.

This issue affects Apache Kylin: from 4.0.0 through 5.0.2. You are fine as long as the Kylin's system and project admin access is well protected.

Users are recommended to upgrade to version 5.0.3, which fixes the issue.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
Low

Exploit likelihood

1.04%Up 1.0 points since Oct 2, 2025
90%50%10%1%

What each source reports

CVE List Score used 7.3

Apache Kylin: Server-Side Request Forgery

Server-Side Request Forgery (SSRF) vulnerability in Apache Kylin.

This issue affects Apache Kylin: from 4.0.0 through 5.0.2. You are fine as long as the Kylin's system and project admin access is well protected.

Users are recommended to upgrade to version 5.0.3, which fixes the issue.

Record
CVE-2025-61735
CVSS 3.1
7.3 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Weakness
CWE-918
Updated
2026-11-02
EUVDEUVD-2025-32572 7.3

Server-Side Request Forgery (SSRF) vulnerability in Apache Kylin.

This issue affects Apache Kylin: from 4.0.0 through 5.0.2. You are fine as long as the Kylin's system and project admin access is well protected.

Users are recommended to upgrade to version 5.0.3, which fixes the issue.

Record
EUVD-2025-32572
CVSS 3.1
7.3 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Updated
2026-11-02
GitHub AdvisoriesGHSA-f6m8-qm7j-fh65 7.3

Apache Kylin Server-Side Request Forgery (SSRF) Vulnerability

Server-Side Request Forgery (SSRF) vulnerability in Apache Kylin.

This issue affects Apache Kylin: from 4.0.0 through 5.0.2. You are fine as long as the Kylin's system and project admin access is well protected.

Users are recommended to upgrade to version 5.0.3, which fixes the issue.

Record
GHSA-f6m8-qm7j-fh65
CVSS 3.1
7.3 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Weakness
CWE-918
Updated
2026-11-02
NVD 7.3

Server-Side Request Forgery (SSRF) vulnerability in Apache Kylin.

This issue affects Apache Kylin: from 4.0.0 through 5.0.2. You are fine as long as the Kylin's system and project admin access is well protected.

Users are recommended to upgrade to version 5.0.3, which fixes the issue.

Record
CVE-2025-61735
CVSS 3.1
7.3 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Weakness
CWE-918
Updated
2026-11-02
OSV 7.3

Apache Kylin: Server-Side Request Forgery

Server-Side Request Forgery (SSRF) vulnerability in Apache Kylin.

This issue affects Apache Kylin: from 4.0.0 through 5.0.2. You are fine as long as the Kylin's system and project admin access is well protected.

Users are recommended to upgrade to version 5.0.3, which fixes the issue.

Record
CVE-2025-61735
CVSS 3.1
7.3 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Weakness
CWE-918
Updated
2026-11-02
OSVGHSA-f6m8-qm7j-fh65 7.3

Apache Kylin Server-Side Request Forgery (SSRF) Vulnerability

Server-Side Request Forgery (SSRF) vulnerability in Apache Kylin.

This issue affects Apache Kylin: from 4.0.0 through 5.0.2. You are fine as long as the Kylin's system and project admin access is well protected.

Users are recommended to upgrade to version 5.0.3, which fixes the issue.

Record
GHSA-f6m8-qm7j-fh65
CVSS 3.1
7.3 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Weakness
CWE-918
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.apache.kylin:kylin
Maven
4.0.0 up to 5.0.3
5.0.3
org.apache.kylin:kylin-common-server
Maven
4.0.0 up to 5.0.3
5.0.3
org.apache.kylin:kylin-common-service
Maven
4.0.0 up to 5.0.3
5.0.3
org.apache.kylin:kylin-core-common
Maven
4.0.0 up to 5.0.3
5.0.3
org.apache.kylin:kylin-core-metadata
Maven
4.0.0 up to 5.0.3
5.0.3
org.apache.kylin:kylin-ops-server
Maven
4.0.0 up to 5.0.3
5.0.3
org.apache.kylin:kylin-server
Maven
4.0.0 up to 5.0.3
5.0.3
org.apache.kylin:kylin
Maven
4.0.0 up to 5.0.3, plus listed versions
4.0.14.0.24.0.34.0.45.0.05.0.0-alpha5.0.0-beta5.0.2
5.0.3
org.apache.kylin:kylin-common-server
Maven
4.0.0 up to 5.0.3, plus listed versions
5.0.05.0.0-alpha5.0.0-beta5.0.2
5.0.3
org.apache.kylin:kylin-common-service
Maven
4.0.0 up to 5.0.3, plus listed versions
5.0.05.0.0-alpha5.0.0-beta5.0.2
5.0.3
Show 4 moreShow less
Affected packages
PackageAffectedFixed
org.apache.kylin:kylin-core-common
Maven
4.0.0 up to 5.0.3, plus listed versions
4.0.14.0.24.0.34.0.45.0.05.0.0-alpha5.0.0-beta5.0.2
5.0.3
org.apache.kylin:kylin-core-metadata
Maven
4.0.0 up to 5.0.3, plus listed versions
4.0.14.0.24.0.34.0.45.0.05.0.0-alpha5.0.0-beta5.0.2
5.0.3
org.apache.kylin:kylin-ops-server
Maven
4.0.0 up to 5.0.3, plus listed versions
5.0.05.0.2
5.0.3
org.apache.kylin:kylin-server
Maven
4.0.0 up to 5.0.3, plus listed versions
4.0.14.0.24.0.34.0.45.0.05.0.0-alpha5.0.0-beta5.0.2
5.0.3

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2025-61735 is a high vulnerability (CVSS 7.3) in Apache Kylin, published October 2, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.04%, the 64th percentile. Fixed in org.apache.kylin:kylin 5.0.3.

References

MoveEnter Open