CVE-2025-61924
PrestaShop Checkout Target PayPal merchant account hijacking from backoffice
PrestaShop Checkout is the PrestaShop official payment module in partnership with PayPal. In versions prior to 4.4.1 and 5.0.5, the Target PayPal merchant account hijacking from backoffice due to wrong usage of the PHP array_search(). The vulnerability is fixed in versions 4.4.1 and 5.0.5. No known workarounds exist.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- High
- User interaction
- None
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
3.8
PrestaShop Checkout Target PayPal merchant account hijacking from backoffice
PrestaShop Checkout is the PrestaShop official payment module in partnership with PayPal. In versions prior to 4.4.1 and 5.0.5, the Target PayPal merchant account hijacking from backoffice due to wrong usage of the PHP array_search(). The vulnerability is fixed in versions 4.4.1 and 5.0.5. No known workarounds exist.
- Record
CVE-2025-61924- CVSS 3.1
- 3.8 Low
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:N - Weakness
- CWE-184
- Updated
- 2026-11-02
EUVDEUVD-2025-34788
3.8
PrestaShop Checkout is the PrestaShop official payment module in partnership with PayPal. In versions prior to 4.4.1 and 5.0.5, the Target PayPal merchant account hijacking from backoffice due to wrong usage of the PHP array_search(). The vulnerability is fixed in versions 4.4.1 and 5.0.5. No known workarounds exist.
- Record
EUVD-2025-34788- CVSS 3.1
- 3.8 Low
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:N - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-wvpg-4wrh-5889
3.8
PrestaShop Checkout Target PayPal merchant account hijacking from backoffice
Impact
Wrong usage of the PHP array_search() allows bypass of validation.
Patches
The problem has been patched in versions:
- v4.4.1 for PrestaShop 1.7 (build number: 7.4.4.1)
- v4.4.1 for PrestaShop 8 (build number: 8.4.4.1)
- v5.0.5 for PrestaShop 1.7 (build number: 7.5.0.5)
- v5.0.5 for PrestaShop 8 (build number: 8.5.0.5)
- v5.0.5 for PrestaShop 9 (build number: 9.5.0.5)
Read the Versioning policy to learn more about the build number.
Credits
Léo CUNÉAZ reported this issue.
- Record
GHSA-wvpg-4wrh-5889- CVSS 3.1
- 3.8 Low
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:N - Weakness
- CWE-184
- Updated
- 2026-11-02
NVD
3.8
PrestaShop Checkout is the PrestaShop official payment module in partnership with PayPal. In versions prior to 4.4.1 and 5.0.5, the Target PayPal merchant account hijacking from backoffice due to wrong usage of the PHP array_search(). The vulnerability is fixed in versions 4.4.1 and 5.0.5. No known workarounds exist.
- Record
CVE-2025-61924- CVSS 3.1
- 3.8 Low
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:N - Weakness
- CWE-184
- Updated
- 2026-11-02
OSV
3.8
PrestaShop Checkout Target PayPal merchant account hijacking from backoffice
PrestaShop Checkout is the PrestaShop official payment module in partnership with PayPal. In versions prior to 4.4.1 and 5.0.5, the Target PayPal merchant account hijacking from backoffice due to wrong usage of the PHP array_search(). The vulnerability is fixed in versions 4.4.1 and 5.0.5. No known workarounds exist.
- Record
CVE-2025-61924- CVSS 3.1
- 3.8 Low
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:N - Weakness
- CWE-184
- Updated
- 2026-11-02
OSVGHSA-wvpg-4wrh-5889
3.8
PrestaShop Checkout Target PayPal merchant account hijacking from backoffice
Impact
Wrong usage of the PHP array_search() allows bypass of validation.
Patches
The problem has been patched in versions:
- v4.4.1 for PrestaShop 1.7 (build number: 7.4.4.1)
- v4.4.1 for PrestaShop 8 (build number: 8.4.4.1)
- v5.0.5 for PrestaShop 1.7 (build number: 7.5.0.5)
- v5.0.5 for PrestaShop 8 (build number: 8.5.0.5)
- v5.0.5 for PrestaShop 9 (build number: 9.5.0.5)
Read the Versioning policy to learn more about the build number.
Credits
Léo CUNÉAZ reported this issue.
- Record
GHSA-wvpg-4wrh-5889- CVSS 3.1
- 3.8 Low
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:N - Weakness
- CWE-184
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
prestashop/ps_checkoutPackagist |
before 4.4.1 | 4.4.1 |
prestashop/ps_checkoutPackagist |
5.0.0 up to 5.0.5 | 5.0.5 |
prestashop/ps_checkoutPackagist |
before 4.4.1, plus listed versions v1.0.1v1.0.2v1.0.3v1.0.4v1.0.5 Show 45 moreShow lessv1.0.6v1.0.7v1.0.8v1.0.9v1.1.1v1.1.2v1.1.3v1.1.4v1.1.5v1.1.6v1.1.7v1.1.8v1.2v1.2.1v1.2.10v1.2.10-beta.1v1.2.10-beta.2v1.2.10-beta.3v1.2.10-beta.4v1.2.11v1.2.12v1.2.12-beta.1v1.2.13v1.2.14-beta.1v1.2.14-beta.2v1.2.2v1.2.3v1.2.5v1.2.6v1.2.6-beta.1v1.2.7v1.2.7-beta.1v1.2.7-beta.2v1.2.8v1.2.9v1.3.0v1.3.0-beta.1v1.3.0-beta.2v1.4.0v1.4.1v1.5.0v1.5.1v1.5.2v2.0.0v2.0.1 |
4.4.1 |
prestashop/ps_checkoutPackagist |
5.0.0 up to 5.0.5, plus listed versions v5.0.1v5.0.2v5.0.3v5.0.4v5.0.4-beta1 Show 9 moreShow lessv5.0.4-beta10v5.0.4-beta2v5.0.4-beta3v5.0.4-beta4v5.0.4-beta5v5.0.4-beta6v5.0.4-beta7v5.0.4-beta8v5.0.4-beta9 |
5.0.5 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2025-61924 is a low vulnerability (CVSS 3.8) in Prestashop Checkout, published October 16, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.27%, the 19th percentile. Fixed in prestashop/ps_checkout 4.4.1.
References
Left out here: 43 versions. The JSON record has them.