CVE-2025-62228
Apache Flink CDC, Apache Flink CDC, Apache Flink CDC, Apache Flink CDC, Apache Flink CDC: SQL injection via maliciously crafted identifiers
Apache Flink CDC version 3.4.0 was vulnerable to a SQL injection via maliciously crafted identifiers eg. crafted database name or crafted table name. Even through only the logged-in database user can trigger the attack, we recommend users update Flink CDC version to 3.5.0 which address this issue.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- High
- User interaction
- None
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- Low
Exploit likelihood
What each source reports
CVE List Score used
5.1
Apache Flink CDC, Apache Flink CDC, Apache Flink CDC, Apache Flink CDC, Apache Flink CDC: SQL injection via maliciously crafted identifiers
Apache Flink CDC version 3.4.0 was vulnerable to a SQL injection via maliciously crafted identifiers eg. crafted database name or crafted table name. Even through only the logged-in database user can trigger the attack, we recommend users update Flink CDC version to 3.5.0 which address this issue.
- Record
CVE-2025-62228- CVSS 4.0
- 5.1 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:L/VI:L/VA:L/SC:L/SI:L/SA:L/R:U/V:C/RE:L/U:Amber - Weakness
- CWE-89
- Updated
- 2026-11-02
EUVDEUVD-2025-33342
5.1
Apache Flink CDC version 3.4.0 was vulnerable to a SQL injection via maliciously crafted identifiers eg. crafted database name or crafted table name. Even through only the logged-in database user can trigger the attack, we recommend users update Flink CDC version to 3.5.0 which address this issue.
- Record
EUVD-2025-33342- CVSS 4.0
- 5.1 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:L/VI:L/VA:L/SC:L/SI:L/SA:L/R:U/V:C/RE:L/U:Amber - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-wqm3-w3p6-xjgm
5.1
Apache Flink CDC is vulnerable to SQL Injection through maliciously crafted identifiers
Apache Flink CDC version 3.0.0 to before 3.5.0 are vulnerable to a SQL injection via maliciously crafted identifiers eg. crafted database name or crafted table name. Even through only the logged-in database user can trigger the attack, users are recommended to update Flink CDC version to 3.5.0 which address this issue.
- Record
GHSA-wqm3-w3p6-xjgm- CVSS 4.0
- 5.1 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:L/VI:L/VA:L/SC:L/SI:L/SA:L - Weakness
- CWE-89
- Updated
- 2026-11-02
NVD
5.1
Apache Flink CDC version 3.4.0 was vulnerable to a SQL injection via maliciously crafted identifiers eg. crafted database name or crafted table name. Even through only the logged-in database user can trigger the attack, we recommend users update Flink CDC version to 3.5.0 which address this issue.
- Record
CVE-2025-62228- CVSS 4.0
- 5.1 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:L/VI:L/VA:L/SC:L/SI:L/SA:L/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:U/V:C/RE:L/U:Amber - CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-89
- Updated
- 2026-11-02
OSVGHSA-wqm3-w3p6-xjgm
5.1
Apache Flink CDC is vulnerable to SQL Injection through maliciously crafted identifiers
Apache Flink CDC version 3.0.0 to before 3.5.0 are vulnerable to a SQL injection via maliciously crafted identifiers eg. crafted database name or crafted table name. Even through only the logged-in database user can trigger the attack, users are recommended to update Flink CDC version to 3.5.0 which address this issue.
- Record
GHSA-wqm3-w3p6-xjgm- CVSS 4.0
- 5.1 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:L/VI:L/VA:L/SC:L/SI:L/SA:L - Weakness
- CWE-89
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
org.apache.flink:flink-cdc-pipeline-connectorsMaven |
3.0.0 up to 3.5.0 | 3.5.0 |
org.apache.flink:flink-connector-oracle-cdcMaven |
3.0.0 up to 3.5.0 | 3.5.0 |
org.apache.flink:flink-connector-db2-cdcMaven |
3.0.0 up to 3.5.0 | 3.5.0 |
org.apache.flink:flink-connector-sqlserver-cdcMaven |
3.0.0 up to 3.5.0 | 3.5.0 |
org.apache.flink:flink-connector-mysql-cdcMaven |
3.0.0 up to 3.5.0 | 3.5.0 |
org.apache.flink:flink-cdc-pipeline-connectorsMaven |
3.0.0 up to 3.5.0, plus listed versions 3.1.03.1.13.2.03.2.13.3.03.4.0 |
3.5.0 |
org.apache.flink:flink-connector-oracle-cdcMaven |
3.0.0 up to 3.5.0, plus listed versions 3.1.03.1.13.2.03.2.13.3.03.4.0 |
3.5.0 |
org.apache.flink:flink-connector-db2-cdcMaven |
3.0.0 up to 3.5.0, plus listed versions 3.1.03.1.13.2.03.2.13.3.03.4.0 |
3.5.0 |
org.apache.flink:flink-connector-sqlserver-cdcMaven |
3.0.0 up to 3.5.0, plus listed versions 3.1.03.1.13.2.03.2.13.3.03.4.0 |
3.5.0 |
org.apache.flink:flink-connector-mysql-cdcMaven |
3.0.0 up to 3.5.0, plus listed versions 3.1.03.1.13.2.03.2.13.3.03.4.0 |
3.5.0 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2025-62228 is a medium vulnerability (CVSS 5.1) in Apache Flink Cdc, published October 9, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.46%, the 39th percentile. Fixed in org.apache.flink:flink-cdc-pipeline-connectors 3.5.0.
References
lists.apache.org/thread/3dn0hc1wbc5sj0jbgdg33gtnwlw7qrl3
openwall.com/lists/oss-security/2025/10/09/2
nvd.nist.gov/vuln/detail/CVE-2025-62228
github.com/apache/flink-cdc/pull/4123
github.com/apache/flink-cdc/commit/d5766187a9a4b191820e10238d4594ae665cdb89
github.com/advisories/GHSA-wqm3-w3p6-xjgm
github.com/apache/flink-cdc