CVE-2025-62365
LibreNMS vulnerable to Reflected-XSS in `report_this` function
LibreNMS is an open-source, PHP/MySQL/SNMP-based network monitoring system. Prior to 25.7.0, there is a reflected-XSS in report_this function in librenms/includes/functions.php. The report_this function had improper filtering (htmlentities function was incorrectly use in a href environment), which caused the project_issues parameter to trigger an XSS vulnerability. This vulnerability is fixed in 25.7.0.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
5.5
LibreNMS vulnerable to Reflected-XSS in `report_this` function
LibreNMS is an open-source, PHP/MySQL/SNMP-based network monitoring system. Prior to 25.7.0, there is a reflected-XSS in report_this function in librenms/includes/functions.php. The report_this function had improper filtering (htmlentities function was incorrectly use in a href environment), which caused the project_issues parameter to trigger an XSS vulnerability. This vulnerability is fixed in 25.7.0.
- Record
CVE-2025-62365- CVSS 4.0
- 5.5 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:P - Weakness
- CWE-79
- Updated
- 2026-11-02
EUVDEUVD-2025-34114
5.5
LibreNMS is an open-source, PHP/MySQL/SNMP-based network monitoring system. Prior to 25.7.0, there is a reflected-XSS in report_this function in librenms/includes/functions.php. The report_this function had improper filtering (htmlentities function was incorrectly use in a href environment), which caused the project_issues parameter to trigger an XSS vulnerability. This vulnerability is fixed in 25.7.0.
- Record
EUVD-2025-34114- CVSS 4.0
- 5.5 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:P - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-86rg-8hc8-v82p
5.5
LibreNMS is vulnerable to Reflected-XSS in `report_this` function
Summary
Reflected-XSS in report_this function in librenms/includes/functions.php
Details
Recently, it was discovered that the report_this function had improper filtering (htmlentities function was incorrectly used in a href environment), which caused the project_issues parameter to trigger an XSS vulnerability.
The Vulnerable Sink: https://github.com/librenms/librenms/blob/master/includes/functions.php#L444
PoC
GET
project_issues=javascript:alert(document.cookie)
Impact
XSS vulnerabilities allow attackers to execute malicious scripts in users' browsers, enabling unauthorized access to sensitive data, session hijacking, or malware distribution.
Suggestion
It is recommended to filter dangerous protocols, e.g. javascript:/file:.
- Record
GHSA-86rg-8hc8-v82p- CVSS 4.0
- 5.5 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:P - Weakness
- CWE-79
- Updated
- 2026-11-02
NVD
5.5
LibreNMS is an open-source, PHP/MySQL/SNMP-based network monitoring system. Prior to 25.7.0, there is a reflected-XSS in report_this function in librenms/includes/functions.php. The report_this function had improper filtering (htmlentities function was incorrectly use in a href environment), which caused the project_issues parameter to trigger an XSS vulnerability. This vulnerability is fixed in 25.7.0.
- Record
CVE-2025-62365- CVSS 4.0
- 5.5 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:P/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X - CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
5.5
LibreNMS vulnerable to Reflected-XSS in `report_this` function
LibreNMS is an open-source, PHP/MySQL/SNMP-based network monitoring system. Prior to 25.7.0, there is a reflected-XSS in report_this function in librenms/includes/functions.php. The report_this function had improper filtering (htmlentities function was incorrectly use in a href environment), which caused the project_issues parameter to trigger an XSS vulnerability. This vulnerability is fixed in 25.7.0.
- Record
CVE-2025-62365- CVSS 4.0
- 5.5 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:P - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVGHSA-86rg-8hc8-v82p
5.5
LibreNMS is vulnerable to Reflected-XSS in `report_this` function
Summary
Reflected-XSS in report_this function in librenms/includes/functions.php
Details
Recently, it was discovered that the report_this function had improper filtering (htmlentities function was incorrectly used in a href environment), which caused the project_issues parameter to trigger an XSS vulnerability.
The Vulnerable Sink: https://github.com/librenms/librenms/blob/master/includes/functions.php#L444
PoC
GET
project_issues=javascript:alert(document.cookie)
Impact
XSS vulnerabilities allow attackers to execute malicious scripts in users' browsers, enabling unauthorized access to sensitive data, session hijacking, or malware distribution.
Suggestion
It is recommended to filter dangerous protocols, e.g. javascript:/file:.
- Record
GHSA-86rg-8hc8-v82p- CVSS 4.0
- 5.5 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:P - Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
librenms/librenmsPackagist |
through 25.6.0 | 25.7.0 |
librenms/librenmsPackagist |
before 25.7.0, plus listed versions 1.191.201.20.11.211.22 Show 45 moreShow less1.22.011.231.241.251.261.271.281.291.301.30.011.311.31.011.31.021.31.031.321.32.011.331.33.011.341.351.361.36.011.371.381.391.401.411.421.42.011.431.441.451.461.471.481.48.11.491.501.50.11.511.521.531.53.11.541.55 |
25.7.0 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2025-62365 is a medium vulnerability (CVSS 5.5) in Librenms, published October 13, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.25%, the 16th percentile. Fixed in librenms/librenms 25.7.0.
References
github.com/librenms/librenms/security/advisories/GHSA-86rg-8hc8-v82p
github.com/librenms/librenms/commit/30d3dd7e5f5e22a8c23c9db3ad90a731c005b008
nvd.nist.gov/vuln/detail/CVE-2025-62365
github.com/advisories/GHSA-86rg-8hc8-v82p
github.com/CVEProject/cvelistV5/tree/main/cves/2025/62xxx/CVE-2025-62365.json
github.com/librenms/librenms
Left out here: 90 versions. The JSON record has them.