Every CVE Search/ Get API key

CVE-2025-6237

Path Traversal and Arbitrary File Deletion in invoke-ai/invokeai

9.8 CriticalFix available

A vulnerability in invokeai version v6.0.0a1 and below allows attackers to perform path traversal and arbitrary file deletion via the GET /api/v1/images/download/{bulk_download_item_name} endpoint. By manipulating the filename arguments, attackers can read and delete any files on the server, including critical system files such as SSH keys, databases, and configuration files. This vulnerability results in high confidentiality, integrity, and availability impacts.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

0.40%Up 0.3 points since Sep 18, 2025
90%50%10%1%

What each source reports

CVE List Score used 9.8

Path Traversal and Arbitrary File Deletion in invoke-ai/invokeai

A vulnerability in invokeai version v6.0.0a1 and below allows attackers to perform path traversal and arbitrary file deletion via the GET /api/v1/images/download/{bulk_download_item_name} endpoint. By manipulating the filename arguments, attackers can read and delete any files on the server, including critical system files such as SSH keys, databases, and configuration files. This vulnerability results in high confidentiality, integrity, and availability impacts.

Record
CVE-2025-6237
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-73
Updated
2026-11-02
EUVDEUVD-2025-29906 9.8

A vulnerability in invokeai version v6.0.0a1 and below allows attackers to perform path traversal and arbitrary file deletion via the GET /api/v1/images/download/{bulk_download_item_name} endpoint. By manipulating the filename arguments, attackers can read and delete any files on the server, including critical system files such as SSH keys, databases, and configuration files. This vulnerability results in high confidentiality, integrity, and availability impacts.

Record
EUVD-2025-29906
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
GitHub AdvisoriesGHSA-vv9c-xxg7-wmv7 9.3

InvokeAI has External Control of File Name or Path

Path Traversal Vulnerability in InvokeAI

A path traversal vulnerability in InvokeAI (versions < 6.7.0) allows an unauthenticated remote attacker to read files outside the intended media directory via the bulk downloads API.

The endpoint accepts a user-controlled file/item name and concatenates it into a filesystem path without proper canonicalization or allow-listing. By supplying sequences such as ../ (or absolute paths), an attacker can cause the server to traverse directories and return arbitrary files.

In certain storage or back-end configurations, abusing attacker-controlled paths can also lead to unintended overwriting or deletion of files referenced by the crafted path.

The issue is fixed in 6.7.0, which normalizes and validates input paths and rejects traversal attempts.

Affected versions: < 6.7.0 Patched version: 6.7.0

Record
GHSA-vv9c-xxg7-wmv7
CVSS 4.0
9.3 CriticalCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-22, CWE-73
Updated
2026-11-02
NVD 9.8

A vulnerability in invokeai version v6.0.0a1 and below allows attackers to perform path traversal and arbitrary file deletion via the GET /api/v1/images/download/{bulk_download_item_name} endpoint. By manipulating the filename arguments, attackers can read and delete any files on the server, including critical system files such as SSH keys, databases, and configuration files. This vulnerability results in high confidentiality, integrity, and availability impacts.

Record
CVE-2025-6237
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-73
Updated
2026-11-02
OSVGHSA-vv9c-xxg7-wmv7 9.3

InvokeAI has External Control of File Name or Path

Path Traversal Vulnerability in InvokeAI

A path traversal vulnerability in InvokeAI (versions < 6.7.0) allows an unauthenticated remote attacker to read files outside the intended media directory via the bulk downloads API.

The endpoint accepts a user-controlled file/item name and concatenates it into a filesystem path without proper canonicalization or allow-listing. By supplying sequences such as ../ (or absolute paths), an attacker can cause the server to traverse directories and return arbitrary files.

In certain storage or back-end configurations, abusing attacker-controlled paths can also lead to unintended overwriting or deletion of files referenced by the crafted path.

The issue is fixed in 6.7.0, which normalizes and validates input paths and rejects traversal attempts.

Affected versions: < 6.7.0 Patched version: 6.7.0

Record
GHSA-vv9c-xxg7-wmv7
CVSS 4.0
9.3 CriticalCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-22, CWE-73
Updated
2026-11-02
OSVPYSEC-2026-359 9.3

InvokeAI has External Control of File Name or Path

Path Traversal Vulnerability in InvokeAI

A path traversal vulnerability in InvokeAI (versions < 6.7.0) allows an unauthenticated remote attacker to read files outside the intended media directory via the bulk downloads API.

The endpoint accepts a user-controlled file/item name and concatenates it into a filesystem path without proper canonicalization or allow-listing. By supplying sequences such as ../ (or absolute paths), an attacker can cause the server to traverse directories and return arbitrary files.

In certain storage or back-end configurations, abusing attacker-controlled paths can also lead to unintended overwriting or deletion of files referenced by the crafted path.

The issue is fixed in 6.7.0, which normalizes and validates input paths and rejects traversal attempts.

Affected versions: < 6.7.0 Patched version: 6.7.0

Record
PYSEC-2026-359
CVSS 4.0
9.3 CriticalCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
invokeai
PyPI
before 6.7.0
6.7.0
invokeai
PyPI
before 6.7.0, plus listed versions
2.2.4.52.2.4.62.2.4.72.2.52.3.0
Show 45 moreShow less
2.3.0a02.3.0a12.3.0a22.3.0a32.3.0rc32.3.0rc42.3.0rc52.3.0rc62.3.0rc72.3.12.3.1.post12.3.1.post22.3.1rc42.3.22.3.2.post12.3.32.3.3rc12.3.42.3.4.post12.3.4a02.3.4rc12.3.52.3.5.post12.3.5.post22.3.5rc13.0.03.0.13.0.1.post13.0.1.post23.0.1.post33.0.1rc13.0.1rc23.0.23.0.2.post13.0.2a13.0.2rc13.1.03.1.13.1.1rc13.2.03.3.03.3.0.post13.3.0.post23.3.0.post33.4.0
6.7.0

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2025-6237 is a critical vulnerability (CVSS 9.8) in Invoke-ai Invoke-ai/invokeai, published September 18, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.40%, the 34th percentile. Fixed in invokeai 6.7.0.

References

This page doesn't list everything

Left out here: 192 versions. The JSON record has them.

MoveEnter Open