Every CVE Search/ Get API key

CVE-2025-62396

Moodle: router (r.php) could expose application directories

5.3 MediumFix available

An error-handling issue in the Moodle router (r.php) could cause the application to display internal directory listings when specific HTTP headers were not properly configured.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
Low
Integrity
None
Availability
None

Exploit likelihood

0.30%Up 0.3 points since Oct 23, 2025
90%50%10%1%

What each source reports

CVE List Score used 5.3

Moodle: router (r.php) could expose application directories

An error-handling issue in the Moodle router (r.php) could cause the application to display internal directory listings when specific HTTP headers were not properly configured.

Record
CVE-2025-62396
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Weakness
CWE-548
Updated
2026-11-02
EUVDEUVD-2025-35671 5.3

An error-handling issue in the Moodle router (r.php) could cause the application to display internal directory listings when specific HTTP headers were not properly configured.

Record
EUVD-2025-35671
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Updated
2026-11-02
GitHub AdvisoriesGHSA-c5cj-xp43-qcc3 5.3

Moodle's error handling leads to sensitive information disclosure

An error-handling issue in the Moodle router (r.php) could cause the application to display internal directory listings when specific HTTP headers were not properly configured.

Record
GHSA-c5cj-xp43-qcc3
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Weakness
CWE-548
Updated
2026-11-02
NVD 5.3

An error-handling issue in the Moodle router (r.php) could cause the application to display internal directory listings when specific HTTP headers were not properly configured.

Record
CVE-2025-62396
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Weakness
CWE-548
Updated
2026-11-02
OSV 5.3

Moodle: router (r.php) could expose application directories

An error-handling issue in the Moodle router (r.php) could cause the application to display internal directory listings when specific HTTP headers were not properly configured.

Record
CVE-2025-62396
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Weakness
CWE-548
Updated
2026-11-02
OSVGHSA-c5cj-xp43-qcc3 5.3

Moodle's error handling leads to sensitive information disclosure

An error-handling issue in the Moodle router (r.php) could cause the application to display internal directory listings when specific HTTP headers were not properly configured.

Record
GHSA-c5cj-xp43-qcc3
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Weakness
CWE-548
Updated
2026-11-02
OSVUBUNTU-CVE-2025-62396 5.3

An error-handling issue in the Moodle router (r.php) could cause the application to display internal directory listings when specific HTTP headers were not properly configured.

Record
UBUNTU-CVE-2025-62396
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Updated
2026-11-02
OSVBIT-moodle-2025-62396 No score

Moodle: router (r.php) could expose application directories

An error-handling issue in the Moodle router (r.php) could cause the application to display internal directory listings when specific HTTP headers were not properly configured.

Record
BIT-moodle-2025-62396
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
moodle/moodle
Packagist
5.0.0-beta up to 5.0.3
5.0.3
moodle/moodle
Packagist
4.5.0-beta up to 4.5.7
4.5.7
moodle
Bitnami
4.5.0 up to 4.5.7, 5.0.0 up to 5.0.3
4.5.75.0.3
moodle/moodle
Packagist
5.0.0-beta up to 5.0.3, plus listed versions
v5.0.0v5.0.0-betav5.0.0-rc1v5.0.0-rc2v5.0.0-rc3v5.0.1v5.0.2
5.0.3
moodle/moodle
Packagist
4.5.0-beta up to 4.5.7, plus listed versions
v4.5.0v4.5.0-betav4.5.0-rc1v4.5.0-rc2v4.5.1
Show 5 moreShow less
v4.5.2v4.5.3v4.5.4v4.5.5v4.5.6
4.5.7
moodle
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
2.7.9+dfsg-12.7.10+dfsg-12.7.11+dfsg-12.7.11+dfsg-22.7.12+dfsg-13.0.3+dfsg-0ubuntu13.0.3+dfsg-0ubuntu1+esm1
None known
moodle
Ubuntu:Pro:18.04:LTS
All versions, plus listed versions
3.0.3+dfsg-0ubuntu13.0.3+dfsg-0ubuntu1+esm1
None known

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2025-62396 is a medium vulnerability (CVSS 5.3) in Moodle, published October 23, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.30%, the 22nd percentile. Fixed in moodle/moodle 5.0.3.

References

Show 6 moreShow less
MoveEnter Open