CVE-2025-62399
Moodle: password brute force risk when mobile/web services enabled
Moodle’s mobile and web service authentication endpoints did not sufficiently restrict repeated password attempts, making them susceptible to brute-force attacks.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
7.5
Moodle: password brute force risk when mobile/web services enabled
Moodle’s mobile and web service authentication endpoints did not sufficiently restrict repeated password attempts, making them susceptible to brute-force attacks.
- Record
CVE-2025-62399- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-307
- Updated
- 2026-11-02
EUVDEUVD-2025-35668
7.5
Moodle’s mobile and web service authentication endpoints did not sufficiently restrict repeated password attempts, making them susceptible to brute-force attacks.
- Record
EUVD-2025-35668- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-m58f-9pvv-8mp2
7.5
Moodle vulnerable to brute-force password guesses
Moodle's mobile and web service authentication endpoints did not sufficiently restrict repeated password attempts, making them susceptible to brute-force attacks.
- Record
GHSA-m58f-9pvv-8mp2- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-307
- Updated
- 2026-11-02
NVD
7.5
Moodle’s mobile and web service authentication endpoints did not sufficiently restrict repeated password attempts, making them susceptible to brute-force attacks.
- Record
CVE-2025-62399- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-307
- Updated
- 2026-11-02
OSV
7.5
Moodle: password brute force risk when mobile/web services enabled
Moodle’s mobile and web service authentication endpoints did not sufficiently restrict repeated password attempts, making them susceptible to brute-force attacks.
- Record
CVE-2025-62399- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-307
- Updated
- 2026-11-02
OSVGHSA-m58f-9pvv-8mp2
7.5
Moodle vulnerable to brute-force password guesses
Moodle's mobile and web service authentication endpoints did not sufficiently restrict repeated password attempts, making them susceptible to brute-force attacks.
- Record
GHSA-m58f-9pvv-8mp2- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-307
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2025-62399
7.5
Moodle’s mobile and web service authentication endpoints did not sufficiently restrict repeated password attempts, making them susceptible to brute-force attacks.
- Record
UBUNTU-CVE-2025-62399- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVBIT-moodle-2025-62399 No score
Moodle: password brute force risk when mobile/web services enabled
Moodle’s mobile and web service authentication endpoints did not sufficiently restrict repeated password attempts, making them susceptible to brute-force attacks.
- Record
BIT-moodle-2025-62399- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
moodle/moodlePackagist |
5.0.0-beta up to 5.0.3 | 5.0.3 |
moodle/moodlePackagist |
4.5.0-beta up to 4.5.7 | 4.5.7 |
moodle/moodlePackagist |
4.2.0-beta up to 4.4.11 | 4.4.11 |
moodle/moodlePackagist |
before 4.1.21 | 4.1.21 |
moodleBitnami |
4.1.0 up to 4.1.21, 4.4.0 up to 4.4.11, 4.5.0 up to 4.5.7, 5.0.0 up to 5.0.3 | 4.1.214.4.114.5.75.0.3 |
moodle/moodlePackagist |
5.0.0-beta up to 5.0.3, plus listed versions v5.0.0v5.0.0-betav5.0.0-rc1v5.0.0-rc2v5.0.0-rc3v5.0.1v5.0.2 |
5.0.3 |
moodle/moodlePackagist |
4.5.0-beta up to 4.5.7, plus listed versions v4.5.0v4.5.0-betav4.5.0-rc1v4.5.0-rc2v4.5.1 Show 5 moreShow lessv4.5.2v4.5.3v4.5.4v4.5.5v4.5.6 |
4.5.7 |
moodle/moodlePackagist |
4.2.0-beta up to 4.4.11, plus listed versions v4.2.0v4.2.0-betav4.2.0-rc1v4.2.0-rc2v4.2.1 Show 40 moreShow lessv4.2.10v4.2.11v4.2.2v4.2.3v4.2.4v4.2.5v4.2.6v4.2.7v4.2.8v4.2.9v4.3.0v4.3.0-betav4.3.0-rc1v4.3.0-rc2v4.3.1v4.3.10v4.3.11v4.3.12v4.3.2v4.3.3v4.3.4v4.3.5v4.3.6v4.3.7v4.3.8v4.3.9v4.4.0v4.4.0-betav4.4.0-rc1v4.4.0-rc2v4.4.1v4.4.10v4.4.2v4.4.3v4.4.4v4.4.5v4.4.6v4.4.7v4.4.8v4.4.9 |
4.4.11 |
moodle/moodlePackagist |
before 4.1.21, plus listed versions v2.3.10v2.3.11v2.3.4v2.3.5v2.3.6 Show 45 moreShow lessv2.3.7v2.3.8v2.3.9v2.4.0v2.4.0-rc1v2.4.1v2.4.10v2.4.11v2.4.2v2.4.3v2.4.4v2.4.5v2.4.6v2.4.7v2.4.8v2.4.9v2.5.0v2.5.0-betav2.5.0-rc1v2.5.1v2.5.2v2.5.3v2.5.4v2.5.5v2.5.6v2.5.7v2.5.8v2.5.9v2.6.0v2.6.0-betav2.6.0-rc1v2.6.1v2.6.10v2.6.11v2.6.2v2.6.3v2.6.4v2.6.5v2.6.6v2.6.7v2.6.8v2.6.9v2.7.0v2.7.0-betav2.7.0-rc1 |
4.1.21 |
moodleUbuntu:Pro:16.04:LTS |
All versions, plus listed versions 2.7.9+dfsg-12.7.10+dfsg-12.7.11+dfsg-12.7.11+dfsg-22.7.12+dfsg-13.0.3+dfsg-0ubuntu13.0.3+dfsg-0ubuntu1+esm1 |
None known |
moodleUbuntu:Pro:18.04:LTS |
All versions, plus listed versions 3.0.3+dfsg-0ubuntu13.0.3+dfsg-0ubuntu1+esm1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2025-62399 is a high vulnerability (CVSS 7.5) in Moodle, published October 23, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.40%, the 34th percentile. Fixed in moodle/moodle 5.0.3.
References
Left out here: 303 versions. The JSON record has them.