Every CVE Search/ Get API key

CVE-2025-63499

Alinto Sogo 5.12.3 is vulnerable to Cross Site Scripting (XSS) via the theme parameter.

6.1 MediumPublic exploitFix available

Alinto Sogo 5.12.3 is vulnerable to Cross Site Scripting (XSS) via the theme parameter.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

0.32%Up 0.3 points since Dec 5, 2025
90%50%10%1%

What each source reports

CVE List Score used 6.1

Alinto Sogo 5.12.3 is vulnerable to Cross Site Scripting (XSS) via the theme parameter.

Record
CVE-2025-63499
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
EUVDEUVD-2025-201283 6.1

Alinto Sogo 5.12.3 is vulnerable to Cross Site Scripting (XSS) via the theme parameter.

Record
EUVD-2025-201283
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
GitHub AdvisoriesGHSA-mrxw-g8fq-xg2c 6.1

Alinto Sogo 5.12.3 is vulnerable to Cross Site Scripting (XSS) via the theme parameter.

Alinto Sogo 5.12.3 is vulnerable to Cross Site Scripting (XSS) via the theme parameter.

Record
GHSA-mrxw-g8fq-xg2c
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
NVD 6.1

Alinto Sogo 5.12.3 is vulnerable to Cross Site Scripting (XSS) via the theme parameter.

Record
CVE-2025-63499
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSV 6.1

Alinto Sogo 5.12.3 is vulnerable to Cross Site Scripting (XSS) via the theme parameter.

Record
CVE-2025-63499
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVDEBIAN-CVE-2025-63499 6.1

Alinto Sogo 5.12.3 is vulnerable to Cross Site Scripting (XSS) via the theme parameter.

Record
DEBIAN-CVE-2025-63499
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVUBUNTU-CVE-2025-63499 6.1

Alinto Sogo 5.12.3 is vulnerable to Cross Site Scripting (XSS) via the theme parameter.

Record
UBUNTU-CVE-2025-63499
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVUSN-8504-1 No score

sogo vulnerabilities

It was discovered that SOGo did not properly sanitize categories used for events, tasks, and contacts. A remote authenticated attacker could possibly use this issue to perform cross-site scripting attacks. This issue only affected Ubuntu 18.04 LTS, Ubuntu 20.04 LTS, Ubuntu 22.04 LTS, and Ubuntu 26.04 LTS. (CVE-2025-71276)

It was discovered that SOGo did not properly sanitize the hint query parameter. A remote attacker could possibly use this issue to perform cross-site scripting attacks. This issue only affected Ubuntu 26.04 LTS. (CVE-2026-3054)

It was discovered that SOGo did not renew the one-time password when a user disabled and re-enabled it, and used a shorter length than recommended. A remote attacker could possibly use this issue to bypass authentication. This issue only affected Ubuntu 22.04 LTS and Ubuntu 26.04 LTS. (CVE-2026-33550)

It was discovered that SOGo did not properly use the SQL adaptor for the user source, resulting in SQL injection when certain databases were used. A remote authenticated attacker could possibly use this issue to obtain sensitive information or execute arbitrary SQL commands. (CVE-2026-46445, CVE-2026-46446)

It was discovered that SOGo did not properly sanitize mail containing ICS calendar invitations. A remote attacker could possibly use this issue to perform cross-site scripting attacks. This issue only affected Ubuntu 26.04 LTS. (CVE-2026-8496)

It was discovered that SOGo did not properly validate identifiers when managing access control lists. A remote authenticated attacker could possibly use this issue to perform SQL injection attacks and obtain sensitive information. (CVE-2026-8851)

It was discovered that SOGo did not properly sanitize the theme parameter. A remote attacker could possibly use this issue to perform cross-site scripting attacks. This issue only affected Ubuntu 18.04 LTS, Ubuntu 20.04 LTS, and Ubuntu 22.04 LTS. (CVE-2025-63499)

It was discovered that SOGo did not properly sanitize the userName parameter on the login page. A remote attacker could possibly use this issue to perform cross-site scripting attacks. This issue only affected Ubuntu 16.04 LTS, Ubuntu 18.04 LTS, Ubuntu 20.04 LTS, and Ubuntu 22.04 LTS. (CVE-2025-63498)

It was discovered that SOGo did not properly sanitize attachments when previewing them. A remote attacker could possibly use this issue to perform cross-site scripting attacks. This issue only affected Ubuntu 16.04 LTS, Ubuntu 18.04 LTS, Ubuntu 20.04 LTS, and Ubuntu 22.04 LTS. (CVE-2024-34462)

It was discovered that SOGo did not validate the signatures of SAML assertions it received when SAML was used for authentication. A remote attacker could possibly use this issue to impersonate other users. This issue only affected Ubuntu 16.04 LTS, Ubuntu 18.04 LTS, and Ubuntu 20.04 LTS. (CVE-2021-33054)

Record
USN-8504-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
sogo
Debian:12
before 5.8.0-2+deb12u1, plus listed versions
5.8.0-1
5.8.0-2+deb12u1
sogo
Debian:13
before 5.12.1-3+deb13u1, plus listed versions
5.12.1-3
5.12.1-3+deb13u1
sogo
Debian:11
From an advisory covering 2 CVEs
before 5.0.1-4+deb11u3, plus listed versions
5.0.1-45.0.1-4+deb11u15.0.1-4+deb11u2
5.0.1-4+deb11u3
sogo
Ubuntu:Pro:18.04:LTS
before 3.2.10-1ubuntu0.1~esm1, plus listed versions
3.2.10-13.2.10-1build1
3.2.10-1ubuntu0.1~esm1
sogo
Ubuntu:Pro:20.04:LTS
before 4.3.0-1ubuntu0.1~esm1, plus listed versions
4.0.8-14.1.0-14.1.1-14.3.0-1
4.3.0-1ubuntu0.1~esm1
sogo
Ubuntu:Pro:22.04:LTS
before 5.5.1-1ubuntu0.1~esm1, plus listed versions
5.1.0-15.2.0-15.2.0-35.3.0-15.3.0-1build25.4.0-15.5.0-15.5.1-1
5.5.1-1ubuntu0.1~esm1
sogo
Ubuntu:25.10
All versions, plus listed versions
5.11.2-45.12.1-15.12.1-1build25.12.1-25.12.1-3
None known
sogo
Ubuntu:Pro:16.04:LTS
From an advisory covering 11 CVEs
before 2.2.17a-1.1ubuntu0.1~esm1, plus listed versions
2.2.17a-12.2.17a-1.12.2.17a-1.1build1
2.2.17a-1.1ubuntu0.1~esm1
sogo
Ubuntu:Pro:18.04:LTS
From an advisory covering 11 CVEs
before 3.2.10-1ubuntu0.1~esm1, plus listed versions
3.2.10-13.2.10-1build1
3.2.10-1ubuntu0.1~esm1
sogo
Ubuntu:Pro:20.04:LTS
From an advisory covering 11 CVEs
before 4.3.0-1ubuntu0.1~esm1, plus listed versions
4.0.8-14.1.0-14.1.1-14.3.0-1
4.3.0-1ubuntu0.1~esm1
sogo
Ubuntu:Pro:22.04:LTS
From an advisory covering 11 CVEs
before 5.5.1-1ubuntu0.1~esm1, plus listed versions
5.1.0-15.2.0-15.2.0-35.3.0-15.3.0-1build25.4.0-15.5.0-15.5.1-1
5.5.1-1ubuntu0.1~esm1
sogo
Ubuntu:Pro:26.04:LTS
From an advisory covering 11 CVEs
before 5.12.4-1.2ubuntu0.1~esm1, plus listed versions
5.12.1-35.12.4-15.12.4-1.15.12.4-1.2
5.12.4-1.2ubuntu0.1~esm1

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
PoC in GitHubpoblaguev-tot/CVE-2025-634992025-12-02

History

History
RecordedChangedSources
affected, facts
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV, PoC in GitHub

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2025-63499 is a medium vulnerability (CVSS 6.1) in Alinto Sogo, published December 4, 2025. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 0.32%, the 24th percentile. Fixed in sogo 5.8.0-2+deb12u1.

References

Show 14 moreShow less
MoveEnter Open