CVE-2025-63913
An issue was discovered in OpenSBI 1.3 allowing attackers to cause a denial of service via...
An issue was discovered in OpenSBI 1.3 allowing attackers to cause a denial of service via crafted request to the SBI function #2 or the 'Find and configure a matching counter' function of SBI PMU extension.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
7.5
An issue was discovered in OpenSBI 1.3 allowing attackers to cause a denial of service via crafted request to the SBI function #2 or the 'Find and configure a matching counter' function of SBI PMU extension.
- Record
CVE-2025-63913- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-400
- Updated
- 2026-11-02
EUVDEUVD-2025-210523
7.5
An issue was discovered in OpenSBI 1.3 allowing attackers to cause a denial of service via crafted request to the SBI function #2 or the 'Find and configure a matching counter' function of SBI PMU extension.
- Record
EUVD-2025-210523- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-2rpc-x25h-pv3j
7.5
An issue was discovered in OpenSBI 1.3 allowing attackers to cause a denial of service via...
An issue was discovered in OpenSBI 1.3 allowing attackers to cause a denial of service via crafted request to the SBI function #2 or the 'Find and configure a matching counter' function of SBI PMU extension.
- Record
GHSA-2rpc-x25h-pv3j- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-400
- Updated
- 2026-11-02
NVD
7.5
An issue was discovered in OpenSBI 1.3 allowing attackers to cause a denial of service via crafted request to the SBI function #2 or the 'Find and configure a matching counter' function of SBI PMU extension.
- Record
CVE-2025-63913- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-400
- Updated
- 2026-11-02
OSVDEBIAN-CVE-2025-63913
7.5
An issue was discovered in OpenSBI 1.3 allowing attackers to cause a denial of service via crafted request to the SBI function #2 or the 'Find and configure a matching counter' function of SBI PMU extension.
- Record
DEBIAN-CVE-2025-63913- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2025-63913
7.5
An issue was discovered in OpenSBI 1.3 allowing attackers to cause a denial of service via crafted request to the SBI function #2 or the 'Find and configure a matching counter' function of SBI PMU extension.
- Record
UBUNTU-CVE-2025-63913- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVAZL-94302 No score
CVE-2025-63913 affecting package qemu for versions less than 0.0.0-0
An issue was discovered in OpenSBI 1.3 allowing attackers to cause a denial of service via crafted request to the SBI function #2 or the 'Find and configure a matching counter' function of SBI PMU extension.
- Record
AZL-94302- Updated
- 2026-11-05
OSVUSN-8853-1 No score
opensbi vulnerability
It was discovered that OpenSBI did not properly validate the counter index mask in SBI PMU extension requests. An attacker could use this issue to cause a denial of service.
- Record
USN-8853-1- Updated
- 2026-11-02
Affected packages
| Package | Affected | Fixed |
|---|---|---|
qemuAzure Linux:3 |
before 0.0.0-0 | 0.0.0-0 |
opensbiDebian:12 |
All versions, plus listed versions 1.1-21.2-11.3-11.3.1-11.4-1 Show 8 moreShow less1.5-11.5.1-11.5.1-1~bpo12+11.5.1-1~bpo12+21.6-11.7-11.8.1-11.9-1 |
None known |
opensbiDebian:13 |
All versions, plus listed versions 1.6-11.7-11.8.1-11.9-1 |
None known |
opensbiDebian:14 |
before 1.7-1, plus listed versions 1.6-1 |
1.7-1 |
opensbiUbuntu:22.04:LTS |
before 1.3-1ubuntu0.22.04.3, plus listed versions 0.9-2ubuntu20.9+160.723aa88ff4-0ubuntu10.9+187.52af6e4b52-0ubuntu11.0-11.0-3ubuntu11.1-0ubuntu0.22.04.11.3-1ubuntu0.22.04.11.3-1ubuntu0.22.04.2 |
1.3-1ubuntu0.22.04.3 |
History
| Recorded | Changed | Sources |
|---|---|---|
| facts | OSV | |
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2025-63913 is a high vulnerability (CVSS 7.5) in opensbi, published July 27, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.46%, the 40th percentile. Fixed in qemu 0.0.0-0.