CVE-2025-64408
Apache Causeway: Java deserialization vulnerability to authenticated attackers
Apache Causeway faces Java deserialization vulnerabilities that allow remote code execution (RCE) through user-controllable URL parameters. These vulnerabilities affect all applications using Causeway's ViewModel functionality and can be exploited by authenticated attackers to execute arbitrary code with application privileges.
This issue affects all current versions.
Users are recommended to upgrade to version 3.5.0, which fixes the issue.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- Low
Exploit likelihood
What each source reports
CVE List Score used
6.3
Apache Causeway: Java deserialization vulnerability to authenticated attackers
Apache Causeway faces Java deserialization vulnerabilities that allow remote code execution (RCE) through user-controllable URL parameters. These vulnerabilities affect all applications using Causeway's ViewModel functionality and can be exploited by authenticated attackers to execute arbitrary code with application privileges.
This issue affects all current versions.
Users are recommended to upgrade to version 3.5.0, which fixes the issue.
- Record
CVE-2025-64408- CVSS 3.1
- 6.3 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L - Weakness
- CWE-502
- Updated
- 2026-11-03
EUVDEUVD-2025-198152
6.3
Apache Causeway faces Java deserialization vulnerabilities that allow remote code execution (RCE) through user-controllable URL parameters. These vulnerabilities affect all applications using Causeway's ViewModel functionality and can be exploited by authenticated attackers to execute arbitrary code with application privileges.
This issue affects all current versions.
Users are recommended to upgrade to version 3.5.0, which fixes the issue.
- Record
EUVD-2025-198152- CVSS 3.1
- 6.3 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-wq4c-57mh-5f7g
9.3
Apache Causeway vulnerable to deserialization in Java
Apache Causeway faces Java deserialization vulnerabilities that allow remote code execution (RCE) through user-controllable URL parameters. These vulnerabilities affect all applications using Causeway's ViewModel functionality and can be exploited by authenticated attackers to execute arbitrary code with application privileges.
This issue affects all current versions.
Users are recommended to upgrade to version 3.5.0, which fixes the issue.
- Record
GHSA-wq4c-57mh-5f7g- CVSS 4.0
- 9.3 Critical
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N - CVSS 3.1
- 6.3 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L - Weakness
- CWE-502
- Updated
- 2026-11-02
NVD
6.3
Apache Causeway faces Java deserialization vulnerabilities that allow remote code execution (RCE) through user-controllable URL parameters. These vulnerabilities affect all applications using Causeway's ViewModel functionality and can be exploited by authenticated attackers to execute arbitrary code with application privileges.
This issue affects all current versions.
Users are recommended to upgrade to version 3.5.0, which fixes the issue.
- Record
CVE-2025-64408- CVSS 3.1
- 6.3 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L - Weakness
- CWE-502
- Updated
- 2026-11-02
OSV
6.3
Apache Causeway: Java deserialization vulnerability to authenticated attackers
Apache Causeway faces Java deserialization vulnerabilities that allow remote code execution (RCE) through user-controllable URL parameters. These vulnerabilities affect all applications using Causeway's ViewModel functionality and can be exploited by authenticated attackers to execute arbitrary code with application privileges.
This issue affects all current versions.
Users are recommended to upgrade to version 3.5.0, which fixes the issue.
- Record
CVE-2025-64408- CVSS 3.1
- 6.3 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L - Weakness
- CWE-502
- Updated
- 2026-11-04
OSVGHSA-wq4c-57mh-5f7g
9.3
Apache Causeway vulnerable to deserialization in Java
Apache Causeway faces Java deserialization vulnerabilities that allow remote code execution (RCE) through user-controllable URL parameters. These vulnerabilities affect all applications using Causeway's ViewModel functionality and can be exploited by authenticated attackers to execute arbitrary code with application privileges.
This issue affects all current versions.
Users are recommended to upgrade to version 3.5.0, which fixes the issue.
- Record
GHSA-wq4c-57mh-5f7g- CVSS 4.0
- 9.3 Critical
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N - CVSS 3.1
- 6.3 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L - Weakness
- CWE-502
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
org.apache.causeway.commons:causeway-commonsMaven |
before 3.5.0 | 3.5.0 |
org.apache.causeway.core:causeway-applibMaven |
before 3.5.0 | 3.5.0 |
org.apache.causeway.core:causeway-coreMaven |
before 3.5.0 | 3.5.0 |
org.apache.causeway.viewer:causeway-viewer-wicketMaven |
before 3.5.0 | 3.5.0 |
org.apache.causeway.commons:causeway-commonsMaven |
before 3.5.0, plus listed versions 2.0.02.0.0-RC12.0.0-RC22.0.0-RC32.0.0-RC4 Show 6 moreShow less2.1.03.0.03.1.03.2.03.3.03.4.0 |
3.5.0 |
org.apache.causeway.core:causeway-applibMaven |
before 3.5.0, plus listed versions 2.0.02.0.0-RC12.0.0-RC22.0.0-RC32.0.0-RC4 Show 6 moreShow less2.1.03.0.03.1.03.2.03.3.03.4.0 |
3.5.0 |
org.apache.causeway.core:causeway-coreMaven |
before 3.5.0, plus listed versions 2.0.02.0.0-RC12.0.0-RC22.0.0-RC32.0.0-RC4 Show 6 moreShow less2.1.03.0.03.1.03.2.03.3.03.4.0 |
3.5.0 |
org.apache.causeway.viewer:causeway-viewer-wicketMaven |
before 3.5.0, plus listed versions 2.0.02.0.0-RC12.0.0-RC22.0.0-RC32.0.0-RC4 Show 6 moreShow less2.1.03.0.03.1.03.2.03.3.03.4.0 |
3.5.0 |
History
| Recorded | Changed | Sources |
|---|---|---|
| facts | CVE List, EUVD | |
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2025-64408 is a medium vulnerability (CVSS 6.3) in Apache Causeway, published November 19, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 11.6%, the 96th percentile. Fixed in org.apache.causeway.commons:causeway-commons 3.5.0.
References
lists.apache.org/thread/rjlg4spqhmgy1xgq9wq5h2tfnq4pm70b
openwall.com/lists/oss-security/2025/11/19/1
nvd.nist.gov/vuln/detail/CVE-2025-64408
github.com/apache/causeway/commit/bef00f58d2a2cba9a45230c9d117a0327e4c7038
github.com/apache/causeway/commit/e66290fe9be87aa0e4c5dc55bce1993a54330624
github.com/apache/causeway/commit/e6bf00c63c33cfa894a19d6122526a1aec227d14