CVE-2025-64775
Apache Struts: File leak in multipart request processing causes disk exhaustion (DoS)
Denial of Service vulnerability in Apache Struts, file leak in multipart request processing causes disk exhaustion.
This issue affects Apache Struts: from 2.0.0 through 6.7.0, from 7.0.0 through 7.0.3.
Users are recommended to upgrade to version 6.8.0 or 7.1.1, which fixes the issue.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
7.5
Apache Struts: File leak in multipart request processing causes disk exhaustion (DoS)
Denial of Service vulnerability in Apache Struts, file leak in multipart request processing causes disk exhaustion.
This issue affects Apache Struts: from 2.0.0 through 6.7.0, from 7.0.0 through 7.0.3.
Users are recommended to upgrade to version 6.8.0 or 7.1.1, which fixes the issue.
- Record
CVE-2025-64775- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-459
- Updated
- 2026-11-02
EUVDEUVD-2025-200019
7.5
Denial of Service vulnerability in Apache Struts, file leak in multipart request processing causes disk exhaustion.
This issue affects Apache Struts: from 2.0.0 through 6.7.0, from 7.0.0 through 7.0.3.
Users are recommended to upgrade to version 6.8.0 or 7.1.1, which fixes the issue.
- Record
EUVD-2025-200019- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-xx7v-hqxh-cjr9
7.5
Apache Struts is Vulnerable to DoS via File Leak
Denial of Service vulnerability in Apache Struts, file leak in multipart request processing causes disk exhaustion.
This issue affects Apache Struts: from 2.0.0 through 6.7.0, from 7.0.0 through 7.0.3.
Users are recommended to upgrade to version 6.8.0 or 7.1.1, which fixes the issue.
- Record
GHSA-xx7v-hqxh-cjr9- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-459
- Updated
- 2026-11-02
NVD
7.5
Denial of Service vulnerability in Apache Struts, file leak in multipart request processing causes disk exhaustion.
This issue affects Apache Struts: from 2.0.0 through 6.7.0, from 7.0.0 through 7.0.3.
Users are recommended to upgrade to version 6.8.0 or 7.1.1, which fixes the issue.
- Record
CVE-2025-64775- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-459
- Updated
- 2026-11-02
OSV
7.5
Apache Struts: File leak in multipart request processing causes disk exhaustion (DoS)
Denial of Service vulnerability in Apache Struts, file leak in multipart request processing causes disk exhaustion.
This issue affects Apache Struts: from 2.0.0 through 6.7.0, from 7.0.0 through 7.0.3.
Users are recommended to upgrade to version 6.8.0 or 7.1.1, which fixes the issue.
- Record
CVE-2025-64775- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-459
- Updated
- 2026-11-02
OSVGHSA-xx7v-hqxh-cjr9
7.5
Apache Struts is Vulnerable to DoS via File Leak
Denial of Service vulnerability in Apache Struts, file leak in multipart request processing causes disk exhaustion.
This issue affects Apache Struts: from 2.0.0 through 6.7.0, from 7.0.0 through 7.0.3.
Users are recommended to upgrade to version 6.8.0 or 7.1.1, which fixes the issue.
- Record
GHSA-xx7v-hqxh-cjr9- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-459
- Updated
- 2026-11-02
OSVCLSA-2026-1782781173 No score
TuxCare security update for org.apache.struts:struts2-core (3 CVEs)
TuxCare rebuilt org.apache.struts:struts2-core to address 3 CVEs. Fixed in 2.5.33-tuxcare.2.
- Record
CLSA-2026-1782781173- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
org.apache.struts:struts2-coreMaven |
6.0.0 up to 6.8.0 | 6.8.0 |
org.apache.struts:struts2-coreMaven |
7.0.0 up to 7.1.1 | 7.1.1 |
org.apache.struts:struts2-coreMaven |
2.0.0 to 2.3.37 | None known |
org.apache.struts:struts2-coreMaven |
2.5.0 to 2.5.33 | None known |
org.apache.struts:struts2-coreTuxCare:Maven From an advisory covering 3 CVEs |
2.5.33 up to 2.5.33-tuxcare.2, plus listed versions 2.5.33-tuxcare.1 |
2.5.33-tuxcare.2 |
org.apache.struts:struts2-coreMaven |
6.0.0 up to 6.8.0, plus listed versions 6.0.36.1.16.1.26.1.2.16.1.2.2 Show 9 moreShow less6.2.06.3.06.3.0.16.3.0.26.4.06.6.06.6.16.7.06.7.4 |
6.8.0 |
org.apache.struts:struts2-coreMaven |
7.0.0 up to 7.1.1, plus listed versions 7.0.3 |
7.1.1 |
org.apache.struts:struts2-coreMaven |
2.0.0 to 2.3.37, plus listed versions 2.0.112.0.11.12.0.11.22.0.122.0.14 Show 45 moreShow less2.0.52.0.62.0.82.0.92.1.22.1.62.1.82.1.8.12.2.12.2.1.12.2.32.2.3.12.3.12.3.1.12.3.1.22.3.122.3.142.3.14.12.3.14.22.3.14.32.3.152.3.15.12.3.15.22.3.15.32.3.162.3.16.12.3.16.22.3.16.32.3.202.3.20.12.3.20.32.3.242.3.24.12.3.24.32.3.282.3.28.12.3.292.3.32.3.302.3.312.3.322.3.332.3.342.3.352.3.36 |
None known |
org.apache.struts:struts2-coreMaven |
2.5.0 to 2.5.33, plus listed versions 2.52.5.12.5.102.5.10.12.5.12 Show 22 moreShow less2.5.132.5.142.5.14.12.5.162.5.172.5.182.5.22.5.202.5.222.5.252.5.262.5.272.5.282.5.28.12.5.28.22.5.28.32.5.292.5.302.5.312.5.322.5.52.5.8 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2025-64775 is a high vulnerability (CVSS 7.5) in Apache Struts, published December 1, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.53%, the 74th percentile. Fixed in org.apache.struts:struts2-core 6.8.0.
References
Left out here: 4 versions. The JSON record has them.