CVE-2025-65409
A divide-by-zero in the encryption/decryption routines of GNU Recutils v1.9 allows attackers to...
A divide-by-zero in the encryption/decryption routines of GNU Recutils v1.9 allows attackers to cause a Denial of Service (DoS) via inputting an empty value as a password.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
7.5
A divide-by-zero in the encryption/decryption routines of GNU Recutils v1.9 allows attackers to cause a Denial of Service (DoS) via inputting an empty value as a password.
- Record
CVE-2025-65409- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-369
- Updated
- 2026-11-02
EUVDEUVD-2025-205832
7.5
A divide-by-zero in the encryption/decryption routines of GNU Recutils v1.9 allows attackers to cause a Denial of Service (DoS) via inputting an empty value as a password.
- Record
EUVD-2025-205832- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-f643-8m38-xc64
7.5
A divide-by-zero in the encryption/decryption routines of GNU Recutils v1.9 allows attackers to...
A divide-by-zero in the encryption/decryption routines of GNU Recutils v1.9 allows attackers to cause a Denial of Service (DoS) via inputting an empty value as a password.
- Record
GHSA-f643-8m38-xc64- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-369
- Updated
- 2026-11-02
NVD
7.5
A divide-by-zero in the encryption/decryption routines of GNU Recutils v1.9 allows attackers to cause a Denial of Service (DoS) via inputting an empty value as a password.
- Record
CVE-2025-65409- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-369
- Updated
- 2026-11-02
OSV
7.5
A divide-by-zero in the encryption/decryption routines of GNU Recutils v1.9 allows attackers to cause a Denial of Service (DoS) via inputting an empty value as a password.
- Record
CVE-2025-65409- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2025-65409
7.5
A divide-by-zero in the encryption/decryption routines of GNU Recutils v1.9 allows attackers to cause a Denial of Service (DoS) via inputting an empty value as a password.
- Record
DEBIAN-CVE-2025-65409- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2025-65409
7.5
A divide-by-zero in the encryption/decryption routines of GNU Recutils v1.9 allows attackers to cause a Denial of Service (DoS) via inputting an empty value as a password.
- Record
UBUNTU-CVE-2025-65409- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVopenSUSE-SU-2026:10000-1 No score
gnu-recutils-1.9-3.1 on GA media
These are all security issues fixed in the gnu-recutils-1.9-3.1 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2026:10000-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
recutilsDebian:12 |
All versions, plus listed versions 1.9-21.9-31.9-41.9-4~bpo13+1 |
None known |
recutilsDebian:14 |
All versions, plus listed versions 1.3-101.3-111.3-91.4-11.5-1 Show 11 moreShow less1.5-1.11.7-11.7-1.11.7-21.7-31.8-11.9-11.9-21.9-31.9-41.9-4~bpo13+1 |
None known |
recutilsUbuntu:Pro:16.04:LTS |
All versions, plus listed versions 1.7-11.7-1ubuntu0.1~esm1 |
None known |
recutilsUbuntu:Pro:18.04:LTS |
All versions, plus listed versions 1.7-1.11.7-21.7-2ubuntu0.1~esm1 |
None known |
recutilsUbuntu:Pro:20.04:LTS |
All versions, plus listed versions 1.7-3build11.8-11.8-1ubuntu0.20.04.1~esm1 |
None known |
recutilsUbuntu:Pro:22.04:LTS |
All versions, plus listed versions 1.8-11.8-1ubuntu0.22.04.1~esm1 |
None known |
recutilsUbuntu:24.04:LTS |
All versions, plus listed versions 1.9-21.9-31.9-3build3 |
None known |
recutilsUbuntu:25.10 |
All versions, plus listed versions 1.9-3build3 |
None known |
recutilsUbuntu:26.10 |
All versions, plus listed versions 1.9-4 |
None known |
recutilsUbuntu:26.04:LTS |
All versions, plus listed versions 1.9-3build31.9-4 |
None known |
gnu-recutilsopenSUSE:Tumbleweed |
before 1.9-3.1 | 1.9-3.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2025-65409 is a high vulnerability (CVSS 7.5) in Gnu Recutils, published December 30, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.36%, the 29th percentile. Fixed in gnu-recutils 1.9-3.1.