Every CVE Search/ Get API key

CVE-2025-65494

NULL pointer dereference in get_san_or_cn_from_cert() in src/coap_openssl.c in OISM libcoap 4.3.5...

7.5 HighFix available

NULL pointer dereference in get_san_or_cn_from_cert() in src/coap_openssl.c in OISM libcoap 4.3.5 allows remote attackers to cause a denial of service via a crafted X.509 certificate that causes sk_GENERAL_NAME_value() to return NULL.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

0.26%Up 0.2 points since Nov 25, 2025
90%50%10%1%

What each source reports

CVE List Score used 7.5

NULL pointer dereference in get_san_or_cn_from_cert() in src/coap_openssl.c in OISM libcoap 4.3.5 allows remote attackers to cause a denial of service via a crafted X.509 certificate that causes sk_GENERAL_NAME_value() to return NULL.

Record
CVE-2025-65494
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-476
Updated
2026-11-02
EUVDEUVD-2025-198715 7.5

NULL pointer dereference in get_san_or_cn_from_cert() in src/coap_openssl.c in OISM libcoap 4.3.5 allows remote attackers to cause a denial of service via a crafted X.509 certificate that causes sk_GENERAL_NAME_value() to return NULL.

Record
EUVD-2025-198715
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
GitHub AdvisoriesGHSA-vm7h-x472-77pq 7.5

NULL pointer dereference in get_san_or_cn_from_cert() in src/coap_openssl.c in OISM libcoap 4.3.5...

NULL pointer dereference in get_san_or_cn_from_cert() in src/coap_openssl.c in OISM libcoap 4.3.5 allows remote attackers to cause a denial of service via a crafted X.509 certificate that causes sk_GENERAL_NAME_value() to return NULL.

Record
GHSA-vm7h-x472-77pq
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-476
Updated
2026-11-02
NVD 7.5

NULL pointer dereference in get_san_or_cn_from_cert() in src/coap_openssl.c in OISM libcoap 4.3.5 allows remote attackers to cause a denial of service via a crafted X.509 certificate that causes sk_GENERAL_NAME_value() to return NULL.

Record
CVE-2025-65494
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-476
Updated
2026-11-05
OSV 7.5

NULL pointer dereference in get_san_or_cn_from_cert() in src/coap_openssl.c in OISM libcoap 4.3.5 allows remote attackers to cause a denial of service via a crafted X.509 certificate that causes sk_GENERAL_NAME_value() to return NULL.

Record
CVE-2025-65494
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-07
OSVDEBIAN-CVE-2025-65494 7.5

NULL pointer dereference in get_san_or_cn_from_cert() in src/coap_openssl.c in OISM libcoap 4.3.5 allows remote attackers to cause a denial of service via a crafted X.509 certificate that causes sk_GENERAL_NAME_value() to return NULL.

Record
DEBIAN-CVE-2025-65494
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2025-65494 7.5

NULL pointer dereference in get_san_or_cn_from_cert() in src/coap_openssl.c in OISM libcoap 4.3.5 allows remote attackers to cause a denial of service via a crafted X.509 certificate that causes sk_GENERAL_NAME_value() to return NULL.

Record
UBUNTU-CVE-2025-65494
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVopenSUSE-SU-2025:15780-1 No score

libcoap-devel-4.3.5a-1.1 on GA media

These are all security issues fixed in the libcoap-devel-4.3.5a-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2025:15780-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libcoap3
Debian:12
All versions, plus listed versions
4.3.1-14.3.1-24.3.3-14.3.4-14.3.4-1.1
Show 5 moreShow less
4.3.4-1.1~exp14.3.5-14.3.5-24.3.5-34.3.5-4
None known
libcoap3
Debian:13
before 4.3.4-1.1+deb13u2, plus listed versions
4.3.4-1.14.3.4-1.1+deb13u1
4.3.4-1.1+deb13u2
libcoap3
Debian:14
before 4.3.5-2, plus listed versions
4.3.4-1.14.3.5-1
4.3.5-2
libcoap
Ubuntu:18.04:LTS
All versions, plus listed versions
4.1.2-1
None known
libcoap2
Ubuntu:20.04:LTS
All versions, plus listed versions
4.2.0-24.2.1-1
None known
libcoap2
Ubuntu:22.04:LTS
All versions, plus listed versions
4.2.1-14.2.1-1build1
None known
libcoap3
Ubuntu:22.04:LTS
All versions, plus listed versions
4.3.0-24.3.0-2build1
None known
libcoap3
Ubuntu:24.04:LTS
All versions, plus listed versions
4.3.1-24.3.3-14.3.4-14.3.4-1.1build24.3.4-1.1build34.3.4-1.1build4
None known
libcoap3
Ubuntu:25.10
All versions, plus listed versions
4.3.4-1.1build4
None known
libcoap3
Ubuntu:26.10
All versions, plus listed versions
4.3.5-24.3.5-34.3.5-44.3.5-4ubuntu1
None known
libcoap3
Ubuntu:26.04:LTS
All versions, plus listed versions
4.3.4-1.1build44.3.5-14.3.5-2
None known
libcoap
openSUSE:Tumbleweed
From an advisory covering 9 CVEs
before 4.3.5a-1.1
4.3.5a-1.1

History

History
RecordedChangedSources
affected
factsNVD
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2025-65494 is a high vulnerability (CVSS 7.5) in Libcoap, published November 24, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.26%, the 17th percentile. Fixed in libcoap3 4.3.4-1.1+deb13u2.

References

Show 11 moreShow less
MoveEnter Open