CVE-2025-66631
CSLA .NET is vulnerable to Remote Code Execution via WcfProxy
CSLA .NET is a framework designed for the development of reusable, object-oriented business layers for applications. Versions 5.5.4 and below allow the use of WcfProxy. WcfProxy uses the now-obsolete NetDataContractSerializer (NDCS) and is vulnerable to remote code execution during deserialization. This vulnerability is fixed in version 6.0.0. To workaround this issue, remove the WcfProxy in data portal configurations.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
7.2
CSLA .NET is vulnerable to Remote Code Execution via WcfProxy
CSLA .NET is a framework designed for the development of reusable, object-oriented business layers for applications. Versions 5.5.4 and below allow the use of WcfProxy. WcfProxy uses the now-obsolete NetDataContractSerializer (NDCS) and is vulnerable to remote code execution during deserialization. This vulnerability is fixed in version 6.0.0. To workaround this issue, remove the WcfProxy in data portal configurations.
- Record
CVE-2025-66631- CVSS 4.0
- 7.2 High
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U - Weakness
- CWE-502
- Updated
- 2026-11-02
EUVDEUVD-2025-201825
7.2
CSLA .NET is a framework designed for the development of reusable, object-oriented business layers for applications. Versions 5.5.4 and below allow the use of WcfProxy. WcfProxy uses the now-obsolete NetDataContractSerializer (NDCS) and is vulnerable to remote code execution during deserialization. This vulnerability is fixed in version 6.0.0. To workaround this issue, remove the WcfProxy in data portal configurations.
- Record
EUVD-2025-201825- CVSS 4.0
- 7.2 High
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-wq34-7f4g-953v
7.2
Csla affected by Remote Code Execution via WcfProxy (NetDataContractSerializer)
Impact
Versions of CSLA .NET prior to version 6 allow the use of WcfProxy. WcfProxy uses the NetDataContractSerializer (NDCS) which has known vulnerabilities that can allow remote execution of code during deserialization. NDCS itself is considered obsolete, and you should avoid using WcfProxy or upgrade to CSLA 6 or higher where this issue does not exist.
Patches
CSLA .NET version 6 and higher do not use WCF or NetDataContractSerializer.
Workarounds
If you are using a version CSLA .NET older than version 6, you should stop using WcfProxy in your data portal configuration. Doing this avoids the use of WCF and the NetDataContractSerializer, avoiding the vulnerability.
- Record
GHSA-wq34-7f4g-953v- CVSS 4.0
- 7.2 High
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U - Weakness
- CWE-502
- Updated
- 2026-11-02
NVD
7.2
CSLA .NET is a framework designed for the development of reusable, object-oriented business layers for applications. Versions 5.5.4 and below allow the use of WcfProxy. WcfProxy uses the now-obsolete NetDataContractSerializer (NDCS) and is vulnerable to remote code execution during deserialization. This vulnerability is fixed in version 6.0.0. To workaround this issue, remove the WcfProxy in data portal configurations.
- Record
CVE-2025-66631- CVSS 4.0
- 7.2 High
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X - CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-502
- Updated
- 2026-11-02
OSV
7.2
CSLA .NET is vulnerable to Remote Code Execution via WcfProxy
CSLA .NET is a framework designed for the development of reusable, object-oriented business layers for applications. Versions 5.5.4 and below allow the use of WcfProxy. WcfProxy uses the now-obsolete NetDataContractSerializer (NDCS) and is vulnerable to remote code execution during deserialization. This vulnerability is fixed in version 6.0.0. To workaround this issue, remove the WcfProxy in data portal configurations.
- Record
CVE-2025-66631- CVSS 4.0
- 7.2 High
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U - Weakness
- CWE-502
- Updated
- 2026-11-02
OSVGHSA-wq34-7f4g-953v
7.2
Csla affected by Remote Code Execution via WcfProxy (NetDataContractSerializer)
Impact
Versions of CSLA .NET prior to version 6 allow the use of WcfProxy. WcfProxy uses the NetDataContractSerializer (NDCS) which has known vulnerabilities that can allow remote execution of code during deserialization. NDCS itself is considered obsolete, and you should avoid using WcfProxy or upgrade to CSLA 6 or higher where this issue does not exist.
Patches
CSLA .NET version 6 and higher do not use WCF or NetDataContractSerializer.
Workarounds
If you are using a version CSLA .NET older than version 6, you should stop using WcfProxy in your data portal configuration. Doing this avoids the use of WCF and the NetDataContractSerializer, avoiding the vulnerability.
- Record
GHSA-wq34-7f4g-953v- CVSS 4.0
- 7.2 High
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U - Weakness
- CWE-502
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
CslaNuGet |
before 6.0.0 | 6.0.0 |
CslaNuGet |
before 6.0.0, plus listed versions 5.0.05.0.0-R190522045.0.0-R190805015.0.0-R190821075.0.0-R19082803 Show 45 moreShow less5.0.0-R190902015.0.0-R190910015.0.0-R190910055.0.0-R190916015.0.0-R190917015.0.15.1.05.1.0-R191010025.1.0-R191101015.1.0-R191107015.1.0-R191223025.1.0-R200119015.1.0-R200120015.1.0-R200122015.1.0-R200205035.1.0-R200207015.2.05.2.0-R200409045.2.0-R200424015.2.0-R200429015.2.0-R200508025.3.05.3.0-R200629015.3.15.3.1-R200826015.3.25.4.05.4.0-R201110025.4.0-R201112025.4.0-R201130045.4.15.4.1-R210119015.4.25.4.2-R210405015.5.05.5.0-R210701015.5.0-R210719015.5.15.5.1-R210803015.5.1-R210822025.5.25.5.2-R211015015.5.35.5.46.0.0-R22020902 |
6.0.0 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2025-66631 is a high vulnerability (CVSS 7.2) in Cslanet Csla .net, published December 8, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.67%, the 52nd percentile. Fixed in Csla 6.0.0.
References
github.com/MarimerLLC/csla/security/advisories/GHSA-wq34-7f4g-953v
github.com/MarimerLLC/csla/issues/4001
github.com/MarimerLLC/csla/pull/4018
learn.microsoft.com/en-us/dotnet/fundamentals/code-analysis/quality-rules/ca2310
nvd.nist.gov/vuln/detail/CVE-2025-66631
github.com/advisories/GHSA-wq34-7f4g-953v
github.com/CVEProject/cvelistV5/tree/main/cves/2025/66xxx/CVE-2025-66631.json
github.com/MarimerLLC/csla
Left out here: 4 versions. The JSON record has them.