CVE-2025-67635
Jenkins has a Denial of service vulnerability in HTTP-based CLI
Jenkins 2.540 and earlier, LTS 2.528.2 and earlier does not properly close HTTP-based CLI connections when the connection stream becomes corrupted, allowing unauthenticated attackers to cause a denial of service.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
7.5
Jenkins 2.540 and earlier, LTS 2.528.2 and earlier does not properly close HTTP-based CLI connections when the connection stream becomes corrupted, allowing unauthenticated attackers to cause a denial of service.
- Record
CVE-2025-67635- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-404
- Updated
- 2026-11-02
EUVDEUVD-2025-202453
7.5
Jenkins 2.540 and earlier, LTS 2.528.2 and earlier does not properly close HTTP-based CLI connections when the connection stream becomes corrupted, allowing unauthenticated attackers to cause a denial of service.
- Record
EUVD-2025-202453- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-9p56-p6mw-w8qc
7.5
Jenkins has a Denial of service vulnerability in HTTP-based CLI
Jenkins 2.540 and earlier, LTS 2.528.2 and earlier does not properly close HTTP-based CLI connections when the connection stream becomes corrupted, allowing unauthenticated attackers to cause a denial of service.
- Record
GHSA-9p56-p6mw-w8qc- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-404
- Updated
- 2026-11-02
NVD
7.5
Jenkins 2.540 and earlier, LTS 2.528.2 and earlier does not properly close HTTP-based CLI connections when the connection stream becomes corrupted, allowing unauthenticated attackers to cause a denial of service.
- Record
CVE-2025-67635- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-404
- Updated
- 2026-11-02
OSV
7.5
Jenkins 2.540 and earlier, LTS 2.528.2 and earlier does not properly close HTTP-based CLI connections when the connection stream becomes corrupted, allowing unauthenticated attackers to cause a denial of service.
- Record
CVE-2025-67635- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVGHSA-9p56-p6mw-w8qc
7.5
Jenkins has a Denial of service vulnerability in HTTP-based CLI
Jenkins 2.540 and earlier, LTS 2.528.2 and earlier does not properly close HTTP-based CLI connections when the connection stream becomes corrupted, allowing unauthenticated attackers to cause a denial of service.
- Record
GHSA-9p56-p6mw-w8qc- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-404
- Updated
- 2026-11-02
OSVROOT-APP-MAVEN-CVE-2025-67635
7.5
CVE-2025-67635 in io.root.org.jenkins-ci.main:cli - Patched by Root
Root has patched CVE-2025-67635 in the io.root.org.jenkins-ci.main:cli package for Root:Maven. Multiple fixed versions available.
- Record
ROOT-APP-MAVEN-CVE-2025-67635- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVBIT-jenkins-2025-67635 No score
Jenkins 2.540 and earlier, LTS 2.528.2 and earlier does not properly close HTTP-based CLI connections when the connection stream becomes corrupted, allowing unauthenticated attackers to cause a denial of service.
- Record
BIT-jenkins-2025-67635- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
org.jenkins-ci.main:jenkins-coreMaven |
2.529 up to 2.541 | 2.541 |
org.jenkins-ci.main:cliMaven |
2.529 up to 2.541 | 2.541 |
org.jenkins-ci.main:jenkins-coreMaven |
before 2.528.3 | 2.528.3 |
org.jenkins-ci.main:cliMaven |
before 2.528.3 | 2.528.3 |
jenkinsBitnami |
before 2.528.3, 2.529.0 up to 2.541.0 | 2.528.32.541.0 |
org.jenkins-ci.main:jenkins-coreMaven |
2.529 up to 2.541, plus listed versions 2.5302.5312.5322.5332.534 Show 6 moreShow less2.5352.5362.5372.5382.5392.540 |
2.541 |
org.jenkins-ci.main:cliMaven |
2.529 up to 2.541, plus listed versions 2.5302.5312.5322.5332.534 Show 6 moreShow less2.5352.5362.5372.5382.5392.540 |
2.541 |
org.jenkins-ci.main:jenkins-coreMaven |
before 2.528.3, plus listed versions 1.3961.3971.3981.3991.400 Show 45 moreShow less1.4011.4031.4041.4051.4061.4071.4081.4091.409.11.409.21.409.31.4101.4111.4121.4131.4141.4151.4161.4171.4181.4191.4201.4211.4221.4231.4241.424.11.424.21.424.31.424.41.424.51.424.61.4251.4261.4271.4281.4291.4301.4311.4321.4331.4341.4351.4361.437 |
2.528.3 |
org.jenkins-ci.main:cliMaven |
before 2.528.3, plus listed versions 1.3961.3971.3981.3991.400 Show 45 moreShow less1.4011.4031.4041.4051.4061.4071.4081.4091.409.11.409.21.409.31.4101.4111.4121.4131.4141.4151.4161.4171.4181.4191.4201.4211.4221.4231.4241.424.11.424.21.424.31.424.41.424.51.424.61.4251.4261.4271.4281.4291.4301.4311.4321.4331.4341.4351.4361.437 |
2.528.3 |
io.root.org.jenkins-ci.main:cliRoot:Maven |
before 2.533-root.io.1 | 2.533-root.io.12.533-root.io.22.533-root.io.32.533-root.io.42.533-root.io.62.533-root.io.7 |
io.root.org.jenkins-ci.main:jenkins-coreRoot:Maven |
before 2.533-root.io.1 | 2.533-root.io.12.533-root.io.22.533-root.io.32.533-root.io.42.533-root.io.6 |
org.jenkins-ci.main:cliRoot:Maven |
before 2.533-aikido.7 | 2.533-aikido.7 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2025-67635 is a high vulnerability (CVSS 7.5) in Jenkins, published December 10, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.56%, the 47th percentile. Fixed in org.jenkins-ci.main:jenkins-core 2.541.
References
Left out here: 1,867 versions. The JSON record has them.