CVE-2025-67896
Exim before 4.99.1 allows remote heap corruption that will be further described on 2025-12-18.
Exim before 4.99.1, with certain non-default rate-limit configurations, allows a remote heap-based buffer overflow because database records are cast directly to internal structures without validation.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- High
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- Low
- Integrity
- High
- Availability
- Low
Exploit likelihood
What each source reports
CVE List Score used
7.0
Exim before 4.99.1, with certain non-default rate-limit configurations, allows a remote heap-based buffer overflow because database records are cast directly to internal structures without validation.
- Record
CVE-2025-67896- CVSS 3.1
- 7.0 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:H/A:L - Weakness
- CWE-122
- Updated
- 2026-11-02
EUVDEUVD-2025-203281
7.0
Exim before 4.99.1, with certain non-default rate-limit configurations, allows a remote heap-based buffer overflow because database records are cast directly to internal structures without validation.
- Record
EUVD-2025-203281- CVSS 3.1
- 7.0 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:H/A:L - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-6qxw-x3vc-phrg
6.4
Exim before 4.99.1 allows remote heap corruption that will be further described on 2025-12-18.
Exim before 4.99.1 allows remote heap corruption that will be further described on 2025-12-18.
- Record
GHSA-6qxw-x3vc-phrg- CVSS 3.1
- 6.4 Medium
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:H/A:L - Weakness
- CWE-122
- Updated
- 2026-11-02
NVD
7.0
Exim before 4.99.1, with certain non-default rate-limit configurations, allows a remote heap-based buffer overflow because database records are cast directly to internal structures without validation.
- Record
CVE-2025-67896- CVSS 3.1
- 7.0 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:H/A:L - CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-122
- Updated
- 2026-11-02
OSV
7.0
Exim before 4.99.1, with certain non-default rate-limit configurations, allows a remote heap-based buffer overflow because database records are cast directly to internal structures without validation.
- Record
CVE-2025-67896- CVSS 3.1
- 7.0 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:H/A:L - Weakness
- CWE-122
- Updated
- 2026-11-02
OSVDEBIAN-CVE-2025-67896
9.8
Exim before 4.99.1, with certain non-default rate-limit configurations, allows a remote heap-based buffer overflow because database records are cast directly to internal structures without validation.
- Record
DEBIAN-CVE-2025-67896- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2025-67896
6.4
Exim before 4.99.1 allows remote heap corruption that will be further described on 2025-12-18.
- Record
UBUNTU-CVE-2025-67896- CVSS 3.1
- 6.4 Medium
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:H/A:L - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
exim4Debian:14 |
before 4.99-7, plus listed versions 4.98.2-14.98.2-1+hurd.14.98.2-24.99-14.99-2 Show 11 moreShow less4.99-34.99-44.99-4~bpo13+14.99-54.99-64.99-6~bpo13+14.99-7~bpo13+14.99~RC1-14.99~RC2-14.99~RC3-14.99~RC3-2 |
4.99-7 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected | ||
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2025-67896 is a high vulnerability (CVSS 7.0) in Exim, published December 14, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.47%, the 40th percentile. Fixed in exim4 4.99-7.