CVE-2025-69219
Apache Airflow Providers Http: Unsafe Pickle Deserialization in apache-airflow-providers-http leading to RCE via HttpOperator
A user with access to the DB could craft a database entry that would result in executing code on Triggerer - which gives anyone who have access to DB the same permissions as Dag Author. Since direct DB access is not usual and recommended for Airflow, the likelihood of it making any damage is low.
You should upgrade to version 6.0.0 of the provider to avoid even that risk.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
8.8
Apache Airflow Providers Http: Unsafe Pickle Deserialization in apache-airflow-providers-http leading to RCE via HttpOperator
A user with access to the DB could craft a database entry that would result in executing code on Triggerer - which gives anyone who have access to DB the same permissions as Dag Author. Since direct DB access is not usual and recommended for Airflow, the likelihood of it making any damage is low.
You should upgrade to version 6.0.0 of the provider to avoid even that risk.
- Record
CVE-2025-69219- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-913
- Updated
- 2026-11-02
EUVDEUVD-2025-208401
8.8
A user with access to the DB could craft a database entry that would result in executing code on Triggerer - which gives anyone who have access to DB the same permissions as Dag Author. Since direct DB access is not usual and recommended for Airflow, the likelihood of it making any damage is low.
You should upgrade to version 6.0.0 of the provider to avoid even that risk.
- Record
EUVD-2025-208401- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-9r5j-7r2x-rv4g
8.8
Apache Airflow Providers Http has Unsafe Pickle Deserializatio leading to RCE via HttpOperator
A user with access to the DB could craft a database entry that would result in executing code on Triggerer - which gives anyone who have access to DB the same permissions as Dag Author. Since direct DB access is not usual and recommended for Airflow, the likelihood of it making any damage is low.
Users should upgrade to version 6.0.0 of the provider to avoid even that risk.
- Record
GHSA-9r5j-7r2x-rv4g- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-913
- Updated
- 2026-11-02
NVD
8.8
A user with access to the DB could craft a database entry that would result in executing code on Triggerer - which gives anyone who have access to DB the same permissions as Dag Author. Since direct DB access is not usual and recommended for Airflow, the likelihood of it making any damage is low.
You should upgrade to version 6.0.0 of the provider to avoid even that risk.
- Record
CVE-2025-69219- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-913
- Updated
- 2026-11-02
OSV
8.8
Apache Airflow Providers Http: Unsafe Pickle Deserialization in apache-airflow-providers-http leading to RCE via HttpOperator
A user with access to the DB could craft a database entry that would result in executing code on Triggerer - which gives anyone who have access to DB the same permissions as Dag Author. Since direct DB access is not usual and recommended for Airflow, the likelihood of it making any damage is low.
You should upgrade to version 6.0.0 of the provider to avoid even that risk.
- Record
CVE-2025-69219- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-913
- Updated
- 2026-11-02
OSVGHSA-9r5j-7r2x-rv4g
8.8
Apache Airflow Providers Http has Unsafe Pickle Deserializatio leading to RCE via HttpOperator
A user with access to the DB could craft a database entry that would result in executing code on Triggerer - which gives anyone who have access to DB the same permissions as Dag Author. Since direct DB access is not usual and recommended for Airflow, the likelihood of it making any damage is low.
Users should upgrade to version 6.0.0 of the provider to avoid even that risk.
- Record
GHSA-9r5j-7r2x-rv4g- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-913
- Updated
- 2026-11-02
OSVPYSEC-2026-2367
8.8
Apache Airflow Providers Http has Unsafe Pickle Deserializatio leading to RCE via HttpOperator
A user with access to the DB could craft a database entry that would result in executing code on Triggerer - which gives anyone who have access to DB the same permissions as Dag Author. Since direct DB access is not usual and recommended for Airflow, the likelihood of it making any damage is low.
Users should upgrade to version 6.0.0 of the provider to avoid even that risk.
- Record
PYSEC-2026-2367- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVCLSA-2026-1779670115 No score
TuxCare security update for apache-airflow-providers-http (1 CVE)
TuxCare rebuilt apache-airflow-providers-http to address 1 CVE. Fixed in 4.13.3.post1+tuxcare.
- Record
CLSA-2026-1779670115- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
apache-airflow-providers-httpPyPI |
before 6.0.0 | 6.0.0 |
apache-airflow-providers-httpTuxCare:PyPI |
4.13.3 up to 4.13.3.post1+tuxcare | 4.13.3.post1+tuxcare |
apache-airflow-providers-httpPyPI |
before 6.0.0, plus listed versions 1.0.01.0.0b11.0.0b21.0.0rc11.1.0 Show 45 moreShow less1.1.0rc11.1.11.1.1rc12.0.02.0.0rc12.0.0rc22.0.12.0.1rc12.0.22.0.2rc12.0.32.0.3rc12.0.3rc22.1.02.1.0rc12.1.12.1.1rc12.1.22.1.2rc13.0.03.0.0rc13.0.0rc24.0.04.0.0rc14.1.04.1.0rc14.1.14.1.1rc14.10.04.10.0rc14.10.14.10.1rc14.11.04.11.0rc14.11.14.11.1rc14.12.04.12.0rc14.13.04.13.0rc14.13.14.13.1rc14.13.24.13.2rc14.13.3 |
6.0.0 |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| PoC in GitHub | ahmetartuc/poc-cve-2025-69219 | 2026-02-11 |
| PoC in GitHub | sak110/CVE-2025-69219 | 2026-03-11 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV, PoC in GitHub |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2025-69219 is a high vulnerability (CVSS 8.8) in Apache Airflow Providers Http, published March 9, 2026. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 0.77%, the 55th percentile. Fixed in apache-airflow-providers-http 6.0.0.
References
Left out here: 65 versions. The JSON record has them.