CVE-2025-69261
WasmEdge integer wrap in MemoryInstance::getSpan()'s memory size check
WasmEdge is a WebAssembly runtime. Prior to version 0.16.0-alpha.3, a multiplication in WasmEdge/include/runtime/instance/memory.h can wrap, causing checkAccessBound() to incorrectly allow the access. This leads to a segmentation fault. Version 0.16.0-alpha.3 contains a patch for the issue.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- Low
Exploit likelihood
What each source reports
CVE List Score used
5.5
WasmEdge integer wrap in MemoryInstance::getSpan()'s memory size check
WasmEdge is a WebAssembly runtime. Prior to version 0.16.0-alpha.3, a multiplication in WasmEdge/include/runtime/instance/memory.h can wrap, causing checkAccessBound() to incorrectly allow the access. This leads to a segmentation fault. Version 0.16.0-alpha.3 contains a patch for the issue.
- Record
CVE-2025-69261- CVSS 4.0
- 5.5 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P - Weakness
- CWE-190
- Updated
- 2026-11-02
EUVDEUVD-2025-205847
5.5
WasmEdge is a WebAssembly runtime. Prior to version 0.16.0-alpha.3, a multiplication in WasmEdge/include/runtime/instance/memory.h can wrap, causing checkAccessBound() to incorrectly allow the access. This leads to a segmentation fault. Version 0.16.0-alpha.3 contains a patch for the issue.
- Record
EUVD-2025-205847- CVSS 4.0
- 5.5 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P - Updated
- 2026-11-02
NVD
5.5
WasmEdge is a WebAssembly runtime. Prior to version 0.16.0-alpha.3, a multiplication in WasmEdge/include/runtime/instance/memory.h can wrap, causing checkAccessBound() to incorrectly allow the access. This leads to a segmentation fault. Version 0.16.0-alpha.3 contains a patch for the issue.
- Record
CVE-2025-69261- CVSS 4.0
- 5.5 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X - CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-190
- Updated
- 2026-11-02
OSV
5.5
WasmEdge integer wrap in MemoryInstance::getSpan()'s memory size check
WasmEdge is a WebAssembly runtime. Prior to version 0.16.0-alpha.3, a multiplication in WasmEdge/include/runtime/instance/memory.h can wrap, causing checkAccessBound() to incorrectly allow the access. This leads to a segmentation fault. Version 0.16.0-alpha.3 contains a patch for the issue.
- Record
CVE-2025-69261- CVSS 4.0
- 5.5 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P - Weakness
- CWE-190
- Updated
- 2026-11-02
OSVDEBIAN-CVE-2025-69261
7.5
WasmEdge is a WebAssembly runtime. Prior to version 0.16.0-alpha.3, a multiplication in WasmEdge/include/runtime/instance/memory.h can wrap, causing checkAccessBound() to incorrectly allow the access. This leads to a segmentation fault. Version 0.16.0-alpha.3 contains a patch for the issue.
- Record
DEBIAN-CVE-2025-69261- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2025-69261
5.5
WasmEdge is a WebAssembly runtime. Prior to version 0.16.0-alpha.3, a multiplication in WasmEdge/include/runtime/instance/memory.h can wrap, causing checkAccessBound() to incorrectly allow the access. This leads to a segmentation fault. Version 0.16.0-alpha.3 contains a patch for the issue.
- Record
UBUNTU-CVE-2025-69261- CVSS 4.0
- 5.5 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P - CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
wasmedgeDebian:13 |
All versions, plus listed versions 0.14.1+dfsg-3.10.14.1+dfsg-3.20.14.1+dfsg-40.16.0+dfsg-10.16.1+dfsg-1 |
None known |
wasmedgeDebian:14 |
before 0.16.0+dfsg-1, plus listed versions 0.14.1+dfsg-3.10.14.1+dfsg-3.20.14.1+dfsg-4 |
0.16.0+dfsg-1 |
wasmedgeUbuntu:24.04:LTS |
All versions, plus listed versions 0.13.4+dfsg-10.13.5+dfsg-10.13.5+dfsg-1build10.13.5+dfsg-1build20.13.5+dfsg-1build30.13.5+dfsg-1build4 |
None known |
wasmedgeUbuntu:25.10 |
All versions, plus listed versions 0.14.1+dfsg-3.10.14.1+dfsg-3.1ubuntu1 |
None known |
wasmedgeUbuntu:26.10 |
All versions, plus listed versions 0.16.1+dfsg-10.16.1+dfsg-1ubuntu1 |
None known |
wasmedgeUbuntu:26.04:LTS |
All versions, plus listed versions 0.14.1+dfsg-3.1ubuntu10.14.1+dfsg-3.20.14.1+dfsg-40.16.0+dfsg-10.16.1+dfsg-1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2025-69261 is a medium vulnerability (CVSS 5.5) in Linuxfoundation Wasmedge, published December 30, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.33%, the 26th percentile. Fixed in wasmedge 0.16.0+dfsg-1.
References
github.com/WasmEdge/WasmEdge/security/advisories/GHSA-89fm-8mr7-gg4m
github.com/WasmEdge/WasmEdge/commit/37cc9fa19bd23edbbdaa9252059b17f191fa4d17
github.com/CVEProject/cvelistV5/tree/main/cves/2025/69xxx/CVE-2025-69261.json
nvd.nist.gov/vuln/detail/CVE-2025-69261
security-tracker.debian.org/tracker/CVE-2025-69261
ubuntu.com/security/CVE-2025-69261
cve.org/CVERecord?id=CVE-2025-69261