CVE-2025-7338
Multer vulnerable to Denial of Service via unhandled exception from malformed request
Multer is a node.js middleware for handling multipart/form-data. A vulnerability that is present starting in version 1.4.4-lts.1 and prior to version 2.0.2 allows an attacker to trigger a Denial of Service (DoS) by sending a malformed multi-part upload request. This request causes an unhandled exception, leading to a crash of the process. Users should upgrade to version 2.0.2 to receive a patch. No known workarounds are available.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
7.5
Multer vulnerable to Denial of Service via unhandled exception from malformed request
Multer is a node.js middleware for handling multipart/form-data. A vulnerability that is present starting in version 1.4.4-lts.1 and prior to version 2.0.2 allows an attacker to trigger a Denial of Service (DoS) by sending a malformed multi-part upload request. This request causes an unhandled exception, leading to a crash of the process. Users should upgrade to version 2.0.2 to receive a patch. No known workarounds are available.
- Record
CVE-2025-7338- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-248
- Updated
- 2026-11-02
EUVDEUVD-2025-21776
7.5
Multer is a node.js middleware for handling multipart/form-data. A vulnerability that is present starting in version 1.4.4-lts.1 and prior to version 2.0.2 allows an attacker to trigger a Denial of Service (DoS) by sending a malformed multi-part upload request. This request causes an unhandled exception, leading to a crash of the process. Users should upgrade to version 2.0.2 to receive a patch. No known workarounds are available.
- Record
EUVD-2025-21776- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-fjgf-rc76-4x9p
7.5
Multer vulnerable to Denial of Service via unhandled exception from malformed request
Impact
A vulnerability in Multer versions >= 1.4.4-lts.1, < 2.0.2 allows an attacker to trigger a Denial of Service (DoS) by sending a malformed request. This request causes an unhandled exception, leading to a crash of the process.
Patches
Users should upgrade to 2.0.2
Workarounds
None
- Record
GHSA-fjgf-rc76-4x9p- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-248
- Updated
- 2026-11-02
NVD
7.5
Multer is a node.js middleware for handling multipart/form-data. A vulnerability that is present starting in version 1.4.4-lts.1 and prior to version 2.0.2 allows an attacker to trigger a Denial of Service (DoS) by sending a malformed multi-part upload request. This request causes an unhandled exception, leading to a crash of the process. Users should upgrade to version 2.0.2 to receive a patch. No known workarounds are available.
- Record
CVE-2025-7338- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-248
- Updated
- 2026-11-02
OSV
7.5
Multer vulnerable to Denial of Service via unhandled exception from malformed request
Multer is a node.js middleware for handling multipart/form-data. A vulnerability that is present starting in version 1.4.4-lts.1 and prior to version 2.0.2 allows an attacker to trigger a Denial of Service (DoS) by sending a malformed multi-part upload request. This request causes an unhandled exception, leading to a crash of the process. Users should upgrade to version 2.0.2 to receive a patch. No known workarounds are available.
- Record
CVE-2025-7338- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-248
- Updated
- 2026-11-02
OSVGHSA-fjgf-rc76-4x9p
7.5
Multer vulnerable to Denial of Service via unhandled exception from malformed request
Impact
A vulnerability in Multer versions >= 1.4.4-lts.1, < 2.0.2 allows an attacker to trigger a Denial of Service (DoS) by sending a malformed request. This request causes an unhandled exception, leading to a crash of the process.
Patches
Users should upgrade to 2.0.2
Workarounds
None
- Record
GHSA-fjgf-rc76-4x9p- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-248
- Updated
- 2026-11-02
OSVCLSA-2026-1773879511 No score
TuxCare security update for multer (1 CVE)
TuxCare rebuilt multer to address 1 CVE. Fixed in 1.4.5-lts.1-tuxcare.3.
- Record
CLSA-2026-1773879511- Updated
- 2026-11-02
OSVCLSA-2026-1786358483 No score
TuxCare security update for multer (2 CVEs)
TuxCare rebuilt multer to address 2 CVEs. Fixed in 1.4.5-lts.2-tuxcare.4.
- Record
CLSA-2026-1786358483- Updated
- 2026-11-02
OSVROOT-APP-NPM-CVE-2025-7338 No score
CVE-2025-7338 in multer - Patched by Root
Root has patched CVE-2025-7338 in the multer package for Root:npm. Multiple fixed versions available.
- Record
ROOT-APP-NPM-CVE-2025-7338- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
multernpm |
1.4.4-lts.1 up to 2.0.2 | 2.0.2 |
multerTuxCare:npm |
1.4.5-lts.1-tuxcare.0 up to 1.4.5-lts.1-tuxcare.3, plus listed versions 1.4.5-lts.11.4.5-lts.1-tuxcare.11.4.5-lts.1-tuxcare.2 |
1.4.5-lts.1-tuxcare.3 |
multerTuxCare:npm From an advisory covering 2 CVEs |
1.4.5-lts.2-tuxcare.0 up to 1.4.5-lts.2-tuxcare.4, plus listed versions 1.4.5-lts.21.4.5-lts.2-tuxcare.11.4.5-lts.2-tuxcare.21.4.5-lts.2-tuxcare.3 |
1.4.5-lts.2-tuxcare.4 |
multerRoot:npm |
before 1.4.4-lts.1-aikido.3 | 1.4.4-lts.1-aikido.31.4.5-lts.2-aikido.91.4.5-lts.2-aikido.51.4.4-lts.1-aikido.41.4.5-lts.1-aikido.21.4.5-lts.1-aikido.31.4.4-aikido.31.4.4-aikido.41.4.5-lts.1-aikido.11.4.4-lts.1-aikido.21.4.4-aikido.51.4.5-lts.2-aikido.61.4.4-aikido.61.4.5-lts.2-aikido.71.4.5-lts.2-aikido.82.0.2-aikido.42.0.2-aikido.52.0.2-aikido.62.0.2-aikido.7 |
@rootio/multerRoot:npm |
before 1.4.4-lts.1-root.io.3 | 1.4.4-lts.1-root.io.31.4.5-lts.2-root.io.21.4.5-lts.2-root.io.31.4.5-lts.2-root.io.41.4.5-lts.2-root.io.91.4.5-lts.2-root.io.51.4.4-lts.1-root.io.41.4.5-lts.1-root.io.21.4.5-lts.1-root.io.31.4.4-root.io.31.4.4-root.io.41.4.5-lts.1-root.io.11.4.4-lts.1-root.io.21.4.4-root.io.51.4.5-lts.2-root.io.61.4.4-root.io.61.4.5-lts.2-root.io.71.4.5-lts.2-root.io.82.0.2-root.io.12.0.2-root.io.22.0.2-root.io.32.0.2-root.io.42.0.2-root.io.52.0.2-root.io.62.0.2-root.io.7 |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| PoC in GitHub | r2c-CSE/multer-sca-rule-test_cve-2025-7338 | 2025-12-04 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV, PoC in GitHub |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2025-7338 is a high vulnerability (CVSS 7.5) in Expressjs Multer, published July 17, 2025. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 0.81%, the 57th percentile. Fixed in multer 2.0.2.
References
github.com/expressjs/multer/security/advisories/GHSA-fjgf-rc76-4x9p
github.com/expressjs/multer/commit/adfeaf669f0e7fe953eab191a762164a452d143b
cna.openjsf.org/security-advisories.html
nvd.nist.gov/vuln/detail/CVE-2025-7338
github.com/advisories/GHSA-fjgf-rc76-4x9p
github.com/CVEProject/cvelistV5/tree/main/cves/2025/7xxx/CVE-2025-7338.json
github.com/expressjs/multer