Every CVE Search/ Get API key

CVE-2025-7656

Integer overflow in V8 in Google Chrome prior to 138.0.7204.157 allowed a remote attacker to...

8.8 HighFix available

CVE-2025-7656 is a high vulnerability (CVSS 8.8) in Google Chrome, published July 15, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 11.0%, the 95th percentile. Fixed in qt6-qtwebengine 6.8.3-r1.

Integer overflow in V8 in Google Chrome prior to 138.0.7204.157 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page. (Chromium security severity: High)

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

11.0%Up 10.9 points since Jul 16, 2025
90%50%10%1%

What each source reports

CVE List Score used 8.8

Integer overflow in V8 in Google Chrome prior to 138.0.7204.157 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page. (Chromium security severity: High)

Record
CVE-2025-7656
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-472
Updated
2026-11-02
EUVDEUVD-2025-21547 8.8

Integer overflow in V8 in Google Chrome prior to 138.0.7204.157 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page. (Chromium security severity: High)

Record
EUVD-2025-21547
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
GitHub AdvisoriesGHSA-x429-qrf9-h4p7 8.8

Integer overflow in V8 in Google Chrome prior to 138.0.7204.157 allowed a remote attacker to...

Integer overflow in V8 in Google Chrome prior to 138.0.7204.157 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page. (Chromium security severity: High)

Record
GHSA-x429-qrf9-h4p7
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-472
Updated
2026-11-02
NVD 8.8

Integer overflow in V8 in Google Chrome prior to 138.0.7204.157 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page. (Chromium security severity: High)

Record
CVE-2025-7656
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-472
Updated
2026-11-02
OSVALPINE-CVE-2025-7656 8.8

Integer overflow in V8 in Google Chrome prior to 138.0.7204.157 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page. (Chromium security severity: High)

Record
ALPINE-CVE-2025-7656
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-03
OSV 8.8

Integer overflow in V8 in Google Chrome prior to 138.0.7204.157 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page. (Chromium security severity: High)

Record
CVE-2025-7656
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2025-7656 8.8

Integer overflow in V8 in Google Chrome prior to 138.0.7204.157 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page. (Chromium security severity: High)

Record
DEBIAN-CVE-2025-7656
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVAZL-65583 No score

CVE-2025-7656 affecting package nodejs18 for versions less than 18.20.3-8

Integer overflow in V8 in Google Chrome prior to 138.0.7204.157 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page. (Chromium security severity: High)

Record
AZL-65583
Updated
2026-11-02
OSVopenSUSE-SU-2025:15350-1 No score

chromedriver-138.0.7204.157-1.1 on GA media

These are all security issues fixed in the chromedriver-138.0.7204.157-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2025:15350-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
qt6-qtwebengine
Alpine:v3.22
before 6.8.3-r1
6.8.3-r1
qt6-qtwebengine
Alpine:v3.23
before 6.9.1-r3
6.9.1-r3
qt6-qtwebengine
Alpine:v3.24
before 6.9.1-r3
6.9.1-r3
nodejs18
Azure Linux:2
before 18.20.3-8
18.20.3-8
chromium
Debian:12
before 138.0.7204.157-1~deb12u1, plus listed versions
113.0.5672.126-1114.0.5735.106-1114.0.5735.106-1~deb11u1114.0.5735.106-1~deb12u1114.0.5735.133-1
Show 45 moreShow less
114.0.5735.133-1~deb11u1114.0.5735.133-1~deb12u1114.0.5735.198-1114.0.5735.198-1~deb11u1114.0.5735.198-1~deb12u1114.0.5735.90-1114.0.5735.90-2114.0.5735.90-2~deb11u1114.0.5735.90-2~deb12u1115.0.5790.102-1115.0.5790.102-2115.0.5790.170-1115.0.5790.170-1~deb11u1115.0.5790.170-1~deb12u1115.0.5790.98-1115.0.5790.98-1~deb11u1115.0.5790.98-1~deb12u1115.0.5790.98-2116.0.5845.110-1116.0.5845.110-1~deb11u1116.0.5845.110-1~deb12u1116.0.5845.110-2116.0.5845.140-1116.0.5845.140-1~deb11u1116.0.5845.140-1~deb12u1116.0.5845.180-1116.0.5845.180-1~deb11u1116.0.5845.180-1~deb12u1116.0.5845.96-1116.0.5845.96-1~deb11u1116.0.5845.96-1~deb12u1116.0.5845.96-2117.0.5938.132-1117.0.5938.132-1~deb11u1117.0.5938.132-1~deb12u1117.0.5938.132-2117.0.5938.149-1117.0.5938.149-1~deb11u1117.0.5938.149-1~deb12u1117.0.5938.62-1117.0.5938.62-1~deb11u1117.0.5938.62-1~deb12u1117.0.5938.92-1118.0.5993.117-1118.0.5993.117-1~deb11u1
138.0.7204.157-1~deb12u1
chromium
Debian:13
before 138.0.7204.157-1
138.0.7204.157-1
chromium
Debian:14
before 138.0.7204.157-1
138.0.7204.157-1
chromium
openSUSE:Tumbleweed
before 138.0.7204.157-1.1
138.0.7204.157-1.1

History

History
WhenChangedSources
2026-11-03affected, aliases, referencesOSV
2026-11-02createdCVE List, EUVD, GitHub Advisories, NVD, OSV

References

This page doesn't list everything

Left out here: 180 versions. The JSON record has them.

MoveEnter Open