Every CVE Search/ Get API key

CVE-2025-7707

World-Writable NLTK Cache Directory Vulnerability in run-llama/llama_index

7.1 HighFix available

The llama_index library version 0.12.33 sets the NLTK data directory to a subdirectory of the codebase by default, which is world-writable in multi-user environments. This configuration allows local users to overwrite, delete, or corrupt NLTK data files, leading to potential denial of service, data tampering, or privilege escalation. The vulnerability arises from the use of a shared cache directory instead of a user-specific one, making it susceptible to local data tampering and denial of service.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
High
Availability
High

Exploit likelihood

0.19%Up 0.2 points since Oct 14, 2025
90%50%10%1%

What each source reports

CVE List Score used 7.1

World-Writable NLTK Cache Directory Vulnerability in run-llama/llama_index

The llama_index library version 0.12.33 sets the NLTK data directory to a subdirectory of the codebase by default, which is world-writable in multi-user environments. This configuration allows local users to overwrite, delete, or corrupt NLTK data files, leading to potential denial of service, data tampering, or privilege escalation. The vulnerability arises from the use of a shared cache directory instead of a user-specific one, making it susceptible to local data tampering and denial of service.

Record
CVE-2025-7707
CVSS 3.0
7.1 HighCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H
Weakness
CWE-377
Updated
2026-11-02
EUVDEUVD-2025-34071 7.1

The llama_index library version 0.12.33 sets the NLTK data directory to a subdirectory of the codebase by default, which is world-writable in multi-user environments. This configuration allows local users to overwrite, delete, or corrupt NLTK data files, leading to potential denial of service, data tampering, or privilege escalation. The vulnerability arises from the use of a shared cache directory instead of a user-specific one, making it susceptible to local data tampering and denial of service.

Record
EUVD-2025-34071
CVSS 3.0
7.1 HighCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H
Updated
2026-11-02
GitHub AdvisoriesGHSA-rg9h-vx28-xxp5 7.1

llama-index has Insecure Temporary File

The llama_index library version 0.12.33 sets the NLTK data directory to a subdirectory of the codebase by default, which is world-writable in multi-user environments. This configuration allows local users to overwrite, delete, or corrupt NLTK data files, leading to potential denial of service, data tampering, or privilege escalation. The vulnerability arises from the use of a shared cache directory instead of a user-specific one, making it susceptible to local data tampering and denial of service.

Record
GHSA-rg9h-vx28-xxp5
CVSS 3.0
7.1 HighCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H
Weakness
CWE-377
Updated
2026-11-02
NVD 7.8

The llama_index library version 0.12.33 sets the NLTK data directory to a subdirectory of the codebase by default, which is world-writable in multi-user environments. This configuration allows local users to overwrite, delete, or corrupt NLTK data files, leading to potential denial of service, data tampering, or privilege escalation. The vulnerability arises from the use of a shared cache directory instead of a user-specific one, making it susceptible to local data tampering and denial of service.

Record
CVE-2025-7707
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVSS 3.0
7.1 HighCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H
Weakness
CWE-377
Updated
2026-11-02
OSV 7.1

World-Writable NLTK Cache Directory Vulnerability in run-llama/llama_index

The llama_index library version 0.12.33 sets the NLTK data directory to a subdirectory of the codebase by default, which is world-writable in multi-user environments. This configuration allows local users to overwrite, delete, or corrupt NLTK data files, leading to potential denial of service, data tampering, or privilege escalation. The vulnerability arises from the use of a shared cache directory instead of a user-specific one, making it susceptible to local data tampering and denial of service.

Record
CVE-2025-7707
CVSS 3.0
7.1 HighCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H
Weakness
CWE-377
Updated
2026-11-02
OSVGHSA-rg9h-vx28-xxp5 7.1

llama-index has Insecure Temporary File

The llama_index library version 0.12.33 sets the NLTK data directory to a subdirectory of the codebase by default, which is world-writable in multi-user environments. This configuration allows local users to overwrite, delete, or corrupt NLTK data files, leading to potential denial of service, data tampering, or privilege escalation. The vulnerability arises from the use of a shared cache directory instead of a user-specific one, making it susceptible to local data tampering and denial of service.

Record
GHSA-rg9h-vx28-xxp5
CVSS 3.0
7.1 HighCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H
Weakness
CWE-377
Updated
2026-11-02
OSVPYSEC-2026-1556 7.1

llama-index has Insecure Temporary File

The llama_index library version 0.12.33 sets the NLTK data directory to a subdirectory of the codebase by default, which is world-writable in multi-user environments. This configuration allows local users to overwrite, delete, or corrupt NLTK data files, leading to potential denial of service, data tampering, or privilege escalation. The vulnerability arises from the use of a shared cache directory instead of a user-specific one, making it susceptible to local data tampering and denial of service.

Record
PYSEC-2026-1556
CVSS 3.0
7.1 HighCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
llama-index
PyPI
before 0.13.0
0.13.0
llama-index
PyPI
before 0.13.0, plus listed versions
0.10.00.10.10.10.100.10.110.10.12
Show 45 moreShow less
0.10.130.10.13.post10.10.140.10.150.10.160.10.170.10.180.10.190.10.200.10.220.10.230.10.240.10.250.10.260.10.270.10.280.10.290.10.30.10.300.10.310.10.320.10.330.10.340.10.350.10.360.10.370.10.380.10.390.10.40.10.400.10.410.10.420.10.430.10.440.10.450.10.45.post10.10.460.10.470.10.480.10.48.post10.10.490.10.50.10.500.10.510.10.52
0.13.0

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2025-7707 is a high vulnerability (CVSS 7.1) in Llamaindex, published October 13, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.19%, the 8th percentile. Fixed in llama-index 0.13.0.

References

This page doesn't list everything

Left out here: 424 versions. The JSON record has them.

MoveEnter Open