Every CVE Search/ Get API key

CVE-2026-100140

Integer overflow vulnerability in XML parsing functionality of Qt5Compat impacts Qt

1.9 LowFix available

An integer overflow vulnerability in the Qt XML parsing (Qt5Compat / QXmlSimpleReader) functionality of Qt.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Passive

What an attacker can affect

Confidentiality
None
Integrity
Low
Availability
High

Exploit likelihood

0.17%Unchanged since Nov 3, 2026
90%50%10%1%

What each source reports

CVE List Score used 1.9

Integer overflow vulnerability in XML parsing functionality of Qt5Compat impacts Qt

An integer overflow vulnerability in the Qt XML parsing (Qt5Compat / QXmlSimpleReader) functionality of Qt.

Record
CVE-2026-100140
CVSS 4.0
1.9 LowCVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:P/VC:N/VI:L/VA:H/SC:N/SI:N/SA:N/E:U/R:U/U:Green
Weakness
CWE-190
Updated
2026-11-02
EUVDEUVD-2026-115135 1.9

An integer overflow vulnerability in the Qt XML parsing (Qt5Compat / QXmlSimpleReader) functionality of Qt.

Record
EUVD-2026-115135
CVSS 4.0
1.9 LowCVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:P/VC:N/VI:L/VA:H/SC:N/SI:N/SA:N/E:U/R:U/U:Green
Updated
2026-11-03
GitHub AdvisoriesGHSA-7695-pqx4-vc24 1.9

An integer overflow vulnerability in the Qt XML parsing (Qt5Compat / QXmlSimpleReader)...

An integer overflow vulnerability in the Qt XML parsing (Qt5Compat / QXmlSimpleReader) functionality of Qt.

Record
GHSA-7695-pqx4-vc24
CVSS 4.0
1.9 LowCVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:P/VC:N/VI:L/VA:H/SC:N/SI:N/SA:N/E:U/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:U/V:X/RE:X/U:Green
Weakness
CWE-190
Updated
2026-11-02
NVD 1.9

An integer overflow vulnerability in the Qt XML parsing (Qt5Compat / QXmlSimpleReader) functionality of Qt.

Record
CVE-2026-100140
CVSS 4.0
1.9 LowCVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:P/VC:N/VI:L/VA:H/SC:N/SI:N/SA:N/E:U/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:U/V:X/RE:X/U:Green
Weakness
CWE-190
Updated
2026-11-03
OSVDEBIAN-CVE-2026-100140 1.9

An integer overflow vulnerability in the Qt XML parsing (Qt5Compat / QXmlSimpleReader) functionality of Qt.

Record
DEBIAN-CVE-2026-100140
CVSS 4.0
1.9 LowCVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:P/VC:N/VI:L/VA:H/SC:N/SI:N/SA:N/E:U/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:U/V:X/RE:X/U:Green
Updated
2026-11-07
OSVUBUNTU-CVE-2026-100140 1.9

An integer overflow vulnerability in the Qt XML parsing (Qt5Compat / QXmlSimpleReader) functionality of Qt.

Record
UBUNTU-CVE-2026-100140
CVSS 4.0
1.9 LowCVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:P/VC:N/VI:L/VA:H/SC:N/SI:N/SA:N/E:U/R:U/U:Green
Updated
2026-11-05
OSVopenSUSE-SU-2026:12442-1 No score

libQt6Core5Compat6-6.12.0-2.1 on GA media

These are all security issues fixed in the libQt6Core5Compat6-6.12.0-2.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2026:12442-1
Updated
2026-11-06

Affected products

Affected packages

Affected packages
PackageAffectedFixed
qt6-5compat
Debian:12
All versions, plus listed versions
6.10.2-16.10.2-26.10.2-36.10.2-46.11.2-1
Show 21 moreShow less
6.11.2-26.11.2-36.4.2-16.4.2-26.4.2-36.4.2-46.6.1-16.6.1-26.6.2-16.6.2-26.7.2-16.7.2-26.7.2-36.8.2-16.8.2-26.8.2-36.9.1-16.9.1-26.9.2-16.9.2-26.9.2-3
None known
qt6-5compat
Debian:13
All versions, plus listed versions
6.10.2-16.10.2-26.10.2-36.10.2-46.11.2-1
Show 8 moreShow less
6.11.2-26.11.2-36.8.2-36.9.1-16.9.1-26.9.2-16.9.2-26.9.2-3
None known
qt6-5compat
Debian:14
All versions, plus listed versions
6.10.2-16.10.2-26.10.2-36.10.2-46.11.2-1
Show 8 moreShow less
6.11.2-26.11.2-36.8.2-36.9.1-16.9.1-26.9.2-16.9.2-26.9.2-3
None known
qt6-5compat
Ubuntu:22.04:LTS
All versions, plus listed versions
6.2.2-56.2.4-1
None known
qt6-5compat
Ubuntu:24.04:LTS
All versions, plus listed versions
6.4.2-36.4.2-46.4.2-4build16.4.2-4build26.4.2-4build3
None known
qt6-5compat
Ubuntu:26.10
All versions, plus listed versions
6.10.2-16.10.2-36.10.2-46.11.2-1
None known
qt6-5compat
Ubuntu:26.04:LTS
All versions, plus listed versions
6.9.2-16.9.2-36.9.2-3build16.10.2-1
None known
qt6-qt5compat
openSUSE:Tumbleweed
before 6.12.0-2.1
6.12.0-2.1

History

History
RecordedChangedSources
affected, aliases, referencesOSV
affected, aliases, facts, referencesOSV
affected, aliases, facts, referencesEUVD, NVD, OSV
first indexedCVE List, EUVD, GitHub Advisories, NVD

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2026-100140 is a low vulnerability (CVSS 1.9) in Qt, published November 2, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.17%, the 5th percentile. Fixed in qt6-qt5compat 6.12.0-2.1.

References

Show 5 moreShow less
MoveEnter Open