Every CVE Search/ Get API key

CVE-2026-100300

Apache ZooKeeper: Unauthenticated persistent denial of service via unvalidated quota-node data and paths crashing the transaction-apply thread

8.7 High

Improper handling of exceptional conditions in the quota subsystem of Apache ZooKeeper allows an attacker able to write under the /zookeeper/quota subtree — unauthenticated on default deployments, where that subtree is world-writable — to crash the server's critical request-processing thread and render the on-disk data directory permanently unbootable.

This issue affects Apache ZooKeeper up to and including 3.9.6. Users are recommended to upgrade to version 3.8.8 or 3.9.7, which fixes the issue.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

0.48%Unchanged since Nov 5, 2026
90%50%10%1%

What each source reports

CVE List Score used 8.7

Apache ZooKeeper: Unauthenticated persistent denial of service via unvalidated quota-node data and paths crashing the transaction-apply thread

Improper handling of exceptional conditions in the quota subsystem of Apache ZooKeeper allows an attacker able to write under the /zookeeper/quota subtree — unauthenticated on default deployments, where that subtree is world-writable — to crash the server's critical request-processing thread and render the on-disk data directory permanently unbootable.

This issue affects Apache ZooKeeper up to and including 3.9.6. Users are recommended to upgrade to version 3.8.8 or 3.9.7, which fixes the issue.

Record
CVE-2026-100300
CVSS 4.0
8.7 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
Weakness
CWE-755
Updated
2026-11-04
EUVDEUVD-2026-116868 8.7

Improper handling of exceptional conditions in the quota subsystem of Apache ZooKeeper allows an attacker able to write under the /zookeeper/quota subtree — unauthenticated on default deployments, where that subtree is world-writable — to crash the server's critical request-processing thread and render the on-disk data directory permanently unbootable.

This issue affects Apache ZooKeeper up to and including 3.9.6. Users are recommended to upgrade to version 3.8.8 or 3.9.7, which fixes the issue.

Record
EUVD-2026-116868
CVSS 4.0
8.7 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
Updated
2026-11-04
GitHub AdvisoriesGHSA-7xqw-mw2f-8c7x 8.7

Improper handling of exceptional conditions in the quota subsystem of Apache ZooKeeper allows an...

Improper handling of exceptional conditions in the quota subsystem of Apache ZooKeeper allows an attacker able to write under the /zookeeper/quota subtree — unauthenticated on default deployments, where that subtree is world-writable — to crash the server's critical request-processing thread and render the on-disk data directory permanently unbootable.

This issue affects Apache ZooKeeper up to and including 3.9.6. Users are recommended to upgrade to version 3.8.8 or 3.9.7, which fixes the issue.

Record
GHSA-7xqw-mw2f-8c7x
CVSS 4.0
8.7 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Weakness
CWE-755
Updated
2026-11-04
NVD 8.7

Improper handling of exceptional conditions in the quota subsystem of Apache ZooKeeper allows an attacker able to write under the /zookeeper/quota subtree — unauthenticated on default deployments, where that subtree is world-writable — to crash the server's critical request-processing thread and render the on-disk data directory permanently unbootable.

This issue affects Apache ZooKeeper up to and including 3.9.6. Users are recommended to upgrade to version 3.8.8 or 3.9.7, which fixes the issue.

Record
CVE-2026-100300
CVSS 4.0
8.7 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Weakness
CWE-755
Updated
2026-11-04
OSVDEBIAN-CVE-2026-100300 8.7

Improper handling of exceptional conditions in the quota subsystem of Apache ZooKeeper allows an attacker able to write under the /zookeeper/quota subtree — unauthenticated on default deployments, where that subtree is world-writable — to crash the server's critical request-processing thread and render the on-disk data directory permanently unbootable. This issue affects Apache ZooKeeper up to and including 3.9.6. Users are recommended to upgrade to version 3.8.8 or 3.9.7, which fixes the issue.

Record
DEBIAN-CVE-2026-100300
CVSS 4.0
8.7 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Updated
2026-11-06
OSVUBUNTU-CVE-2026-100300 8.7

Improper handling of exceptional conditions in the quota subsystem of Apache ZooKeeper allows an attacker able to write under the /zookeeper/quota subtree — unauthenticated on default deployments, where that subtree is world-writable — to crash the server's critical request-processing thread and render the on-disk data directory permanently unbootable. This issue affects Apache ZooKeeper up to and including 3.9.6. Users are recommended to upgrade to version 3.8.8 or 3.9.7, which fixes the issue.

Record
UBUNTU-CVE-2026-100300
CVSS 4.0
8.7 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
Updated
2026-11-06

Affected products

Affected packages

Affected packages
PackageAffectedFixed
zookeeper
Debian:12
All versions, plus listed versions
3.8.0-113.8.0-11+deb12u13.8.0-11+deb12u23.9.1-13.9.2-1
Show 10 moreShow less
3.9.2-23.9.3-13.9.3-23.9.4-13.9.4-23.9.5-13.9.5-23.9.6-13.9.6-23.9.6-3
None known
zookeeper
Debian:13
All versions, plus listed versions
3.9.3-13.9.3-1+deb13u13.9.3-23.9.4-13.9.4-2
Show 5 moreShow less
3.9.5-13.9.5-23.9.6-13.9.6-23.9.6-3
None known
zookeeper
Debian:14
All versions, plus listed versions
3.9.3-13.9.3-23.9.4-13.9.4-23.9.5-1
Show 4 moreShow less
3.9.5-23.9.6-13.9.6-23.9.6-3
None known
zookeeper
Ubuntu:Pro:14.04:LTS
All versions, plus listed versions
3.4.5+dfsg-13.4.5+dfsg-1ubuntu0.1~esm13.4.5+dfsg-1ubuntu0.1~esm3
None known
zookeeper
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
3.4.6-83.4.7-13.4.8-13.4.8-1ubuntu0.1~esm13.4.8-1ubuntu0.1~esm2
None known
zookeeper
Ubuntu:Pro:18.04:LTS
All versions, plus listed versions
3.4.10-23.4.10-33.4.13-33.4.13-3ubuntu0.1~esm1
None known
zookeeper
Ubuntu:20.04:LTS
All versions, plus listed versions
3.4.13-13.4.13-33.4.13-3build13.4.13-43.4.13-53.4.13-5build13.4.13-5ubuntu0.1
None known
zookeeper
Ubuntu:22.04:LTS
All versions, plus listed versions
3.4.13-5ubuntu43.4.13-6ubuntu23.4.13-6ubuntu33.4.13-6ubuntu43.4.13-6ubuntu4.1
None known
zookeeper
Ubuntu:24.04:LTS
All versions, plus listed versions
3.8.0-113.9.1-13.9.1-1build13.9.1-1build2
None known
zookeeper
Ubuntu:26.10
All versions, plus listed versions
3.9.5-13.9.5-2
None known
zookeeper
Ubuntu:26.04:LTS
All versions, plus listed versions
3.9.3-1build23.9.3-1build33.9.4-13.9.5-1
None known

History

History
RecordedChangedSources
affected, aliases, referencesOSV
affected, aliases, referencesCVE List, EUVD, NVD, OSV
publishedEUVD
publishedEUVD, NVD
referencesCVE List
aliases, referencesGitHub Advisories
aliases, publishedEUVD
first indexedCVE List

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2026-100300 is a high vulnerability (CVSS 8.7) in Apache Software Foundation Zookeeper, published November 4, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.48%, the 42nd percentile. No source names a fixed version.

References

MoveEnter Open