Every CVE Search/ Get API key

CVE-2026-100310

GNU libextractor before 1.16 Privilege Escalation via LIBEXTRACTOR_PREFIX

7.3 HighFix available

GNU libextractor before 1.16 loads plugins from an untrusted search path specified by the LIBEXTRACTOR_PREFIX environment variable without proper privilege checks. A local attacker can exploit this by setting LIBEXTRACTOR_PREFIX to a directory containing a malicious plugin that executes arbitrary code with elevated privileges when loaded by a setuid or setgid program.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

0.14%Unchanged since Sep 26, 2026
90%50%10%1%

What each source reports

CVE List Score used 7.3

GNU libextractor before 1.16 Privilege Escalation via LIBEXTRACTOR_PREFIX

GNU libextractor before 1.16 loads plugins from an untrusted search path specified by the LIBEXTRACTOR_PREFIX environment variable without proper privilege checks. A local attacker can exploit this by setting LIBEXTRACTOR_PREFIX to a directory containing a malicious plugin that executes arbitrary code with elevated privileges when loaded by a setuid or setgid program.

Record
CVE-2026-100310
CVSS 4.0
7.3 HighCVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
CVSS 3.1
7.0 HighCVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-426
Updated
2026-11-02
EUVDEUVD-2026-87314 7.3

GNU libextractor before 1.16 loads plugins from an untrusted search path specified by the LIBEXTRACTOR_PREFIX environment variable without proper privilege checks. A local attacker can exploit this by setting LIBEXTRACTOR_PREFIX to a directory containing a malicious plugin that executes arbitrary code with elevated privileges when loaded by a setuid or setgid program.

Record
EUVD-2026-87314
CVSS 4.0
7.3 HighCVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
Updated
2026-11-02
GitHub AdvisoriesGHSA-rxpm-xfjv-mq65 7.3

GNU libextractor before 1.16 loads plugins from an untrusted search path specified by the...

GNU libextractor before 1.16 loads plugins from an untrusted search path specified by the LIBEXTRACTOR_PREFIX environment variable without proper privilege checks. A local attacker can exploit this by setting LIBEXTRACTOR_PREFIX to a directory containing a malicious plugin that executes arbitrary code with elevated privileges when loaded by a setuid or setgid program.

Record
GHSA-rxpm-xfjv-mq65
CVSS 4.0
7.3 HighCVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.1
7.0 HighCVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-426
Updated
2026-11-02
NVD 7.3

GNU libextractor before 1.16 loads plugins from an untrusted search path specified by the LIBEXTRACTOR_PREFIX environment variable without proper privilege checks. A local attacker can exploit this by setting LIBEXTRACTOR_PREFIX to a directory containing a malicious plugin that executes arbitrary code with elevated privileges when loaded by a setuid or setgid program.

Record
CVE-2026-100310
CVSS 4.0
7.3 HighCVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.1
7.0 HighCVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-426
Updated
2026-11-02
OSVDEBIAN-CVE-2026-100310 7.3

GNU libextractor before 1.16 loads plugins from an untrusted search path specified by the LIBEXTRACTOR_PREFIX environment variable without proper privilege checks. A local attacker can exploit this by setting LIBEXTRACTOR_PREFIX to a directory containing a malicious plugin that executes arbitrary code with elevated privileges when loaded by a setuid or setgid program.

Record
DEBIAN-CVE-2026-100310
CVSS 4.0
7.3 HighCVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Updated
2026-11-02
OSVUBUNTU-CVE-2026-100310 7.3

GNU libextractor before 1.16 loads plugins from an untrusted search path specified by the LIBEXTRACTOR_PREFIX environment variable without proper privilege checks. A local attacker can exploit this by setting LIBEXTRACTOR_PREFIX to a directory containing a malicious plugin that executes arbitrary code with elevated privileges when loaded by a setuid or setgid program.

Record
UBUNTU-CVE-2026-100310
CVSS 4.0
7.3 HighCVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
CVSS 3.1
7.0 HighCVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2026-0484 No score

Updated libextractor package fixes security vulnerabilities

GNU libextractor before 1.15 Stack Overflow via OLE2. (CVE-2026-91752) GNU libextractor before 1.16 Privilege Escalation via LIBEXTRACTOR_PREFIX. (CVE-2026-100310)

Record
MGASA-2026-0484
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libextractor
Debian:12
All versions, plus listed versions
1:1.11-71:1.11-81:1.13-11:1.13-101:1.13-2
Show 11 moreShow less
1:1.13-31:1.13-41:1.13-4+loong641:1.13-51:1.13-61:1.13-71:1.13-81:1.13-91:1.17-11:1.19-11:1.19-2
None known
libextractor
Debian:13
All versions, plus listed versions
1:1.13-101:1.13-81:1.13-91:1.17-11:1.19-11:1.19-2
None known
libextractor
Debian:14
before 1:1.17-1, plus listed versions
1:1.13-101:1.13-81:1.13-9
1:1.17-1
libextractor
Mageia:10
From an advisory covering 2 CVEs
before 1.16-1.mga10
1.16-1.mga10
libextractor
Ubuntu:Pro:14.04:LTS
All versions, plus listed versions
1:1.1-1ubuntu11:1.2-1ubuntu11:1.3-11:1.3-1ubuntu0.1~esm1
None known
libextractor
Ubuntu:16.04:LTS
All versions, plus listed versions
1:1.3-2build11:1.3-2ubuntu11:1.3-31:1.3-4+deb9u3build0.16.04.1
None known
libextractor
Ubuntu:18.04:LTS
All versions, plus listed versions
1:1.3-4build31:1.6-11:1.6-1build11:1.6-2
None known
libextractor
Ubuntu:20.04:LTS
All versions, plus listed versions
1:1.9-21:1.9-2ubuntu11:1.9-3
None known
libextractor
Ubuntu:22.04:LTS
All versions, plus listed versions
1:1.11-5
None known
libextractor
Ubuntu:24.04:LTS
All versions, plus listed versions
1:1.11-81:1.13-31:1.13-3build21:1.13-3build3
None known
libextractor
Ubuntu:26.10
All versions, plus listed versions
1:1.13-91:1.13-101:1.19-2
None known
libextractor
Ubuntu:26.04:LTS
All versions, plus listed versions
1:1.13-8build11:1.13-9
None known

History

History
RecordedChangedSources
affected, facts
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2026-100310 is a high vulnerability (CVSS 7.3) in Gnu Libextractor, published September 25, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.14%, the 3rd percentile. Fixed in libextractor 1:1.17-1.

References

Show 9 moreShow less
MoveEnter Open