Every CVE Search/ Get API key

CVE-2026-102875

VLC media player before 3.0.24 Path Traversal via skins2

8.5 HighFix available

VLC media player before 3.0.24 contains a path traversal vulnerability in the skins2 ThemeLoader that fails to validate member names in .vlt skin archives. Attackers can craft malicious skin files with path traversal sequences to write arbitrary files with VLC user privileges, enabling code execution through Lua script injection.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Passive

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

0.17%Unchanged since Sep 30, 2026
90%50%10%1%

What each source reports

CVE List Score used 8.5

VLC media player before 3.0.24 Path Traversal via skins2

VLC media player before 3.0.24 contains a path traversal vulnerability in the skins2 ThemeLoader that fails to validate member names in .vlt skin archives. Attackers can craft malicious skin files with path traversal sequences to write arbitrary files with VLC user privileges, enabling code execution through Lua script injection.

Record
CVE-2026-102875
CVSS 4.0
8.5 HighCVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-22
Updated
2026-11-02
EUVDEUVD-2026-89410 8.5

VLC media player before 3.0.24 contains a path traversal vulnerability in the skins2 ThemeLoader that fails to validate member names in .vlt skin archives. Attackers can craft malicious skin files with path traversal sequences to write arbitrary files with VLC user privileges, enabling code execution through Lua script injection.

Record
EUVD-2026-89410
CVSS 4.0
8.5 HighCVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
Updated
2026-11-02
GitHub AdvisoriesGHSA-g288-22w4-chf6 8.5

VLC media player before 3.0.24 contains a path traversal vulnerability in the skins2 ThemeLoader...

VLC media player before 3.0.24 contains a path traversal vulnerability in the skins2 ThemeLoader that fails to validate member names in .vlt skin archives. Attackers can craft malicious skin files with path traversal sequences to write arbitrary files with VLC user privileges, enabling code execution through Lua script injection.

Record
GHSA-g288-22w4-chf6
CVSS 4.0
8.5 HighCVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-22
Updated
2026-11-02
NVD 8.5

VLC media player before 3.0.24 contains a path traversal vulnerability in the skins2 ThemeLoader that fails to validate member names in .vlt skin archives. Attackers can craft malicious skin files with path traversal sequences to write arbitrary files with VLC user privileges, enabling code execution through Lua script injection.

Record
CVE-2026-102875
CVSS 4.0
8.5 HighCVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-22
Updated
2026-11-02
OSVDEBIAN-CVE-2026-102875 8.5

VLC media player before 3.0.24 contains a path traversal vulnerability in the skins2 ThemeLoader that fails to validate member names in .vlt skin archives. Attackers can craft malicious skin files with path traversal sequences to write arbitrary files with VLC user privileges, enabling code execution through Lua script injection.

Record
DEBIAN-CVE-2026-102875
CVSS 4.0
8.5 HighCVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Updated
2026-11-02
OSVUBUNTU-CVE-2026-102875 8.5

VLC media player before 3.0.24 contains a path traversal vulnerability in the skins2 ThemeLoader that fails to validate member names in .vlt skin archives. Attackers can craft malicious skin files with path traversal sequences to write arbitrary files with VLC user privileges, enabling code execution through Lua script injection.

Record
UBUNTU-CVE-2026-102875
CVSS 4.0
8.5 HighCVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
vlc
Debian:12
before 3.0.24-0+deb12u1, plus listed versions
3.0.18-23.0.18-33.0.18-43.0.19-13.0.20-0+deb12u1
Show 28 moreShow less
3.0.20-13.0.20-23.0.20-33.0.20-43.0.21-0+deb12u13.0.21-13.0.21-103.0.21-113.0.21-23.0.21-33.0.21-43.0.21-4~exp13.0.21-53.0.21-63.0.21-73.0.21-83.0.21-93.0.22-0+deb12u13.0.22-13.0.22-23.0.22-33.0.22-43.0.22~rc1-13.0.22~rc2-13.0.23-0+deb12u13.0.23-13.0.23-23.0.23-3
3.0.24-0+deb12u1
vlc
Debian:13
before 3.0.24-0+deb13u1, plus listed versions
3.0.21-103.0.21-113.0.22-0+deb13u13.0.22-13.0.22-2
Show 8 moreShow less
3.0.22-33.0.22-43.0.22~rc1-13.0.22~rc2-13.0.23-0+deb13u13.0.23-13.0.23-23.0.23-3
3.0.24-0+deb13u1
vlc
Debian:14
before 3.0.24-1, plus listed versions
3.0.21-103.0.21-113.0.22-13.0.22-23.0.22-3
Show 6 moreShow less
3.0.22-43.0.22~rc1-13.0.22~rc2-13.0.23-13.0.23-23.0.23-3
3.0.24-1
vlc
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
2.2.1-32.2.1-52.2.2-12.2.2-22.2.2-3
Show 11 moreShow less
2.2.2-3build12.2.2-42.2.2-52.2.2-5ubuntu0.16.04.12.2.2-5ubuntu0.16.04.22.2.2-5ubuntu0.16.04.32.2.2-5ubuntu0.16.04.42.2.2-5ubuntu0.16.04.5+esm12.2.2-5ubuntu0.16.04.5+esm22.2.2-5ubuntu0.16.04.5+esm32.2.2-5ubuntu0.16.04.5+esm4
None known
vlc
Ubuntu:Pro:18.04:LTS
All versions, plus listed versions
2.2.6-62.2.6-6build12.2.7-12.2.8-12.2.8-1ubuntu4
Show 23 moreShow less
2.2.8-23.0.0~rc1-1ubuntu13.0.0~rc1-1ubuntu33.0.0~rc2-1ubuntu13.0.0~rc2-2ubuntu13.0.0~rc2-2ubuntu23.0.0~rc4-1ubuntu13.0.0~rc7-2ubuntu13.0.0~rc8-1ubuntu13.0.0-1ubuntu13.0.1-1ubuntu53.0.1-2ubuntu13.0.1-2ubuntu23.0.1-33.0.1-3build13.0.2-0ubuntu0.13.0.3-1-1ubuntu13.0.4-1ubuntu0.23.0.7.1-0ubuntu18.04.13.0.8-0ubuntu18.04.13.0.8-0ubuntu18.04.1+esm13.0.8-0ubuntu18.04.1+esm23.0.8-0ubuntu18.04.1+esm3
None known
vlc
Ubuntu:Pro:20.04:LTS
All versions, plus listed versions
3.0.8-23.0.8-2build13.0.8-33.0.8-3build13.0.8-3build2
Show 6 moreShow less
3.0.8-3build43.0.8-43.0.9.2-13.0.9.2-1ubuntu0.1~esm13.0.9.2-1ubuntu0.1~esm23.0.9.2-1ubuntu0.1~esm3
None known
vlc
Ubuntu:Pro:22.04:LTS
All versions, plus listed versions
3.0.16-13.0.16-1build13.0.16-1build23.0.16-1build33.0.16-1build4
Show 5 moreShow less
3.0.16-1build53.0.16-1build73.0.16-1ubuntu0.1~esm13.0.16-1ubuntu0.1~esm23.0.16-1ubuntu0.1~esm3
None known
vlc
Ubuntu:Pro:24.04:LTS
All versions, plus listed versions
3.0.18-43.0.19-13.0.19-1build13.0.20-1build13.0.20-3build63.0.20-3ubuntu0.1~esm1
None known
vlc
Ubuntu:26.10
All versions, plus listed versions
3.0.23-13.0.23-33.0.23-3build13.0.24-13.0.24-1ubuntu1
None known
vlc
Ubuntu:26.04:LTS
All versions, plus listed versions
3.0.21-113.0.22~rc1-13.0.22~rc1-1build13.0.22~rc1-1build23.0.22~rc1-1build3
Show 6 moreShow less
3.0.22~rc2-13.0.22-13.0.22-23.0.22-2build13.0.22-43.0.23-1
None known

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2026-102875 is a high vulnerability (CVSS 8.5) in Videolan Vlc, published September 29, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.17%, the 6th percentile. Fixed in vlc 3.0.24-0+deb12u1.

References

Show 4 moreShow less
MoveEnter Open