CVE-2026-103552
Apache Directory LDAP API: A unbound client can send a deeply nested search filter that overflows the stack in the server's decoder
Stack Overflow vulnerability in Apache Directory LDAP API.
Before binding, a client can send a deeply nested search filter that overflows the stack in the server's decoder.
This issue affects Apache Directory LDAP API: from 1.2.0 before 1.2.9.
Users are recommended to upgrade to version 1.2.9, which fixes the issue.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- Low
Exploit likelihood
What each source reports
CVE List Score used
7.3
Apache Directory LDAP API: A unbound client can send a deeply nested search filter that overflows the stack in the server's decoder
Stack Overflow vulnerability in Apache Directory LDAP API.
Before binding, a client can send a deeply nested search filter that overflows the stack in the server's decoder.
This issue affects Apache Directory LDAP API: from 1.2.0 before 1.2.9.
Users are recommended to upgrade to version 1.2.9, which fixes the issue.
- Record
CVE-2026-103552- CVSS 3.1
- 7.3 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L - Weakness
- CWE-121
- Updated
- 2026-11-02
EUVDEUVD-2026-91382
7.3
Stack Overflow vulnerability in Apache Directory LDAP API.
Before binding, a client can send a deeply nested search filter that overflows the stack in the server's decoder.
This issue affects Apache Directory LDAP API: from 1.2.0 before 1.2.9.
Users are recommended to upgrade to version 1.2.9, which fixes the issue.
- Record
EUVD-2026-91382- CVSS 3.1
- 7.3 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-mggr-349m-j697
7.3
Stack Overflow vulnerability in Apache Directory LDAP API. Before binding, a client can send a...
Stack Overflow vulnerability in Apache Directory LDAP API.
Before binding, a client can send a deeply nested search filter that overflows the stack in the server's decoder.
This issue affects Apache Directory LDAP API: from 1.2.0 before 1.2.9.
Users are recommended to upgrade to version 1.2.9, which fixes the issue.
- Record
GHSA-mggr-349m-j697- CVSS 3.1
- 7.3 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L - Weakness
- CWE-121
- Updated
- 2026-11-02
NVD
7.3
Stack Overflow vulnerability in Apache Directory LDAP API.
Before binding, a client can send a deeply nested search filter that overflows the stack in the server's decoder.
This issue affects Apache Directory LDAP API: from 1.2.0 before 1.2.9.
Users are recommended to upgrade to version 1.2.9, which fixes the issue.
- Record
CVE-2026-103552- CVSS 3.1
- 7.3 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L - Weakness
- CWE-121
- Updated
- 2026-11-02
OSVDEBIAN-CVE-2026-103552
7.3
Stack Overflow vulnerability in Apache Directory LDAP API. Before binding, a client can send a deeply nested search filter that overflows the stack in the server's decoder. This issue affects Apache Directory LDAP API: from 1.2.0 before 1.2.9. Users are recommended to upgrade to version 1.2.9, which fixes the issue.
- Record
DEBIAN-CVE-2026-103552- CVSS 3.1
- 7.3 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L - Updated
- 2026-11-02
OSVUBUNTU-CVE-2026-103552
7.3
Stack Overflow vulnerability in Apache Directory LDAP API. Before binding, a client can send a deeply nested search filter that overflows the stack in the server's decoder. This issue affects Apache Directory LDAP API: from 1.2.0 before 1.2.9. Users are recommended to upgrade to version 1.2.9, which fixes the issue.
- Record
UBUNTU-CVE-2026-103552- CVSS 3.1
- 7.3 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
apache-directory-apiDebian:12 |
All versions, plus listed versions 2.1.2-12.1.2-2 |
None known |
apache-directory-apiDebian:13 |
All versions, plus listed versions 2.1.2-2 |
None known |
apache-directory-apiDebian:14 |
All versions, plus listed versions 2.1.2-2 |
None known |
apache-directory-apiUbuntu:16.04:LTS |
All versions, plus listed versions 1.0.0~M20-3 |
None known |
apache-directory-apiUbuntu:18.04:LTS |
All versions, plus listed versions 1.0.0~M20-51.0.0-1 |
None known |
apache-directory-apiUbuntu:20.04:LTS |
All versions, plus listed versions 1.0.0-1 |
None known |
apache-directory-apiUbuntu:22.04:LTS |
All versions, plus listed versions 1.0.0-2 |
None known |
apache-directory-apiUbuntu:24.04:LTS |
All versions, plus listed versions 2.1.2-1 |
None known |
apache-directory-apiUbuntu:26.10 |
All versions, plus listed versions 2.1.2-2build1 |
None known |
apache-directory-apiUbuntu:26.04:LTS |
All versions, plus listed versions 2.1.2-22.1.2-2build1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2026-103552 is a high vulnerability (CVSS 7.3) in Apache Software Foundation Directory Ldap Api, published October 2, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.33%, the 25th percentile. No source names a fixed version.
References
lists.apache.org/thread.html/fn3bwknn57266hx66w9vv6b4k8rfwcx7
openwall.com/lists/oss-security/2026/10/02/4
nvd.nist.gov/vuln/detail/CVE-2026-103552
github.com/advisories/GHSA-mggr-349m-j697
security-tracker.debian.org/tracker/CVE-2026-103552
ubuntu.com/security/CVE-2026-103552
cve.org/CVERecord?id=CVE-2026-103552