CVE-2026-105643
Ghost: Stored XSS via Embed Card Previews
Ghost is a Node.js content management system. From version 6.34.0 until 6.67.0, embed cards in the Ghost editor could bypass protections against stored cross-site scripting. Any staff user, including Contributors, could store scripts in post content that ran when another staff user opened the post in the editor, potentially compromising that user’s admin session. Self-hosted sites should leave the new security.embedPreviewUrl configuration option at its default value. This issue is fixed in version 6.67.0.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
7.3
Ghost: Stored XSS via Embed Card Previews
Ghost is a Node.js content management system. From version 6.34.0 until 6.67.0, embed cards in the Ghost editor could bypass protections against stored cross-site scripting. Any staff user, including Contributors, could store scripts in post content that ran when another staff user opened the post in the editor, potentially compromising that user’s admin session. Self-hosted sites should leave the new security.embedPreviewUrl configuration option at its default value. This issue is fixed in version 6.67.0.
- Record
CVE-2026-105643- CVSS 3.1
- 7.3 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N - Weakness
- CWE-79, CWE-653
- Updated
- 2026-11-02
EUVDEUVD-2026-92632
7.3
Ghost is a Node.js content management system. From version 6.34.0 until 6.67.0, embed cards in the Ghost editor could bypass protections against stored cross-site scripting. Any staff user, including Contributors, could store scripts in post content that ran when another staff user opened the post in the editor, potentially compromising that user’s admin session. Self-hosted sites should leave the new security.embedPreviewUrl configuration option at its default value. This issue is fixed in version 6.67.0.
- Record
EUVD-2026-92632- CVSS 3.1
- 7.3 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-69qc-f5m6-889c
7.3
Ghost: Stored XSS via Embed Card Previews
Impact
Embed cards in the Ghost editor could be used to bypass the fix for GHSA-8vhf-xxpj-4qrg. Any staff user, including Contributors, could store scripts in post content that ran when another staff user opened the post in the editor, possibly resulting in compromise of that user's admin session.
Self-hosted sites should leave the new security.embedPreviewUrl config option at its default.
Vulnerable versions
This vulnerability is present in Ghost from v6.34.0 up to v6.65.0.
Patches
v6.67.0 contains a fix for this issue.
How to update
For self-hosters using Docker, find Docker's official Ghost image here. Updating a Docker-based Ghost instance is documented here.
If your Ghost is a Ghost-CLI install see our documentation on updating it to the latest version here.
References
Ghost thanks DONG2209 (Dong Nguyen) and Pedro Pinho for disclosing this vulnerability responsibly.
For more information
If you have any questions or comments about this advisory, email us at [email protected].
- Record
GHSA-69qc-f5m6-889c- CVSS 3.1
- 7.3 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N - Weakness
- CWE-79, CWE-653
- Updated
- 2026-11-02
NVD
7.3
Ghost is a Node.js content management system. From version 6.34.0 until 6.67.0, embed cards in the Ghost editor could bypass protections against stored cross-site scripting. Any staff user, including Contributors, could store scripts in post content that ran when another staff user opened the post in the editor, potentially compromising that user’s admin session. Self-hosted sites should leave the new security.embedPreviewUrl configuration option at its default value. This issue is fixed in version 6.67.0.
- Record
CVE-2026-105643- CVSS 3.1
- 7.3 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N - Weakness
- CWE-79, CWE-653
- Updated
- 2026-11-02
OSV
7.3
Ghost: Stored XSS via Embed Card Previews
Ghost is a Node.js content management system. From version 6.34.0 until 6.67.0, embed cards in the Ghost editor could bypass protections against stored cross-site scripting. Any staff user, including Contributors, could store scripts in post content that ran when another staff user opened the post in the editor, potentially compromising that user’s admin session. Self-hosted sites should leave the new security.embedPreviewUrl configuration option at its default value. This issue is fixed in version 6.67.0.
- Record
CVE-2026-105643- CVSS 3.1
- 7.3 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N - Weakness
- CWE-653, CWE-79
- Updated
- 2026-11-02
OSVGHSA-69qc-f5m6-889c
7.3
Ghost: Stored XSS via Embed Card Previews
Impact
Embed cards in the Ghost editor could be used to bypass the fix for GHSA-8vhf-xxpj-4qrg. Any staff user, including Contributors, could store scripts in post content that ran when another staff user opened the post in the editor, possibly resulting in compromise of that user's admin session.
Self-hosted sites should leave the new security.embedPreviewUrl config option at its default.
Vulnerable versions
This vulnerability is present in Ghost from v6.34.0 up to v6.65.0.
Patches
v6.67.0 contains a fix for this issue.
How to update
For self-hosters using Docker, find Docker's official Ghost image here. Updating a Docker-based Ghost instance is documented here.
If your Ghost is a Ghost-CLI install see our documentation on updating it to the latest version here.
References
Ghost thanks DONG2209 (Dong Nguyen) and Pedro Pinho for disclosing this vulnerability responsibly.
For more information
If you have any questions or comments about this advisory, email us at [email protected].
- Record
GHSA-69qc-f5m6-889c- CVSS 3.1
- 7.3 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N - Weakness
- CWE-653, CWE-79
- Updated
- 2026-11-02
OSVBIT-ghost-2026-105643 No score
Ghost: Stored XSS via Embed Card Previews
Ghost is a Node.js content management system. From version 6.34.0 until 6.67.0, embed cards in the Ghost editor could bypass protections against stored cross-site scripting. Any staff user, including Contributors, could store scripts in post content that ran when another staff user opened the post in the editor, potentially compromising that user’s admin session. Self-hosted sites should leave the new security.embedPreviewUrl configuration option at its default value. This issue is fixed in version 6.67.0.
- Record
BIT-ghost-2026-105643- Updated
- 2026-11-02
Affected products
Affected packages
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2026-105643 is a high vulnerability (CVSS 7.3) in Tryghost Ghost, published October 5, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.28%, the 20th percentile. Fixed in ghost 6.67.0.
References
github.com/TryGhost/Ghost/security/advisories/GHSA-69qc-f5m6-889c
github.com/penpot/penpot/security/advisories/GHSA-qvq5-c536-pmx8
nvd.nist.gov/vuln/detail/CVE-2026-105643
github.com/advisories/GHSA-69qc-f5m6-889c
github.com/CVEProject/cvelistV5/tree/main/cves/2026/105xxx/CVE-2026-105643.json
github.com/TryGhost/Ghost