CVE-2026-105677
Ghost: Remote Code Execution via Theme Translation Files
Ghost is a Node.js content management system. From 6.10.3 until 6.64.0, a vulnerability in how Ghost loads theme translation files allowed an authenticated Administrator to execute arbitrary code on the server via a crafted theme. This issue is fixed in version 6.64.0.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- High
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
7.2
Ghost: Remote Code Execution via Theme Translation Files
Ghost is a Node.js content management system. From 6.10.3 until 6.64.0, a vulnerability in how Ghost loads theme translation files allowed an authenticated Administrator to execute arbitrary code on the server via a crafted theme. This issue is fixed in version 6.64.0.
- Record
CVE-2026-105677- CVSS 3.1
- 7.2 High
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-22, CWE-94, CWE-829
- Updated
- 2026-11-02
EUVDEUVD-2026-92767
7.2
Ghost is a Node.js content management system. From 6.10.3 until 6.64.0, a vulnerability in how Ghost loads theme translation files allowed an authenticated Administrator to execute arbitrary code on the server via a crafted theme. This issue is fixed in version 6.64.0.
- Record
EUVD-2026-92767- CVSS 3.1
- 7.2 High
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-jj74-hc2q-xrvm
7.2
Ghost: Remote Code Execution via Theme Translation Files
Impact
A vulnerability in how Ghost loads theme translation files allowed an authenticated Administrator to execute arbitrary code on the server via a crafted theme.
Vulnerable versions
This vulnerability is present in Ghost from v6.10.3 up to v6.64.0.
Patches
v6.64.0 contains a fix for this issue.
How to update
For self-hosters using Docker, find Docker's official Ghost image here. Updating a Docker-based Ghost instance is documented here.
If your Ghost is a Ghost-CLI install see our documentation on updating it to the latest version here.
References
Ghost thanks Miguel Segovia Gil of KPMG, Alemmi, and Tomer-PL for disclosing this vulnerability responsibly.
For more information
If you have any questions or comments about this advisory, email us at [email protected].
- Record
GHSA-jj74-hc2q-xrvm- CVSS 3.1
- 7.2 High
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-22, CWE-94, CWE-829
- Updated
- 2026-11-02
NVD
7.2
Ghost is a Node.js content management system. From 6.10.3 until 6.64.0, a vulnerability in how Ghost loads theme translation files allowed an authenticated Administrator to execute arbitrary code on the server via a crafted theme. This issue is fixed in version 6.64.0.
- Record
CVE-2026-105677- CVSS 3.1
- 7.2 High
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-22, CWE-94, CWE-829
- Updated
- 2026-11-02
OSVCVE-2026-104418
8.6
Ghost from 6.10.3 before 6.64.0 RCE via Theme Translation Files
Ghost from 6.10.3 before 6.64.0 contains a remote code execution vulnerability that allows authenticated administrators to run code by abusing theme translation file loading. Attackers with administrator access can upload a crafted theme containing malicious translation files to execute arbitrary code on the Ghost server.
- Record
CVE-2026-104418- CVSS 4.0
- 8.6 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N - Weakness
- CWE-22
- Updated
- 2026-11-02
OSV
7.2
Ghost: Remote Code Execution via Theme Translation Files
Ghost is a Node.js content management system. From 6.10.3 until 6.64.0, a vulnerability in how Ghost loads theme translation files allowed an authenticated Administrator to execute arbitrary code on the server via a crafted theme. This issue is fixed in version 6.64.0.
- Record
CVE-2026-105677- CVSS 3.1
- 7.2 High
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-22, CWE-829, CWE-94
- Updated
- 2026-11-02
OSVGHSA-jj74-hc2q-xrvm
7.2
Ghost: Remote Code Execution via Theme Translation Files
Impact
A vulnerability in how Ghost loads theme translation files allowed an authenticated Administrator to execute arbitrary code on the server via a crafted theme.
Vulnerable versions
This vulnerability is present in Ghost from v6.10.3 up to v6.64.0.
Patches
v6.64.0 contains a fix for this issue.
How to update
For self-hosters using Docker, find Docker's official Ghost image here. Updating a Docker-based Ghost instance is documented here.
If your Ghost is a Ghost-CLI install see our documentation on updating it to the latest version here.
References
Ghost thanks Miguel Segovia Gil of KPMG, Alemmi, and Tomer-PL for disclosing this vulnerability responsibly.
For more information
If you have any questions or comments about this advisory, email us at [email protected].
- Record
GHSA-jj74-hc2q-xrvm- CVSS 3.1
- 7.2 High
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-22, CWE-829, CWE-94
- Updated
- 2026-11-02
OSVBIT-ghost-2026-104418 No score
Ghost from 6.10.3 before 6.64.0 RCE via Theme Translation Files
Ghost from 6.10.3 before 6.64.0 contains a remote code execution vulnerability that allows authenticated administrators to run code by abusing theme translation file loading. Attackers with administrator access can upload a crafted theme containing malicious translation files to execute arbitrary code on the Ghost server.
- Record
BIT-ghost-2026-104418- Updated
- 2026-11-02
OSVBIT-ghost-2026-105677 No score
Ghost: Remote Code Execution via Theme Translation Files
Ghost is a Node.js content management system. From 6.10.3 until 6.64.0, a vulnerability in how Ghost loads theme translation files allowed an authenticated Administrator to execute arbitrary code on the server via a crafted theme. This issue is fixed in version 6.64.0.
- Record
BIT-ghost-2026-105677- Updated
- 2026-11-02
Affected products
Affected packages
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2026-105677 is a high vulnerability (CVSS 7.2) in Tryghost Ghost, published October 2, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.52%, the 44th percentile. Fixed in ghost 6.64.0.
References
github.com/TryGhost/Ghost/security/advisories/GHSA-jj74-hc2q-xrvm
github.com/TryGhost/Ghost/issues/30635
github.com/TryGhost/Ghost/commit/d2f498694be549074dd5817fd0e8a1371b65df02
github.com/TryGhost/Ghost/releases/tag/v6.64.0
nvd.nist.gov/vuln/detail/CVE-2026-105677
github.com/advisories/GHSA-jj74-hc2q-xrvm
Show 5 moreShow less
nvd.nist.gov/vuln/detail/CVE-2026-104418
vulncheck.com/advisories/ghost-from-6.10.3-before-6.64.0-rce-via-theme-translation-files
github.com/CVEProject/cvelistV5/tree/main/cves/2026/104xxx/CVE-2026-104418.json
github.com/CVEProject/cvelistV5/tree/main/cves/2026/105xxx/CVE-2026-105677.json
github.com/TryGhost/Ghost