Every CVE Search/ Get API key

CVE-2026-109347

Adminer before 6.1.1 RCE via UTF-8 BOM SQLite ATTACH Bypass

8.6 HighFix available

Adminer before 6.1.1 contains a remote code execution vulnerability that allows authenticated SQLite users to bypass ATTACH and VACUUM INTO restrictions by prefixing statements with a UTF-8 byte-order mark. Attackers can attach a database file at a PHP-served path and create a table named with PHP code to execute it as the web server user.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
High
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

0.85%Up 0.2 points since Oct 13, 2026
90%50%10%1%

What each source reports

CVE List Score used 8.6

Adminer before 6.1.1 RCE via UTF-8 BOM SQLite ATTACH Bypass

Adminer before 6.1.1 contains a remote code execution vulnerability that allows authenticated SQLite users to bypass ATTACH and VACUUM INTO restrictions by prefixing statements with a UTF-8 byte-order mark. Attackers can attach a database file at a PHP-served path and create a table named with PHP code to execute it as the web server user.

Record
CVE-2026-109347
CVSS 4.0
8.6 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
CVSS 3.1
7.2 HighCVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-94
Updated
2026-11-02
EUVDEUVD-2026-97649 8.6

Adminer before 6.1.1 contains a remote code execution vulnerability that allows authenticated SQLite users to bypass ATTACH and VACUUM INTO restrictions by prefixing statements with a UTF-8 byte-order mark. Attackers can attach a database file at a PHP-served path and create a table named with PHP code to execute it as the web server user.

Record
EUVD-2026-97649
CVSS 4.0
8.6 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
Updated
2026-11-02
GitHub AdvisoriesGHSA-q48c-r4q8-5c57 8.6

Adminer before 6.1.1 contains a remote code execution vulnerability that allows authenticated...

Adminer before 6.1.1 contains a remote code execution vulnerability that allows authenticated SQLite users to bypass ATTACH and VACUUM INTO restrictions by prefixing statements with a UTF-8 byte-order mark. Attackers can attach a database file at a PHP-served path and create a table named with PHP code to execute it as the web server user.

Record
GHSA-q48c-r4q8-5c57
CVSS 4.0
8.6 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.1
7.2 HighCVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-94
Updated
2026-11-02
NVD 8.6

Adminer before 6.1.1 contains a remote code execution vulnerability that allows authenticated SQLite users to bypass ATTACH and VACUUM INTO restrictions by prefixing statements with a UTF-8 byte-order mark. Attackers can attach a database file at a PHP-served path and create a table named with PHP code to execute it as the web server user.

Record
CVE-2026-109347
CVSS 4.0
8.6 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.1
7.2 HighCVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-94
Updated
2026-11-02
OSV 8.6

Adminer before 6.1.1 RCE via UTF-8 BOM SQLite ATTACH Bypass

Adminer before 6.1.1 contains a remote code execution vulnerability that allows authenticated SQLite users to bypass ATTACH and VACUUM INTO restrictions by prefixing statements with a UTF-8 byte-order mark. Attackers can attach a database file at a PHP-served path and create a table named with PHP code to execute it as the web server user.

Record
CVE-2026-109347
CVSS 4.0
8.6 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
Weakness
CWE-94
Updated
2026-11-02
OSVDEBIAN-CVE-2026-109347 8.6

Adminer before 6.1.1 contains a remote code execution vulnerability that allows authenticated SQLite users to bypass ATTACH and VACUUM INTO restrictions by prefixing statements with a UTF-8 byte-order mark. Attackers can attach a database file at a PHP-served path and create a table named with PHP code to execute it as the web server user.

Record
DEBIAN-CVE-2026-109347
CVSS 4.0
8.6 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Updated
2026-11-02
OSVUBUNTU-CVE-2026-109347 8.6

Adminer before 6.1.1 contains a remote code execution vulnerability that allows authenticated SQLite users to bypass ATTACH and VACUUM INTO restrictions by prefixing statements with a UTF-8 byte-order mark. Attackers can attach a database file at a PHP-served path and create a table named with PHP code to execute it as the web server user.

Record
UBUNTU-CVE-2026-109347
CVSS 4.0
8.6 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
CVSS 3.1
7.2 HighCVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
adminer
Debian:12
All versions, plus listed versions
4.8.1-14.8.1-24.8.1-45.1.0-15.2.1+dfsg-1
Show 13 moreShow less
5.3.0+dfsg-15.4.0+dfsg-15.4.1+dfsg-15.4.2+dfsg-15.4.3+dfsg-15.4.4+dfsg-16.0.0-16.0.1-16.0.2-16.1.0-16.1.1-16.1.2-16.2.0-1
None known
adminer
Debian:13
All versions, plus listed versions
5.2.1+dfsg-15.3.0+dfsg-15.4.0+dfsg-15.4.1+dfsg-15.4.2+dfsg-1
Show 9 moreShow less
5.4.3+dfsg-15.4.4+dfsg-16.0.0-16.0.1-16.0.2-16.1.0-16.1.1-16.1.2-16.2.0-1
None known
adminer
Debian:14
before 6.1.1-1, plus listed versions
5.2.1+dfsg-15.3.0+dfsg-15.4.0+dfsg-15.4.1+dfsg-15.4.2+dfsg-1
Show 6 moreShow less
5.4.3+dfsg-15.4.4+dfsg-16.0.0-16.0.1-16.0.2-16.1.0-1
6.1.1-1
adminer
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
4.2.1-14.2.1-1ubuntu14.2.1-1ubuntu1+esm1
None known
adminer
Ubuntu:Pro:18.04:LTS
All versions, plus listed versions
4.3.1-24.5.0-14.6.1-14.6.2-14.6.2-1ubuntu0.1~esm1
None known
adminer
Ubuntu:Pro:20.04:LTS
All versions, plus listed versions
4.7.2-14.7.4-14.7.5-14.7.6-14.7.6-1ubuntu0.1~esm1
None known
adminer
Ubuntu:22.04:LTS
All versions, plus listed versions
4.7.9-24.8.1-1
None known
adminer
Ubuntu:24.04:LTS
All versions, plus listed versions
4.8.1-14.8.1-1ubuntu14.8.1-2
None known
adminer
Ubuntu:26.10
All versions, plus listed versions
5.4.1+dfsg-15.4.2+dfsg-15.4.4+dfsg-16.0.0-1
None known
adminer
Ubuntu:26.04:LTS
All versions, plus listed versions
5.2.1+dfsg-15.3.0+dfsg-15.4.0+dfsg-15.4.1+dfsg-1
None known

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2026-109347 is a high vulnerability (CVSS 8.6) in Vrana Adminer, published October 12, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.85%, the 58th percentile. Fixed in adminer 6.1.1-1.

References

MoveEnter Open