Every CVE Search/ Get API key

CVE-2026-112307

sqlparse through 0.6.0 PHP Code Injection via output_format='php'

8.4 HighFix available

sqlparse through 0.6.0 contains a PHP code injection vulnerability that allows attackers to inject PHP expressions by supplying SQL text containing unescaped dollar signs. Attackers can embed ${expr} or {${expr}} sequences that OutputPHPFilter places in double-quoted strings, executing arbitrary PHP code when the generated snippet runs.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Passive

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
Low

Exploit likelihood

0.14%Unchanged since Oct 20, 2026
90%50%10%1%

What each source reports

CVE List Score used 8.4

sqlparse through 0.6.0 PHP Code Injection via output_format='php'

sqlparse through 0.6.0 contains a PHP code injection vulnerability that allows attackers to inject PHP expressions by supplying SQL text containing unescaped dollar signs. Attackers can embed ${expr} or {${expr}} sequences that OutputPHPFilter places in double-quoted strings, executing arbitrary PHP code when the generated snippet runs.

Record
CVE-2026-112307
CVSS 4.0
8.4 HighCVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N
CVSS 3.1
7.3 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:L
Weakness
CWE-94
Updated
2026-11-02
EUVDEUVD-2026-104399 8.4

sqlparse through 0.6.0 contains a PHP code injection vulnerability that allows attackers to inject PHP expressions by supplying SQL text containing unescaped dollar signs. Attackers can embed ${expr} or {${expr}} sequences that OutputPHPFilter places in double-quoted strings, executing arbitrary PHP code when the generated snippet runs.

Record
EUVD-2026-104399
CVSS 4.0
8.4 HighCVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N
Updated
2026-11-02
GitHub AdvisoriesGHSA-457h-p88w-wq8p 8.4

sqlparse through 0.6.0 contains a PHP code injection vulnerability that allows attackers to...

sqlparse through 0.6.0 contains a PHP code injection vulnerability that allows attackers to inject PHP expressions by supplying SQL text containing unescaped dollar signs. Attackers can embed ${expr} or {${expr}} sequences that OutputPHPFilter places in double-quoted strings, executing arbitrary PHP code when the generated snippet runs.

Record
GHSA-457h-p88w-wq8p
CVSS 4.0
8.4 HighCVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.1
7.3 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:L
Weakness
CWE-94
Updated
2026-11-02
NVD 8.4

sqlparse through 0.6.0 contains a PHP code injection vulnerability that allows attackers to inject PHP expressions by supplying SQL text containing unescaped dollar signs. Attackers can embed ${expr} or {${expr}} sequences that OutputPHPFilter places in double-quoted strings, executing arbitrary PHP code when the generated snippet runs.

Record
CVE-2026-112307
CVSS 4.0
8.4 HighCVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.1
7.3 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:L
Weakness
CWE-94
Updated
2026-11-02
OSV 8.4

sqlparse through 0.6.0 PHP Code Injection via output_format='php'

sqlparse through 0.6.0 contains a PHP code injection vulnerability that allows attackers to inject PHP expressions by supplying SQL text containing unescaped dollar signs. Attackers can embed ${expr} or {${expr}} sequences that OutputPHPFilter places in double-quoted strings, executing arbitrary PHP code when the generated snippet runs.

Record
CVE-2026-112307
CVSS 4.0
8.4 HighCVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N
Weakness
CWE-94
Updated
2026-11-03
OSVDEBIAN-CVE-2026-112307 8.4

sqlparse through 0.6.0 contains a PHP code injection vulnerability that allows attackers to inject PHP expressions by supplying SQL text containing unescaped dollar signs. Attackers can embed ${expr} or {${expr}} sequences that OutputPHPFilter places in double-quoted strings, executing arbitrary PHP code when the generated snippet runs.

Record
DEBIAN-CVE-2026-112307
CVSS 4.0
8.4 HighCVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Updated
2026-11-02
OSVUBUNTU-CVE-2026-112307 8.4

sqlparse through 0.6.0 contains a PHP code injection vulnerability that allows attackers to inject PHP expressions by supplying SQL text containing unescaped dollar signs. Attackers can embed ${expr} or {${expr}} sequences that OutputPHPFilter places in double-quoted strings, executing arbitrary PHP code when the generated snippet runs.

Record
UBUNTU-CVE-2026-112307
CVSS 4.0
8.4 HighCVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N
CVSS 3.1
7.3 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:L
Updated
2026-11-02
OSVopenSUSE-SU-2026:12382-1 No score

python313-sqlparse-0.6.0-2.1 on GA media

These are all security issues fixed in the python313-sqlparse-0.6.0-2.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2026:12382-1
Updated
2026-11-02
OSVSUSE-SU-2026:5042-1 No score

Security update for python-sqlparse

This update for python-sqlparse fixes the following issue:

  • CVE-2026-112307: arbitrary code execution via unescaped PHP output formatting (bsc#1286096).
Record
SUSE-SU-2026:5042-1
Updated
2026-11-03

Affected products

Affected packages

Affected packages
PackageAffectedFixed
sqlparse
Debian:12
All versions, plus listed versions
0.4.2-10.4.2-1+deb12u10.4.4-10.5.0-10.5.1-1
Show 6 moreShow less
0.5.1-20.5.2-10.5.3-10.5.4-10.5.5-10.5.5-2
None known
sqlparse
Debian:13
All versions, plus listed versions
0.5.3-10.5.4-10.5.5-10.5.5-2
None known
sqlparse
Debian:14
All versions, plus listed versions
0.5.3-10.5.4-10.5.5-10.5.5-2
None known
python-sqlparse
SUSE:Linux Enterprise Module for Package Hub 15 SP7
before 0.2.4-150100.6.17.1
0.2.4-150100.6.17.1
sqlparse
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
0.1.13-2ubuntu20.1.18-10.1.18-1ubuntu0.1~esm1
None known
sqlparse
Ubuntu:Pro:18.04:LTS
All versions, plus listed versions
0.2.2-10.2.4-0.10.2.4-0.1ubuntu0.10.2.4-0.1ubuntu0.1+esm1
None known
sqlparse
Ubuntu:Pro:20.04:LTS
All versions, plus listed versions
0.2.4-10.2.4-1build10.2.4-20.2.4-30.2.4-3ubuntu0.10.2.4-3ubuntu0.1+esm1
None known
sqlparse
Ubuntu:22.04:LTS
All versions, plus listed versions
0.4.1-1ubuntu10.4.2-10.4.2-1ubuntu0.22.04.10.4.2-1ubuntu0.22.04.20.4.2-1ubuntu0.22.04.3
None known
sqlparse
Ubuntu:24.04:LTS
All versions, plus listed versions
0.4.2-1ubuntu10.4.4-10.4.4-1ubuntu0.10.4.4-1ubuntu0.2
None known
sqlparse
Ubuntu:26.10
All versions, plus listed versions
0.5.4-10.5.5-20.5.5-2ubuntu1
None known
sqlparse
Ubuntu:26.04:LTS
All versions, plus listed versions
0.5.3-10.5.4-10.5.4-1ubuntu0.1
None known
python-sqlparse
openSUSE:Tumbleweed
before 0.6.0-2.1
0.6.0-2.1

History

History
RecordedChangedSources
affected, aliases, referencesOSV
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2026-112307 is a high vulnerability (CVSS 8.4) in Andialbrecht Sqlparse, published October 19, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.14%, the 3rd percentile. Fixed in python-sqlparse 0.2.4-150100.6.17.1.

References

Show 8 moreShow less
MoveEnter Open