Every CVE Search/ Get API key

CVE-2026-11487

Neovim View Branch secure.lua M.read command injection

4.8 MediumFix available

A flaw has been found in Neovim up to 0.12.2. Affected by this issue is the function M.read of the file runtime/lua/vim/secure.lua of the component View Branch. Executing a manipulation of the argument path can lead to command injection. It is possible to launch the attack on the local host. The exploit has been published and may be used. This patch is called f83e0dcaf8cf18de94828341b0a1a61a86c75baf. A patch should be applied to remediate this issue.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
Low

Exploit likelihood

1.01%Up 0.8 points since Jun 8, 2026
90%50%10%1%

What each source reports

CVE List Score used 4.8

Neovim View Branch secure.lua M.read command injection

A flaw has been found in Neovim up to 0.12.2. Affected by this issue is the function M.read of the file runtime/lua/vim/secure.lua of the component View Branch. Executing a manipulation of the argument path can lead to command injection. It is possible to launch the attack on the local host. The exploit has been published and may be used. This patch is called f83e0dcaf8cf18de94828341b0a1a61a86c75baf. A patch should be applied to remediate this issue.

Record
CVE-2026-11487
CVSS 4.0
4.8 MediumCVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P
CVSS 3.1
5.3 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L/E:P/RL:O/RC:C
CVSS 3.0
5.3 MediumCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L/E:P/RL:O/RC:C
CVSS 2.0
4.3 AV:L/AC:L/Au:S/C:P/I:P/A:P/E:POC/RL:OF/RC:C
Weakness
CWE-77, CWE-74
Updated
2026-11-02
EUVDEUVD-2026-35018 4.8

A flaw has been found in Neovim up to 0.12.2. Affected by this issue is the function M.read of the file runtime/lua/vim/secure.lua of the component View Branch. Executing a manipulation of the argument path can lead to command injection. It is possible to launch the attack on the local host. The exploit has been published and may be used. This patch is called f83e0dcaf8cf18de94828341b0a1a61a86c75baf. A patch should be applied to remediate this issue.

Record
EUVD-2026-35018
CVSS 4.0
4.8 MediumCVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P
Updated
2026-11-02
GitHub AdvisoriesGHSA-6869-x4fx-m53f 1.9

A flaw has been found in Neovim up to 0.12.2. Affected by this issue is the function M.read of...

A flaw has been found in Neovim up to 0.12.2. Affected by this issue is the function M.read of the file runtime/lua/vim/secure.lua of the component View Branch. Executing a manipulation of the argument path can lead to command injection. It is possible to launch the attack on the local host. The exploit has been published and may be used. This patch is called f83e0dcaf8cf18de94828341b0a1a61a86c75baf. A patch should be applied to remediate this issue.

Record
GHSA-6869-x4fx-m53f
CVSS 4.0
1.9 LowCVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.1
5.3 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
Weakness
CWE-74
Updated
2026-11-02
NVD 1.9

A flaw has been found in Neovim up to 0.12.2. Affected by this issue is the function M.read of the file runtime/lua/vim/secure.lua of the component View Branch. Executing a manipulation of the argument path can lead to command injection. It is possible to launch the attack on the local host. The exploit has been published and may be used. This patch is called f83e0dcaf8cf18de94828341b0a1a61a86c75baf. A patch should be applied to remediate this issue.

Record
CVE-2026-11487
CVSS 4.0
1.9 LowCVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.1
5.3 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
CVSS 2.0
4.3 MediumAV:L/AC:L/Au:S/C:P/I:P/A:P
Weakness
CWE-74, CWE-77
Updated
2026-11-02
OSV 1.9

Neovim View Branch secure.lua M.read command injection

A flaw has been found in Neovim up to 0.12.2. Affected by this issue is the function M.read of the file runtime/lua/vim/secure.lua of the component View Branch. Executing a manipulation of the argument path can lead to command injection. It is possible to launch the attack on the local host. The exploit has been published and may be used. This patch is called f83e0dcaf8cf18de94828341b0a1a61a86c75baf. A patch should be applied to remediate this issue.

Record
CVE-2026-11487
CVSS 4.0
1.9 LowCVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P
Weakness
CWE-74, CWE-77
Updated
2026-11-02
OSVDEBIAN-CVE-2026-11487 1.9

A flaw has been found in Neovim up to 0.12.2. Affected by this issue is the function M.read of the file runtime/lua/vim/secure.lua of the component View Branch. Executing a manipulation of the argument path can lead to command injection. It is possible to launch the attack on the local host. The exploit has been published and may be used. This patch is called f83e0dcaf8cf18de94828341b0a1a61a86c75baf. A patch should be applied to remediate this issue.

Record
DEBIAN-CVE-2026-11487
CVSS 4.0
1.9 LowCVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Updated
2026-11-02
OSVUBUNTU-CVE-2026-11487 1.9

A flaw has been found in Neovim up to 0.12.2. Affected by this issue is the function M.read of the file runtime/lua/vim/secure.lua of the component View Branch. Executing a manipulation of the argument path can lead to command injection. It is possible to launch the attack on the local host. The exploit has been published and may be used. This patch is called f83e0dcaf8cf18de94828341b0a1a61a86c75baf. A patch should be applied to remediate this issue.

Record
UBUNTU-CVE-2026-11487
CVSS 4.0
1.9 LowCVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P
CVSS 3.1
5.3 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
Updated
2026-11-02

Affected packages

Affected packages
PackageAffectedFixed
neovim
Debian:13
All versions, plus listed versions
0.10.4-80.11.4-10.11.4-20.11.4-30.11.4-4
Show 11 moreShow less
0.11.5-10.11.5-20.11.5-30.11.6-10.12.2-10.12.2-20.12.3-10.12.3-20.12.3-30.12.3-40.12.4-1
None known
neovim
Debian:14
before 0.12.3-1, plus listed versions
0.10.4-80.11.4-10.11.4-20.11.4-30.11.4-4
Show 6 moreShow less
0.11.5-10.11.5-20.11.5-30.11.6-10.12.2-10.12.2-2
0.12.3-1
neovim
Ubuntu:Pro:18.04:LTS
All versions, plus listed versions
0.2.0-3build20.2.2-20.2.2-30.2.2-3ubuntu0.1~esm1
None known
neovim
Ubuntu:20.04:LTS
All versions, plus listed versions
0.3.8-10.4.3-3
None known
neovim
Ubuntu:22.04:LTS
All versions, plus listed versions
0.4.4-10.5.1-10.6.0-10.6.1-10.6.1-20.6.1-3
None known
neovim
Ubuntu:24.04:LTS
All versions, plus listed versions
0.7.2-70.7.2-80.9.5-6ubuntu10.9.5-6ubuntu2
None known
neovim
Ubuntu:25.10
All versions, plus listed versions
0.9.5-100.10.4-8build2
None known
neovim
Ubuntu:26.10
All versions, plus listed versions
0.11.6-10.12.4-1
None known
neovim
Ubuntu:26.04:LTS
All versions, plus listed versions
0.10.4-8build20.11.4-30.11.4-40.11.5-20.11.5-30.11.6-1
None known

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2026-11487 is a medium vulnerability (CVSS 4.8) in neovim, published June 8, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.01%, the 63rd percentile. Fixed in neovim 0.12.3-1.

References

Show 8 moreShow less
MoveEnter Open