Every CVE Search/ Get API key

CVE-2026-118543

Commerce Core - Moderately critical - Cross-site request forgery - SA-CONTRIB-2026-258

5.3 MediumFix available

Cross-Site Request Forgery (CSRF) vulnerability in Drupal Commerce Core allows Cross Site Request Forgery. This issue affects Commerce Core versions: from 0.0.0 to 2.41.0, from 3.0.0 to 3.3.13.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
Low
Availability
None

Exploit likelihood

0.16%Unchanged since Oct 30, 2026
90%50%10%1%

What each source reports

CVE List Score used 5.3

Commerce Core - Moderately critical - Cross-site request forgery - SA-CONTRIB-2026-258

Cross-Site Request Forgery (CSRF) vulnerability in Drupal Commerce Core allows Cross Site Request Forgery. This issue affects Commerce Core versions: from 0.0.0 to 2.41.0, from 3.0.0 to 3.3.13.

Record
CVE-2026-118543
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Weakness
CWE-352
Updated
2026-11-06
EUVDEUVD-2026-113514 5.3

Cross-Site Request Forgery (CSRF) vulnerability in Drupal Commerce Core allows Cross Site Request Forgery. This issue affects Commerce Core versions: from 0.0.0 to 2.41.0, from 3.0.0 to 3.3.13.

Record
EUVD-2026-113514
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Updated
2026-11-06
GitHub AdvisoriesGHSA-h38c-8g33-pr7c 5.3

Cross-Site Request Forgery (CSRF) vulnerability in Drupal Commerce Core allows Cross Site Request...

Cross-Site Request Forgery (CSRF) vulnerability in Drupal Commerce Core allows Cross Site Request Forgery. This issue affects Commerce Core versions: from 0.0.0 to 2.41.0, from 3.0.0 to 3.3.13.

Record
GHSA-h38c-8g33-pr7c
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Weakness
CWE-352
Updated
2026-11-06
NVD 5.3

Cross-Site Request Forgery (CSRF) vulnerability in Drupal Commerce Core allows Cross Site Request Forgery. This issue affects Commerce Core versions: from 0.0.0 to 2.41.0, from 3.0.0 to 3.3.13.

Record
CVE-2026-118543
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Weakness
CWE-352
Updated
2026-11-06
OSV 5.3

Commerce Core - Moderately critical - Cross-site request forgery - SA-CONTRIB-2026-258

Cross-Site Request Forgery (CSRF) vulnerability in Drupal Commerce Core allows Cross Site Request Forgery. This issue affects Commerce Core versions: from 0.0.0 to 2.41.0, from 3.0.0 to 3.3.13.

Record
CVE-2026-118543
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Weakness
CWE-352
Updated
2026-11-07
OSVDRUPAL-CONTRIB-2026-258 No score

This module enables you to sell goods and services to customers through a shopping cart and checkout form. It shows an inbox on the Commerce dashboard with announcements from the Drupal Commerce project, including notices about security updates.

Routes for the inbox do not check for a CSRF token. As a result, an attacker can trick a user with the "access commerce administration pages" permission into visiting a crafted page that will dismiss notifications for the messages. The inbox is also shared by all users, so if one commerce administrator is tricked, this hides the messages from every administrator, including notices that a security update is available.

Record
DRUPAL-CONTRIB-2026-258
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
drupal/commerce
Packagist:https://packages.drupal.org/8
before 2.41.0, 3.0.0 up to 3.3.13
2.41.03.3.13

History

History
RecordedChangedSources
severityCVE List
severityEUVD
facts, referencesOSV
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2026-118543 is a medium vulnerability (CVSS 5.3) in Drupal Commerce Core, published October 28, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.16%, the 4th percentile. Fixed in drupal/commerce 2.41.0.

References

MoveEnter Open