CVE-2026-119842
Gst-plugins-base: gst-plugins-base: null-pointer dereference in mdvdsub subtitle parser via missing closing-brace check
A flaw was found in GStreamer's gst-plugins-base MicroDVD subtitle parser. When processing a specially crafted subtitle file, the parser may dereference a NULL pointer, causing the application to crash when a user opens or plays media with a malformed MicroDVD (.sub) subtitle file.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
6.5
Gst-plugins-base: gst-plugins-base: null-pointer dereference in mdvdsub subtitle parser via missing closing-brace check
A flaw was found in GStreamer's gst-plugins-base MicroDVD subtitle parser. When processing a specially crafted subtitle file, the parser may dereference a NULL pointer, causing the application to crash when a user opens or plays media with a malformed MicroDVD (.sub) subtitle file.
- Record
CVE-2026-119842- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Weakness
- CWE-476
- Updated
- 2026-11-05
EUVDEUVD-2026-114326
6.5
A flaw was found in GStreamer's gst-plugins-base MicroDVD subtitle parser. When processing a specially crafted subtitle file, the parser may dereference a NULL pointer, causing the application to crash when a user opens or plays media with a malformed MicroDVD (.sub) subtitle file.
- Record
EUVD-2026-114326- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-05
GitHub AdvisoriesGHSA-c6jr-3xqv-fchj
6.5
A flaw was found in GStreamer's gst-plugins-base MicroDVD subtitle parser. When processing a...
A flaw was found in GStreamer's gst-plugins-base MicroDVD subtitle parser. When processing a specially crafted subtitle file, the parser may dereference a NULL pointer, causing the application to crash when a user opens or plays media with a malformed MicroDVD (.sub) subtitle file.
- Record
GHSA-c6jr-3xqv-fchj- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Weakness
- CWE-476
- Updated
- 2026-11-02
NVD
6.5
A flaw was found in GStreamer's gst-plugins-base MicroDVD subtitle parser. When processing a specially crafted subtitle file, the parser may dereference a NULL pointer, causing the application to crash when a user opens or plays media with a malformed MicroDVD (.sub) subtitle file.
- Record
CVE-2026-119842- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Weakness
- CWE-476
- Updated
- 2026-11-05
OSVDEBIAN-CVE-2026-119842
6.5
A flaw was found in GStreamer's gst-plugins-base MicroDVD subtitle parser. When processing a specially crafted subtitle file, the parser may dereference a NULL pointer, causing the application to crash when a user opens or plays media with a malformed MicroDVD (.sub) subtitle file.
- Record
DEBIAN-CVE-2026-119842- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-04
OSVUBUNTU-CVE-2026-119842
6.5
A flaw was found in GStreamer's gst-plugins-base MicroDVD subtitle parser. When processing a specially crafted subtitle file, the parser may dereference a NULL pointer, causing the application to crash when a user opens or plays media with a malformed MicroDVD (.sub) subtitle file.
- Record
UBUNTU-CVE-2026-119842- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-05
OSVAZL-112714 No score
CVE-2026-119842 affecting package gstreamer1-plugins-base 1.20.0-3
A flaw was found in GStreamer's gst-plugins-base MicroDVD subtitle parser. When processing a specially crafted subtitle file, the parser may dereference a NULL pointer, causing the application to crash when a user opens or plays media with a malformed MicroDVD (.sub) subtitle file.
- Record
AZL-112714- Updated
- 2026-11-07
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
gstreamer1-plugins-baseAzure Linux:3 |
through 1.20.0-3 | None known |
gst-plugins-base1.0Debian:12 |
All versions, plus listed versions 1.22.0-31.22.0-3+deb12u11.22.0-3+deb12u21.22.0-3+deb12u31.22.0-3+deb12u4 Show 45 moreShow less1.22.0-3+deb12u51.22.0-3+deb12u61.22.0-3+deb12u71.22.1-11.22.10-11.22.2-11.22.3-11.22.3-21.22.4-11.22.5-11.22.6-11.22.7-11.22.8-11.22.9-11.23.1-11.23.1-21.23.2-11.23.2-21.23.90-11.24.0-11.24.0-21.24.1-11.24.10-11.24.11-11.24.11-21.24.11-31.24.12-11.24.2-11.24.3-11.24.4-11.24.4-1+hurd.11.24.5-11.24.6-11.24.7-11.24.7-21.24.7-31.24.7-41.24.8-11.24.9-11.25.1-11.25.1-21.25.1-31.25.1-41.25.1-51.25.50-1 |
None known |
gst-plugins-base1.0Debian:13 |
All versions, plus listed versions 1.26.10-11.26.2-11.26.2-1+deb13u11.26.2-1+deb13u21.26.3-1 Show 31 moreShow less1.26.4-11.26.5-11.26.5-21.26.6-11.26.6-21.26.6-31.26.7-11.26.8-11.26.9-11.27.1-11.27.2-11.27.2-21.27.2-31.27.50-11.27.50-21.27.90-11.28.0-11.28.1-11.28.2-11.28.2-21.28.3-11.28.4-11.28.5-11.28.6-11.28.6-21.28.7-11.28.8-11.29.1-11.29.1-21.29.1-31.29.2-1 |
None known |
gst-plugins-base1.0Debian:14 |
before 1.28.2-1, plus listed versions 1.26.10-11.26.2-11.26.3-11.26.4-11.26.5-1 Show 16 moreShow less1.26.5-21.26.6-11.26.6-21.26.6-31.26.7-11.26.8-11.26.9-11.27.1-11.27.2-11.27.2-21.27.2-31.27.50-11.27.50-21.27.90-11.28.0-11.28.1-1 |
1.28.2-1 |
gst-plugins-base1.0Ubuntu:Pro:16.04:LTS |
All versions, plus listed versions 1.6.0-1ubuntu11.6.1-1ubuntu11.6.2-1ubuntu11.7.1-1ubuntu11.7.2-1ubuntu1 Show 14 moreShow less1.7.90-1ubuntu11.7.91-1ubuntu11.8.0-1ubuntu11.8.1-1ubuntu0.11.8.2-1ubuntu0.11.8.2-1ubuntu0.21.8.3-1ubuntu0.11.8.3-1ubuntu0.21.8.3-1ubuntu0.31.8.3-1ubuntu0.3+esm11.8.3-1ubuntu0.3+esm21.8.3-1ubuntu0.3+esm31.8.3-1ubuntu0.3+esm41.8.3-1ubuntu0.3+esm5 |
None known |
gst-plugins-base1.0Ubuntu:Pro:18.04:LTS |
All versions, plus listed versions 1.12.3-11.12.4-11.13.1-1ubuntu11.13.91-1ubuntu11.14.0-1ubuntu1 Show 11 moreShow less1.14.0-2ubuntu11.14.1-1ubuntu1~ubuntu18.04.11.14.1-1ubuntu1~ubuntu18.04.21.14.4-1ubuntu1.1~ubuntu18.04.11.14.5-0ubuntu1~18.04.11.14.5-0ubuntu1~18.04.21.14.5-0ubuntu1~18.04.31.14.5-0ubuntu1~18.04.3+esm11.14.5-0ubuntu1~18.04.3+esm21.14.5-0ubuntu1~18.04.3+esm31.14.5-0ubuntu1~18.04.3+esm4 |
None known |
gst-plugins-base1.0Ubuntu:Pro:20.04:LTS |
All versions, plus listed versions 1.16.1-11.16.2-11.16.2-21.16.2-2ubuntu31.16.2-2ubuntu4 Show 10 moreShow less1.16.2-41.16.2-4ubuntu0.11.16.3-0ubuntu11.16.3-0ubuntu1.11.16.3-0ubuntu1.21.16.3-0ubuntu1.31.16.3-0ubuntu1.41.16.3-0ubuntu1.4+esm11.16.3-0ubuntu1.4+esm21.16.3-0ubuntu1.4+esm3 |
None known |
gst-plugins-base1.0Ubuntu:22.04:LTS |
All versions, plus listed versions 1.18.5-11.19.90-11.20.0-11.20.0-21.20.1-1 Show 6 moreShow less1.20.1-1ubuntu0.11.20.1-1ubuntu0.21.20.1-1ubuntu0.41.20.1-1ubuntu0.51.20.1-1ubuntu0.61.20.1-1ubuntu0.7 |
None known |
gst-plugins-base1.0Ubuntu:24.04:LTS |
All versions, plus listed versions 1.22.6-11.22.7-11.22.8-11.22.10-11.24.1-1 Show 7 moreShow less1.24.1-1build11.24.2-11.24.2-1ubuntu0.11.24.2-1ubuntu0.21.24.2-1ubuntu0.31.24.2-1ubuntu0.41.24.2-1ubuntu0.5 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, aliases, references | NVD, OSV | |
| products | CVE List, EUVD, OSV | |
| affected, aliases, facts, references | EUVD, NVD, OSV | |
| products | CVE List | |
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2026-119842 is a medium vulnerability (CVSS 6.5) in Red Hat Enterprise Linux 10, published October 30, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.33%, the 26th percentile. Fixed in gst-plugins-base1.0 1.28.2-1.
References
Left out here: 38 versions. The JSON record has them.