Every CVE Search/ Get API key

CVE-2026-119977

WordPress Core 4.7.0 - 7.1.3 - Unauthenticated Upgrade-Window Staged-Installer Remote Code Execution

8.1 HighIn KEVPublic exploitFix available

WordPress Core is vulnerable to Remote Code Execution in versions 4.7 through 7.1.3. This is due to predictable, web-accessible staging paths used during full-package core upgrades. This makes it possible for unauthenticated attackers to execute code on the server during the upgrade window.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
High
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

1.16%Up 0.6 points since Oct 31, 2026
90%50%10%1%

What each source reports

CVE List Score used 8.1

WordPress Core 4.7.0 - 7.1.3 - Unauthenticated Upgrade-Window Staged-Installer Remote Code Execution

WordPress Core is vulnerable to Remote Code Execution in versions 4.7 through 7.1.3. This is due to predictable, web-accessible staging paths used during full-package core upgrades. This makes it possible for unauthenticated attackers to execute code on the server during the upgrade window.

Record
CVE-2026-119977
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-367
Updated
2026-11-04
EUVDEUVD-2026-114575 8.1

WordPress Core is vulnerable to Remote Code Execution in versions 4.7 through 7.1.3. This is due to predictable, web-accessible staging paths used during full-package core upgrades. This makes it possible for unauthenticated attackers to execute code on the server during the upgrade window.

Record
EUVD-2026-114575
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-04
GitHub AdvisoriesGHSA-p6jj-qrp3-7m4g 8.1

WordPress Core is vulnerable to Remote Code Execution in versions 4.7 through 7.1.3. This is due...

WordPress Core is vulnerable to Remote Code Execution in versions 4.7 through 7.1.3. This is due to predictable, web-accessible staging paths used during full-package core upgrades. This makes it possible for unauthenticated attackers to execute code on the server during the upgrade window.

Record
GHSA-p6jj-qrp3-7m4g
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-367
Updated
2026-11-03
CISA KEV No score

WordPress WordPress Core Time-of-check Time-of-use (TOCTOU) Race Condition Vulnerability

WordPress WordPress Core contains a time-of-check time-of-use (TOCTOU) race condition vulnerability that could allow unauthenticated attackers to execute code on the server during the upgrade window. This is due to predictable, web-accessible staging paths used during full-package core upgrades.

Record
CVE-2026-119977
Weakness
CWE-367
Updated
2026-11-03
NVD 8.1

WordPress Core is vulnerable to Remote Code Execution in versions 4.7 through 7.1.3. This is due to predictable, web-accessible staging paths used during full-package core upgrades. This makes it possible for unauthenticated attackers to execute code on the server during the upgrade window.

Record
CVE-2026-119977
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-367
Updated
2026-11-04
OSV 8.1

WordPress Core 4.7.0 - 7.1.3 - Unauthenticated Upgrade-Window Staged-Installer Remote Code Execution

WordPress Core is vulnerable to Remote Code Execution in versions 4.7 through 7.1.3. This is due to predictable, web-accessible staging paths used during full-package core upgrades. This makes it possible for unauthenticated attackers to execute code on the server during the upgrade window.

Record
CVE-2026-119977
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-367
Updated
2026-11-06
OSVDEBIAN-CVE-2026-119977 8.1

WordPress Core is vulnerable to Remote Code Execution in versions 4.7 through 7.1.3. This is due to predictable, web-accessible staging paths used during full-package core upgrades. This makes it possible for unauthenticated attackers to execute code on the server during the upgrade window.

Record
DEBIAN-CVE-2026-119977
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-05

Affected products

Affected packages

Affected packages
PackageAffectedFixed
wordpress
Debian:12
All versions, plus listed versions
6.1.1+dfsg1-16.1.6+dfsg1-0+deb12u16.1.9+dfsg1-0+deb12u16.2+dfsg1-16.2.1+dfsg1-1
Show 27 moreShow less
6.2.2+dfsg1-16.3+dfsg1-16.3.1+dfsg1-16.3.2+dfsg1-16.4.1+dfsg1-16.4.1+dfsg1-1.16.4.2+dfsg1-16.4.3+dfsg1-16.5+dfsg1-16.5.2+dfsg1-16.5.3+dfsg1-16.5.5+dfsg1-16.6.1+dfsg1-16.7.2+dfsg1-16.7.2+dfsg1-1.16.8.1+dfsg1-16.8.3+dfsg1-16.9+dfsg1-16.9.4+dfsg1-17.0+dfsg1-17.0.2+dfsg1-17.0.3+dfsg1-17.1+dfsg1-17.1.1+dfsg1-17.1.2+dfsg1-17.1.3+dfsg1-17.1.4+dfsg1-1
None known
wordpress
Debian:13
before 6.8.12+dfsg1-0+deb13u1, plus listed versions
6.8.1+dfsg1-16.8.10+dfsg1-0+deb13u16.8.3+dfsg1-0+deb13u16.8.3+dfsg1-16.8.6+dfsg1-0+deb13u16.8.7+dfsg1-0+deb13u1
6.8.12+dfsg1-0+deb13u1
wordpress
Debian:14
before 7.1.4+dfsg1-1, plus listed versions
6.8.1+dfsg1-16.8.3+dfsg1-16.9+dfsg1-16.9.4+dfsg1-17.0+dfsg1-1
Show 6 moreShow less
7.0.2+dfsg1-17.0.3+dfsg1-17.1+dfsg1-17.1.1+dfsg1-17.1.2+dfsg1-17.1.3+dfsg1-1
7.1.4+dfsg1-1

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
PoC in GitHubpaulmann/Bash_WP-CLI_Update2021-11-15
PoC in GitHubWorthes/CVE-2026-119977-WordPress-Upgrade-RCE-Bypasses-7.1.42026-11-04
PoC in GitHubfoxcornlab/wordpress-core-scanner2026-11-04
PoC in GitHublysophavin18/CVE-2026-1199772026-11-04
PoC in GitHubtc4dy/CVE-2026-119977-Toolkit2026-11-05
PoC in GitHubriabinov/CVE-2026-1199772026-11-07

History

History
RecordedChangedSources
exploitsPoC in GitHub
exploitsPoC in GitHub
referencesOSV
exploitsPoC in GitHub
affected, aliases, facts, referencesOSV
exploits, factsPoC in GitHub
products, referencesCVE List, EUVD, NVD
exploitation, referencesCVE List, EUVD
referencesGitHub Advisories
exploitation, facts, kev, productsCISA KEV
first indexedCVE List, EUVD, GitHub Advisories, NVD

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2026-119977 is a high vulnerability (CVSS 8.1) in Wordpress, published October 31, 2026. CISA lists it as known to be exploited, since November 3, 2026. EUVD reports exploitation since November 3, 2026. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 1.16%, the 67th percentile. Fixed in wordpress 6.8.12+dfsg1-0+deb13u1.

References

Show 8 moreShow less
MoveEnter Open