Every CVE Search/ Get API key

CVE-2026-15686

Adminer multi_query Incorrect Check of Function Return Value Remote Code Execution Vulnerability

7.2 HighFix available

Adminer multi_query Incorrect Check of Function Return Value Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of Adminer. Authentication is required to exploit this vulnerability.

The specific flaw exists within the multi_query method. The issue results from an incorrect check of a function return value. An attacker can leverage this vulnerability to execute code in the context of the web server. Was ZDI-CAN-28201.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
High
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

1.08%Unchanged since Aug 21, 2026
90%50%10%1%

What each source reports

CVE List Score used 7.2

Adminer multi_query Incorrect Check of Function Return Value Remote Code Execution Vulnerability

Adminer multi_query Incorrect Check of Function Return Value Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of Adminer. Authentication is required to exploit this vulnerability.

The specific flaw exists within the multi_query method. The issue results from an incorrect check of a function return value. An attacker can leverage this vulnerability to execute code in the context of the web server. Was ZDI-CAN-28201.

Record
CVE-2026-15686
CVSS 3.0
7.2 HighCVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-253
Updated
2026-11-02
EUVDEUVD-2026-63460 7.2

Adminer multi_query Incorrect Check of Function Return Value Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of Adminer. Authentication is required to exploit this vulnerability.

The specific flaw exists within the multi_query method. The issue results from an incorrect check of a function return value. An attacker can leverage this vulnerability to execute code in the context of the web server. Was ZDI-CAN-28201.

Record
EUVD-2026-63460
CVSS 3.0
7.2 HighCVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
GitHub AdvisoriesGHSA-cmr6-cvgm-wxx6 7.2

Adminer multi_query Incorrect Check of Function Return Value Remote Code Execution Vulnerability....

Adminer multi_query Incorrect Check of Function Return Value Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of Adminer. Authentication is required to exploit this vulnerability.

The specific flaw exists within the multi_query method. The issue results from an incorrect check of a function return value. An attacker can leverage this vulnerability to execute code in the context of the web server. Was ZDI-CAN-28201.

Record
GHSA-cmr6-cvgm-wxx6
CVSS 3.0
7.2 HighCVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-253
Updated
2026-11-02
NVD 7.2

Adminer multi_query Incorrect Check of Function Return Value Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of Adminer. Authentication is required to exploit this vulnerability.

The specific flaw exists within the multi_query method. The issue results from an incorrect check of a function return value. An attacker can leverage this vulnerability to execute code in the context of the web server. Was ZDI-CAN-28201.

Record
CVE-2026-15686
CVSS 3.0
7.2 HighCVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-253
Updated
2026-11-02
OSV 7.2

Adminer multi_query Incorrect Check of Function Return Value Remote Code Execution Vulnerability

Adminer multi_query Incorrect Check of Function Return Value Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of Adminer. Authentication is required to exploit this vulnerability.

The specific flaw exists within the multi_query method. The issue results from an incorrect check of a function return value. An attacker can leverage this vulnerability to execute code in the context of the web server. Was ZDI-CAN-28201.

Record
CVE-2026-15686
CVSS 3.0
7.2 HighCVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-253
Updated
2026-11-02
OSVDEBIAN-CVE-2026-15686 7.2

Adminer multi_query Incorrect Check of Function Return Value Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of Adminer. Authentication is required to exploit this vulnerability. The specific flaw exists within the multi_query method. The issue results from an incorrect check of a function return value. An attacker can leverage this vulnerability to execute code in the context of the web server. Was ZDI-CAN-28201.

Record
DEBIAN-CVE-2026-15686
CVSS 3.0
7.2 HighCVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2026-15686 7.2

Adminer multi_query Incorrect Check of Function Return Value Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of Adminer. Authentication is required to exploit this vulnerability. The specific flaw exists within the multi_query method. The issue results from an incorrect check of a function return value. An attacker can leverage this vulnerability to execute code in the context of the web server. Was ZDI-CAN-28201.

Record
UBUNTU-CVE-2026-15686
CVSS 3.0
7.2 HighCVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
adminer
Debian:12
All versions, plus listed versions
4.8.1-14.8.1-24.8.1-45.1.0-15.2.1+dfsg-1
Show 12 moreShow less
5.3.0+dfsg-15.4.0+dfsg-15.4.1+dfsg-15.4.2+dfsg-15.4.3+dfsg-15.4.4+dfsg-16.0.0-16.0.1-16.0.2-16.1.0-16.1.1-16.1.2-1
None known
adminer
Debian:13
All versions, plus listed versions
5.2.1+dfsg-15.3.0+dfsg-15.4.0+dfsg-15.4.1+dfsg-15.4.2+dfsg-1
Show 8 moreShow less
5.4.3+dfsg-15.4.4+dfsg-16.0.0-16.0.1-16.0.2-16.1.0-16.1.1-16.1.2-1
None known
adminer
Debian:14
before 5.4.3+dfsg-1, plus listed versions
5.2.1+dfsg-15.3.0+dfsg-15.4.0+dfsg-15.4.1+dfsg-15.4.2+dfsg-1
5.4.3+dfsg-1
adminer
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
4.2.1-14.2.1-1ubuntu14.2.1-1ubuntu1+esm1
None known
adminer
Ubuntu:Pro:18.04:LTS
All versions, plus listed versions
4.3.1-24.5.0-14.6.1-14.6.2-14.6.2-1ubuntu0.1~esm1
None known
adminer
Ubuntu:Pro:20.04:LTS
All versions, plus listed versions
4.7.2-14.7.4-14.7.5-14.7.6-14.7.6-1ubuntu0.1~esm1
None known
adminer
Ubuntu:22.04:LTS
All versions, plus listed versions
4.7.9-24.8.1-1
None known
adminer
Ubuntu:24.04:LTS
All versions, plus listed versions
4.8.1-14.8.1-1ubuntu14.8.1-2
None known
adminer
Ubuntu:26.10
All versions, plus listed versions
5.4.1+dfsg-15.4.2+dfsg-15.4.4+dfsg-16.0.0-1
None known
adminer
Ubuntu:26.04:LTS
All versions, plus listed versions
5.2.1+dfsg-15.3.0+dfsg-15.4.0+dfsg-15.4.1+dfsg-1
None known

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2026-15686 is a high vulnerability (CVSS 7.2) in Adminer, published August 20, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.08%, the 65th percentile. Fixed in adminer 5.4.3+dfsg-1.

References

MoveEnter Open