CVE-2026-15911
Confluent Kafka Python Improper TLS Certificate Validation
Confluent Kafka Python client's HashiCorp Vault KMS integration could allow a remote attacker to obtain sensitive information due to improper TLS certificate validation.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- High
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
7.4
Confluent Kafka Python Improper TLS Certificate Validation
Confluent Kafka Python client's HashiCorp Vault KMS integration could allow a remote attacker to obtain sensitive information due to improper TLS certificate validation.
- Record
CVE-2026-15911- CVSS 3.1
- 7.4 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N - Weakness
- CWE-295
- Updated
- 2026-11-02
EUVDEUVD-2026-91008
7.4
Confluent Kafka Python client's HashiCorp Vault KMS integration could allow a remote attacker to obtain sensitive information due to improper TLS certificate validation.
- Record
EUVD-2026-91008- CVSS 3.1
- 7.4 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-r743-crv8-m3qr
7.4
Confluent Kafka Python client's HashiCorp Vault KMS integration could allow a remote attacker to...
Confluent Kafka Python client's HashiCorp Vault KMS integration could allow a remote attacker to obtain sensitive information due to improper TLS certificate validation.
- Record
GHSA-r743-crv8-m3qr- CVSS 3.1
- 7.4 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N - Weakness
- CWE-295
- Updated
- 2026-11-02
NVD
7.4
Confluent Kafka Python client's HashiCorp Vault KMS integration could allow a remote attacker to obtain sensitive information due to improper TLS certificate validation.
- Record
CVE-2026-15911- CVSS 3.1
- 7.4 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N - Weakness
- CWE-295
- Updated
- 2026-11-02
OSVopenSUSE-SU-2026:12006-1 No score
python313-confluent-kafka-2.15.1-1.1 on GA media
These are all security issues fixed in the python313-confluent-kafka-2.15.1-1.1 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2026:12006-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
python-confluent-kafkaopenSUSE:Tumbleweed |
before 2.15.1-1.1 | 2.15.1-1.1 |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| PoC in GitHub | rahulreddykarne/CVE-2026-15911-Confluent_Kafka | 2026-09-26 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV, PoC in GitHub |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2026-15911 is a high vulnerability (CVSS 7.4) in Confluent Confluent-kafka, published October 1, 2026. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 0.30%, the 22nd percentile. Fixed in python-confluent-kafka 2.15.1-1.1.
References
support.confluent.io/hc/en-us/articles/54133146724244-CONFSA-2026-22-CVE-2026-15911-Confluent-Kafka-Python-Client-Vulnerability-TLS-Certificate-verification-disabled-by-default-in-HashiCorp-Vault-KMS-Integration
nvd.nist.gov/vuln/detail/CVE-2026-15911
github.com/advisories/GHSA-r743-crv8-m3qr
suse.com/security/cve/CVE-2026-15911