CVE-2026-16633
PDF.js: Arbitrary JavaScript execution upon opening a malicious PDF
CVE-2026-16633 is a high vulnerability (CVSS 8.6) in pdfjs-dist, published August 6, 2026. No source lists public exploit code. Fixed in pdfjs-dist 6.2.108.
Impact
If PDF.js is used to load a malicious PDF, and PDF.js is configured with enableScripting set to true (which is the default value) and no CSP for disallowing script-src, unrestricted attacker-controlled JavaScript will be executed in the context of the hosting domain.
Patches
Workarounds
Set enableScripting to false or set a CSP.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Passive
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- None
What each source reports
GitHub Advisories Score usedGHSA-hq66-cqwq-w95j
8.6
PDF.js: Arbitrary JavaScript execution upon opening a malicious PDF
Impact
If PDF.js is used to load a malicious PDF, and PDF.js is configured with enableScripting set to true (which is the default value) and no CSP for disallowing script-src, unrestricted attacker-controlled JavaScript will be executed in the context of the hosting domain.
Patches
Workarounds
Set enableScripting to false or set a CSP.
- Record
GHSA-hq66-cqwq-w95j- CVSS 4.0
- 8.6 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVGHSA-hq66-cqwq-w95j
8.6
PDF.js: Arbitrary JavaScript execution upon opening a malicious PDF
Impact
If PDF.js is used to load a malicious PDF, and PDF.js is configured with enableScripting set to true (which is the default value) and no CSP for disallowing script-src, unrestricted attacker-controlled JavaScript will be executed in the context of the hosting domain.
Patches
Workarounds
Set enableScripting to false or set a CSP.
- Record
GHSA-hq66-cqwq-w95j- CVSS 4.0
- 8.6 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVROOT-APP-NPM-CVE-2026-16633 No score
CVE-2026-16633 in pdfjs-dist - Patched by Root
Root has patched CVE-2026-16633 in the pdfjs-dist package for Root:npm. Multiple fixed versions available.
- Record
ROOT-APP-NPM-CVE-2026-16633- Updated
- 2026-11-02
Affected packages
| Package | Affected | Fixed |
|---|---|---|
pdfjs-distnpm |
5.6.83 up to 6.2.108 | 6.2.108 |
pdfjs-distRoot:npm |
before 6.0.227-aikido.1 | 6.0.227-aikido.1 |
@rootio/pdfjs-distRoot:npm |
before 6.0.227-root.io.1 | 6.0.227-root.io.1 |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-02 | created | GitHub Advisories, OSV |