CVE-2026-22879
vtk vtk-dicom vtkDICOMItem::NewDataElement heap-based buffer overflow vulnerability
A heap-based buffer overflow vulnerability exists in the vtkDICOMItem::FindDataElementOrInsert functionality of vtk-dicom (version(s): 9.5.2). A specially crafted DICOM file can lead to heap-based memory corruption. An attacker can provide a malicious file to trigger this vulnerability.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- High
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
8.1
A heap-based buffer overflow vulnerability exists in the vtkDICOMItem::FindDataElementOrInsert functionality of vtk-dicom (version(s): 9.5.2). A specially crafted DICOM file can lead to heap-based memory corruption. An attacker can provide a malicious file to trigger this vulnerability.
- Record
CVE-2026-22879- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-129
- Updated
- 2026-11-02
EUVDEUVD-2026-39582
8.1
A heap-based buffer overflow vulnerability exists in the vtkDICOMItem::FindDataElementOrInsert functionality of vtk-dicom (version(s): 9.5.2). A specially crafted DICOM file can lead to heap-based memory corruption. An attacker can provide a malicious file to trigger this vulnerability.
- Record
EUVD-2026-39582- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-prp5-qv62-frpc
8.1
vtk vtk-dicom vtkDICOMItem::NewDataElement heap-based buffer overflow vulnerability
vtk vtk-dicom vtkDICOMItem::NewDataElement heap-based buffer overflow vulnerability
- Record
GHSA-prp5-qv62-frpc- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-129
- Updated
- 2026-11-02
NVD
8.1
A heap-based buffer overflow vulnerability exists in the vtkDICOMItem::FindDataElementOrInsert functionality of vtk-dicom (version(s): 9.5.2). A specially crafted DICOM file can lead to heap-based memory corruption. An attacker can provide a malicious file to trigger this vulnerability.
- Record
CVE-2026-22879- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-129
- Updated
- 2026-11-02
OSVDEBIAN-CVE-2026-22879
8.1
A heap-based buffer overflow vulnerability exists in the vtkDICOMItem::FindDataElementOrInsert functionality of vtk-dicom (version(s): 9.5.2). A specially crafted DICOM file can lead to heap-based memory corruption. An attacker can provide a malicious file to trigger this vulnerability.
- Record
DEBIAN-CVE-2026-22879- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVJLSEC-2026-633
8.1
vtk vtk-dicom vtkDICOMItem::NewDataElement heap-based buffer overflow vulnerability
vtk vtk-dicom vtkDICOMItem::NewDataElement heap-based buffer overflow vulnerability
- Record
JLSEC-2026-633- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2026-22879
8.1
A heap-based buffer overflow vulnerability exists in the vtkDICOMItem::FindDataElementOrInsert functionality of vtk-dicom (version(s): 9.5.2). A specially crafted DICOM file can lead to heap-based memory corruption. An attacker can provide a malicious file to trigger this vulnerability.
- Record
UBUNTU-CVE-2026-22879- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
vtk-dicomDebian:12 |
All versions, plus listed versions 0.8.14-3.10.8.14-3.2~exp10.8.17-10.8.17-20.8.17-3 |
None known |
vtk-dicomDebian:13 |
All versions, plus listed versions 0.8.17-10.8.17-20.8.17-3 |
None known |
VTK_jllJulia |
9.5.2+0 up to 9.6.1+0 | 9.6.1+0 |
vtk-dicomUbuntu:16.04:LTS |
All versions, plus listed versions 0.5.5-2build30.5.5-2build40.7.1-10.7.4-2 |
None known |
vtk-dicomUbuntu:18.04:LTS |
All versions, plus listed versions 0.7.10-1build1 |
None known |
vtk-dicomUbuntu:20.04:LTS |
All versions, plus listed versions 0.8.10-10.8.11-10.8.11-1build10.8.11-1build20.8.11-30.8.12-10.8.12-1build10.8.12-1build2 |
None known |
vtk-dicomUbuntu:22.04:LTS |
All versions, plus listed versions 0.8.12-40.8.12-4build1 |
None known |
vtk-dicomUbuntu:24.04:LTS |
All versions, plus listed versions 0.8.14-3.10.8.14-3.1build10.8.14-3.1build20.8.14-3.1build30.8.14-3.1build40.8.14-3.1build50.8.14-3.1ubuntu3 |
None known |
vtk-dicomUbuntu:25.10 |
All versions, plus listed versions 0.8.17-1 |
None known |
vtk-dicomUbuntu:26.10 |
All versions, plus listed versions 0.8.17-2build20.8.17-30.8.17-3build1 |
None known |
vtk-dicomUbuntu:26.04:LTS |
All versions, plus listed versions 0.8.17-10.8.17-20.8.17-2build10.8.17-2build2 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2026-22879 is a high vulnerability (CVSS 8.1) in Vtk, published June 25, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.49%, the 42nd percentile. Fixed in VTK_jll 9.6.1+0.