CVE-2026-23535
wlc Path traversal: Unsanitized API slugs in download command
wlc is a Weblate command-line client using Weblate's REST API. Prior to 1.17.2, the multi-translation download could write to an arbitrary location when instructed by a crafted server. This vulnerability is fixed in 1.17.2.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- High
- Privileges needed
- Low
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
8.1
wlc Path traversal: Unsanitized API slugs in download command
wlc is a Weblate command-line client using Weblate's REST API. Prior to 1.17.2, the multi-translation download could write to an arbitrary location when instructed by a crafted server. This vulnerability is fixed in 1.17.2.
- Record
CVE-2026-23535- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H - Weakness
- CWE-22
- Updated
- 2026-11-02
EUVDEUVD-2026-2864
8.1
wlc is a Weblate command-line client using Weblate's REST API. Prior to 1.17.2, the multi-translation download could write to an arbitrary location when instructed by a crafted server. This vulnerability is fixed in 1.17.2.
- Record
EUVD-2026-2864- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-mmwx-79f6-67jg
8.0
Weblate wlc path traversal vulnerability: Unsanitized API slugs in download command
Impact
Multi-translation download could write to an arbitrary location when instructed by a crafted server.
Patches
Workarounds
Do not use wlc download with untrusted servers.
References
This issue was reported to us by wh1zee via HackerOne.
- Record
GHSA-mmwx-79f6-67jg- CVSS 3.1
- 8.0 High
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H - Weakness
- CWE-22
- Updated
- 2026-11-02
NVD
8.0
wlc is a Weblate command-line client using Weblate's REST API. Prior to 1.17.2, the multi-translation download could write to an arbitrary location when instructed by a crafted server. This vulnerability is fixed in 1.17.2.
- Record
CVE-2026-23535- CVSS 3.1
- 8.0 High
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H - Weakness
- CWE-22
- Updated
- 2026-11-02
OSV
8.0
wlc Path traversal: Unsanitized API slugs in download command
wlc is a Weblate command-line client using Weblate's REST API. Prior to 1.17.2, the multi-translation download could write to an arbitrary location when instructed by a crafted server. This vulnerability is fixed in 1.17.2.
- Record
CVE-2026-23535- CVSS 3.1
- 8.0 High
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H - Weakness
- CWE-22
- Updated
- 2026-11-02
OSVDEBIAN-CVE-2026-23535
8.0
wlc is a Weblate command-line client using Weblate's REST API. Prior to 1.17.2, the multi-translation download could write to an arbitrary location when instructed by a crafted server. This vulnerability is fixed in 1.17.2.
- Record
DEBIAN-CVE-2026-23535- CVSS 3.1
- 8.0 High
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H - Updated
- 2026-11-02
OSVGHSA-mmwx-79f6-67jg
8.0
Weblate wlc path traversal vulnerability: Unsanitized API slugs in download command
Impact
Multi-translation download could write to an arbitrary location when instructed by a crafted server.
Patches
Workarounds
Do not use wlc download with untrusted servers.
References
This issue was reported to us by wh1zee via HackerOne.
- Record
GHSA-mmwx-79f6-67jg- CVSS 3.1
- 8.0 High
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H - Weakness
- CWE-22
- Updated
- 2026-11-02
OSVPYSEC-2026-2053
8.0
Weblate wlc path traversal vulnerability: Unsanitized API slugs in download command
Impact
Multi-translation download could write to an arbitrary location when instructed by a crafted server.
Patches
Workarounds
Do not use wlc download with untrusted servers.
References
This issue was reported to us by wh1zee via HackerOne.
- Record
PYSEC-2026-2053- CVSS 3.1
- 8.0 High
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2026-23535
8.0
wlc is a Weblate command-line client using Weblate's REST API. Prior to 1.17.2, the multi-translation download could write to an arbitrary location when instructed by a crafted server. This vulnerability is fixed in 1.17.2.
- Record
UBUNTU-CVE-2026-23535- CVSS 3.1
- 8.0 High
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
wlcPyPI |
before 1.17.2 | 1.17.2 |
wlcDebian:12 |
All versions, plus listed versions 1.13-21.14-11.15-11.15-21.16.1-11.17.2-12.0.0-1 |
None known |
wlcDebian:13 |
All versions, plus listed versions 1.15-11.15-21.16.1-11.17.2-12.0.0-1 |
None known |
wlcDebian:14 |
before 1.17.2-1, plus listed versions 1.15-11.15-21.16.1-1 |
1.17.2-1 |
wlcPyPI |
before 1.17.2, plus listed versions 0.00.10.100.20.3 Show 25 moreShow less0.40.50.60.70.80.91.01.11.101.111.121.131.141.151.16.11.17.01.17.11.21.31.41.51.61.71.81.9 |
1.17.2 |
wlcUbuntu:Pro:18.04:LTS |
All versions, plus listed versions 0.8-10.8-1ubuntu0.1~esm1 |
None known |
wlcUbuntu:Pro:20.04:LTS |
All versions, plus listed versions 1.1-11.2-11.2-1ubuntu0.20.04.1~esm1 |
None known |
wlcUbuntu:Pro:22.04:LTS |
All versions, plus listed versions 1.2-11.2-1ubuntu0.22.04.1~esm1 |
None known |
wlcUbuntu:Pro:24.04:LTS |
All versions, plus listed versions 1.13-21.13-2ubuntu0.1~esm1 |
None known |
wlcUbuntu:25.10 |
All versions, plus listed versions 1.15-11.15-21.15-2ubuntu0.1 |
None known |
wlcUbuntu:26.10 |
All versions, plus listed versions 1.16.1-12.0.0-1 |
None known |
wlcUbuntu:26.04:LTS |
All versions, plus listed versions 1.15-21.16.1-1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2026-23535 is a high vulnerability (CVSS 8.1) in Weblate Wlc, published January 16, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.39%, the 33rd percentile. Fixed in wlc 1.17.2.