CVE-2026-23643
CakePHP PaginatorHelper::limitControl() vulnerable to reflected cross-site-scripting
CakePHP is a rapid development framework for PHP. The PaginatorHelper::limitControl() method has a cross-site-scripting vulnerability via query string parameter manipulation. This issue has been fixed in 5.2.12 and 5.3.1.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
5.4
CakePHP PaginatorHelper::limitControl() vulnerable to reflected cross-site-scripting
CakePHP is a rapid development framework for PHP. The PaginatorHelper::limitControl() method has a cross-site-scripting vulnerability via query string parameter manipulation. This issue has been fixed in 5.2.12 and 5.3.1.
- Record
CVE-2026-23643- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
EUVDEUVD-2026-2861
5.4
CakePHP is a rapid development framework for PHP. The PaginatorHelper::limitControl() method has a cross-site-scripting vulnerability via query string parameter manipulation. This issue has been fixed in 5.2.12 and 5.3.1.
- Record
EUVD-2026-2861- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-qh8m-9qxx-53m5
5.4
CakePHP PaginatorHelper::limitControl() vulnerable to reflected cross-site-scripting
Impact
The PaginatorHelper::limitControl() method has a cross-site-scripting vulnerability via query string parameter manipulation.
Patches
This issue has been fixed in 5.2.12 and 5.3.1
Workarounds
If you are unable to upgrade, you should avoid using Paginator::limitControl() until you can upgrade.
- Record
GHSA-qh8m-9qxx-53m5- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
NVD
5.4
CakePHP is a rapid development framework for PHP. The PaginatorHelper::limitControl() method has a cross-site-scripting vulnerability via query string parameter manipulation. This issue has been fixed in 5.2.12 and 5.3.1.
- Record
CVE-2026-23643- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
5.4
CakePHP PaginatorHelper::limitControl() vulnerable to reflected cross-site-scripting
CakePHP is a rapid development framework for PHP. The PaginatorHelper::limitControl() method has a cross-site-scripting vulnerability via query string parameter manipulation. This issue has been fixed in 5.2.12 and 5.3.1.
- Record
CVE-2026-23643- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVDEBIAN-CVE-2026-23643
5.4
CakePHP is a rapid development framework for PHP. The PaginatorHelper::limitControl() method has a cross-site-scripting vulnerability via query string parameter manipulation. This issue has been fixed in 5.2.12 and 5.3.1.
- Record
DEBIAN-CVE-2026-23643- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N - Updated
- 2026-11-02
OSVGHSA-qh8m-9qxx-53m5
5.4
CakePHP PaginatorHelper::limitControl() vulnerable to reflected cross-site-scripting
Impact
The PaginatorHelper::limitControl() method has a cross-site-scripting vulnerability via query string parameter manipulation.
Patches
This issue has been fixed in 5.2.12 and 5.3.1
Workarounds
If you are unable to upgrade, you should avoid using Paginator::limitControl() until you can upgrade.
- Record
GHSA-qh8m-9qxx-53m5- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2026-23643
5.4
CakePHP is a rapid development framework for PHP. The PaginatorHelper::limitControl() method has a cross-site-scripting vulnerability via query string parameter manipulation. This issue has been fixed in 5.2.12 and 5.3.1.
- Record
UBUNTU-CVE-2026-23643- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N - Updated
- 2026-11-03
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
cakephp/cakephpPackagist |
5.2.10 up to 5.2.12 | 5.2.12 |
cakephp/cakephpPackagist |
5.3.0 to 5.3.0 | 5.3.1 |
cakephp/cakephpPackagist |
5.2.10 up to 5.2.12, plus listed versions 5.2.11 |
5.2.12 |
cakephp/cakephpPackagist |
5.3.0 up to 5.3.1 | 5.3.1 |
cakephpUbuntu:Pro:16.04:LTS |
All versions, plus listed versions 2.7.2-12.8.0-12.8.0-1ubuntu0.1~esm1 |
None known |
cakephpUbuntu:20.04:LTS |
All versions, plus listed versions 2.10.11-2 |
None known |
cakephpUbuntu:22.04:LTS |
All versions, plus listed versions 2.10.11-2.12.10.24-1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | OSV | |
| affected | ||
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2026-23643 is a medium vulnerability (CVSS 5.4) in Cakephp, published January 16, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.28%, the 20th percentile. Fixed in cakephp/cakephp 5.2.12.
References
github.com/cakephp/cakephp/security/advisories/GHSA-qh8m-9qxx-53m5
github.com/cakephp/cakephp/issues/19172
github.com/cakephp/cakephp/commit/c842e7f45d85696e6527d8991dd72f525ced955f
bakery.cakephp.org/2026/01/14/cakephp_5212.html
github.com/cakephp/cakephp/releases/tag/5.2.12
github.com/cakephp/cakephp/releases/tag/5.3.1
Show 7 moreShow less
nvd.nist.gov/vuln/detail/CVE-2026-23643
github.com/advisories/GHSA-qh8m-9qxx-53m5
github.com/CVEProject/cvelistV5/tree/main/cves/2026/23xxx/CVE-2026-23643.json
security-tracker.debian.org/tracker/CVE-2026-23643
github.com/cakephp/cakephp
ubuntu.com/security/CVE-2026-23643
cve.org/CVERecord?id=CVE-2026-23643