CVE-2026-24015
Apache IoTDB: Insecure Default Configuration Vulnerability
A vulnerability in Apache IoTDB.
This issue affects Apache IoTDB: from 1.0.0 before 1.3.7, from 2.0.0 before 2.0.7.
Users are recommended to upgrade to version 1.3.7 or 2.0.7, which fixes the issue.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
A vulnerability in Apache IoTDB.
This issue affects Apache IoTDB: from 1.0.0 before 1.3.7, from 2.0.0 before 2.0.7.
Users are recommended to upgrade to version 1.3.7 or 2.0.7, which fixes the issue.
- Record
CVE-2026-24015- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-1327
- Updated
- 2026-11-02
CVE List
9.8
Apache IoTDB: Insecure Default Configuration Vulnerability
A vulnerability in Apache IoTDB.
This issue affects Apache IoTDB: from 1.0.0 before 1.3.7, from 2.0.0 before 2.0.7.
Users are recommended to upgrade to version 1.3.7 or 2.0.7, which fixes the issue.
- Record
CVE-2026-24015- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-1327
- Updated
- 2026-11-02
EUVDEUVD-2026-10308
9.8
A vulnerability in Apache IoTDB.
This issue affects Apache IoTDB: from 1.0.0 before 1.3.7, from 2.0.0 before 2.0.7.
Users are recommended to upgrade to version 1.3.7 or 2.0.7, which fixes the issue.
- Record
EUVD-2026-10308- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-74cf-pgh9-m5q2
9.8
Apache IoTDB has an Insecure Default Configuration Vulnerability
A vulnerability in Apache IoTDB.
This issue affects Apache IoTDB: from 1.0.0 before 1.3.7, from 2.0.0 before 2.0.7.
Users are recommended to upgrade to version 1.3.7 or 2.0.7, which fixes the issue.
- Record
GHSA-74cf-pgh9-m5q2- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-1327
- Updated
- 2026-11-02
OSV
9.8
Apache IoTDB: Insecure Default Configuration Vulnerability
A vulnerability in Apache IoTDB.
This issue affects Apache IoTDB: from 1.0.0 before 1.3.7, from 2.0.0 before 2.0.7.
Users are recommended to upgrade to version 1.3.7 or 2.0.7, which fixes the issue.
- Record
CVE-2026-24015- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-1327
- Updated
- 2026-11-02
OSVGHSA-74cf-pgh9-m5q2
9.8
Apache IoTDB has an Insecure Default Configuration Vulnerability
A vulnerability in Apache IoTDB.
This issue affects Apache IoTDB: from 1.0.0 before 1.3.7, from 2.0.0 before 2.0.7.
Users are recommended to upgrade to version 1.3.7 or 2.0.7, which fixes the issue.
- Record
GHSA-74cf-pgh9-m5q2- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-1327
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
org.apache.iotdb:iotdb-coreMaven |
1.0.0 up to 1.3.7 | 1.3.7 |
org.apache.iotdb:iotdb-coreMaven |
2.0.0 up to 2.0.7 | 2.0.7 |
org.apache.iotdb:iotdb-coreMaven |
1.0.0 up to 1.3.7, plus listed versions 1.3.01.3.11.3.21.3.31.3.41.3.4-11.3.51.3.6 |
1.3.7 |
org.apache.iotdb:iotdb-coreMaven |
2.0.0 up to 2.0.7, plus listed versions 2.0.1-beta2.0.22.0.2-12.0.32.0.42.0.52.0.6 |
2.0.7 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2026-24015 is a critical vulnerability (CVSS 9.8) in Apache Iotdb, published March 9, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.65%, the 51st percentile. Fixed in org.apache.iotdb:iotdb-core 1.3.7.