CVE-2026-25957
Cube Denial of Service (DoS) - An authenticated attacker can crash the server by sending a specially crafted request
Cube is a semantic layer for building data applications. From 1.1.17 to before 1.5.13 and 1.4.2, it is possible to make the entire Cube API unavailable by submitting a specially crafted request to a Cube API endpoint. This vulnerability is fixed in 1.5.13 and 1.4.2.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
6.5
Cube Denial of Service (DoS) - An authenticated attacker can crash the server by sending a specially crafted request
Cube is a semantic layer for building data applications. From 1.1.17 to before 1.5.13 and 1.4.2, it is possible to make the entire Cube API unavailable by submitting a specially crafted request to a Cube API endpoint. This vulnerability is fixed in 1.5.13 and 1.4.2.
- Record
CVE-2026-25957- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-755
- Updated
- 2026-11-02
EUVDEUVD-2026-6246
6.5
Cube is a semantic layer for building data applications. From 1.1.17 to before 1.5.13 and 1.4.2, it is possible to make the entire Cube API unavailable by submitting a specially crafted request to a Cube API endpoint. This vulnerability is fixed in 1.5.13 and 1.4.2.
- Record
EUVD-2026-6246- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-9vph-2hvm-x66g
6.5
Cube Core is vulnerable to Denial of Service (DoS) via crafted request
Impact
It is possible to make the entire Cube API unavailable by submitting a specially crafted request to a Cube API endpoint.
Affected Versions:
>= 1.1.17
Mitigation:
Upgrade to a patched version:
- 1.5.13 and later (regular release)
- 1.4.2 (active LTS release)
References
The issue was reported by our Core engineer, Dmitrii Patsura (@ovr), in our internal Slack and was promptly patched in a recent update.
- Record
GHSA-9vph-2hvm-x66g- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-755
- Updated
- 2026-11-02
NVD
6.5
Cube is a semantic layer for building data applications. From 1.1.17 to before 1.5.13 and 1.4.2, it is possible to make the entire Cube API unavailable by submitting a specially crafted request to a Cube API endpoint. This vulnerability is fixed in 1.5.13 and 1.4.2.
- Record
CVE-2026-25957- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-755
- Updated
- 2026-11-02
OSV
6.5
Cube Denial of Service (DoS) - An authenticated attacker can crash the server by sending a specially crafted request
Cube is a semantic layer for building data applications. From 1.1.17 to before 1.5.13 and 1.4.2, it is possible to make the entire Cube API unavailable by submitting a specially crafted request to a Cube API endpoint. This vulnerability is fixed in 1.5.13 and 1.4.2.
- Record
CVE-2026-25957- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-755
- Updated
- 2026-11-02
OSVGHSA-9vph-2hvm-x66g
6.5
Cube Core is vulnerable to Denial of Service (DoS) via crafted request
Impact
It is possible to make the entire Cube API unavailable by submitting a specially crafted request to a Cube API endpoint.
Affected Versions:
>= 1.1.17
Mitigation:
Upgrade to a patched version:
- 1.5.13 and later (regular release)
- 1.4.2 (active LTS release)
References
The issue was reported by our Core engineer, Dmitrii Patsura (@ovr), in our internal Slack and was promptly patched in a recent update.
- Record
GHSA-9vph-2hvm-x66g- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-755
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
@cubejs-backend/server-corenpm |
1.1.17 up to 1.4.2 | 1.4.2 |
@cubejs-backend/server-corenpm |
1.5.0 up to 1.5.13 | 1.5.13 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2026-25957 is a medium vulnerability (CVSS 6.5) in Cube-js Cube, published February 9, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.43%, the 37th percentile. Fixed in @cubejs-backend/server-core 1.4.2.