CVE-2026-28811
Apache JSPWiki: Error Handling - Reveals Error Details
Debug Messages Revealing Unnecessary Information in Apache JSPWiki up to 2.12.3. Users are recommended to upgrade to version 2.12.4, which fixes this issue.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
7.5
Apache JSPWiki: Error Handling - Reveals Error Details
Debug Messages Revealing Unnecessary Information in Apache JSPWiki up to 2.12.3. Users are recommended to upgrade to version 2.12.4, which fixes this issue.
- Record
CVE-2026-28811- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-1295
- Updated
- 2026-11-02
EUVDEUVD-2026-51178
7.5
Debug Messages Revealing Unnecessary Information in Apache JSPWiki up to 2.12.3. Users are recommended to upgrade to version 2.12.4, which fixes this issue.
- Record
EUVD-2026-51178- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-4xg4-cv39-wq7w
7.5
Debug Messages Revealing Unnecessary Information in Apache JSPWiki up to 2.12.3. Users are...
Debug Messages Revealing Unnecessary Information in Apache JSPWiki up to 2.12.3. Users are recommended to upgrade to version 2.12.4, which fixes this issue.
- Record
GHSA-4xg4-cv39-wq7w- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-1295
- Updated
- 2026-11-02
NVD
7.5
Debug Messages Revealing Unnecessary Information in Apache JSPWiki up to 2.12.3. Users are recommended to upgrade to version 2.12.4, which fixes this issue.
- Record
CVE-2026-28811- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-1295
- Updated
- 2026-11-02
OSV
7.5
Apache JSPWiki: Error Handling - Reveals Error Details
Debug Messages Revealing Unnecessary Information in Apache JSPWiki up to 2.12.3. Users are recommended to upgrade to version 2.12.4, which fixes this issue.
- Record
CVE-2026-28811- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-1295
- Updated
- 2026-11-02
Affected products
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2026-28811 is a high vulnerability (CVSS 7.5) in Apache Jspwiki, published July 30, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.79%, the 56th percentile. No source names a fixed version.
References
lists.apache.org/thread/2dm414zzjo3pvhjz6mvqy3b5yhvnkcg5
jspwiki-wiki.apache.org/Wiki.jsp?page=CVE-2026-28811
openwall.com/lists/oss-security/2026/07/30/14
nvd.nist.gov/vuln/detail/CVE-2026-28811
github.com/advisories/GHSA-4xg4-cv39-wq7w
github.com/CVEProject/cvelistV5/tree/main/cves/2026/28xxx/CVE-2026-28811.json