Every CVE Search/ Get API key

CVE-2026-29053

Ghost Vulnerable to Remote Code Execution via Malicious Themes

7.7 HighPublic exploitFix available

Ghost is a Node.js content management system. From version 0.7.2 to 6.19.0, specifically crafted malicious themes can execute arbitrary code on the server running Ghost. This issue has been patched in version 6.19.1.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
High
Privileges needed
High
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

4.90%Up 4.9 points since Mar 5, 2026
90%50%10%1%

What each source reports

CVE List Score used 7.7

Ghost Vulnerable to Remote Code Execution via Malicious Themes

Ghost is a Node.js content management system. From version 0.7.2 to 6.19.0, specifically crafted malicious themes can execute arbitrary code on the server running Ghost. This issue has been patched in version 6.19.1.

Record
CVE-2026-29053
CVSS 3.1
7.7 HighCVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:H
Weakness
CWE-74
Updated
2026-11-02
EUVDEUVD-2026-9788 7.7

Ghost is a Node.js content management system. From version 0.7.2 to 6.19.0, specifically crafted malicious themes can execute arbitrary code on the server running Ghost. This issue has been patched in version 6.19.1.

Record
EUVD-2026-9788
CVSS 3.1
7.7 HighCVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:H
Updated
2026-11-02
GitHub AdvisoriesGHSA-cgc2-rcrh-qr5x 7.6

Ghost Vulnerable to Remote Code Execution via Malicious Themes

Impact

Specifically crafted malicious themes can execute arbitrary code on the server running Ghost.

Vulnerable Versions

This vulnerability is present in Ghost v0.7.2 to v6.19.0.

Patches

v6.19.1 contains a fix for this issue.

Workarounds

Ghost generally recommends users refrain from installing untrusted themes. If a malicious theme has already been installed, it is recommended to uninstall the theme and then inspect it to understand its impact, which will be attack-specific.

References

Ghost thanks Cristian-Alexandru Staicu at Endor Labs for disclosing this vulnerability responsibly.

For more information

If there are any questions or comments about this advisory, email Ghost at [email protected].

Record
GHSA-cgc2-rcrh-qr5x
CVSS 3.1
7.6 HighCVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:H
Weakness
CWE-74
Updated
2026-11-02
NVD 7.6

Ghost is a Node.js content management system. From version 0.7.2 to 6.19.0, specifically crafted malicious themes can execute arbitrary code on the server running Ghost. This issue has been patched in version 6.19.1.

Record
CVE-2026-29053
CVSS 3.1
7.6 HighCVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:H
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-74
Updated
2026-11-02
OSV 7.6

Ghost Vulnerable to Remote Code Execution via Malicious Themes

Ghost is a Node.js content management system. From version 0.7.2 to 6.19.0, specifically crafted malicious themes can execute arbitrary code on the server running Ghost. This issue has been patched in version 6.19.1.

Record
CVE-2026-29053
CVSS 3.1
7.6 HighCVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:H
Weakness
CWE-74
Updated
2026-11-02
OSVGHSA-cgc2-rcrh-qr5x 7.6

Ghost Vulnerable to Remote Code Execution via Malicious Themes

Impact

Specifically crafted malicious themes can execute arbitrary code on the server running Ghost.

Vulnerable Versions

This vulnerability is present in Ghost v0.7.2 to v6.19.0.

Patches

v6.19.1 contains a fix for this issue.

Workarounds

Ghost generally recommends users refrain from installing untrusted themes. If a malicious theme has already been installed, it is recommended to uninstall the theme and then inspect it to understand its impact, which will be attack-specific.

References

Ghost thanks Cristian-Alexandru Staicu at Endor Labs for disclosing this vulnerability responsibly.

For more information

If there are any questions or comments about this advisory, email Ghost at [email protected].

Record
GHSA-cgc2-rcrh-qr5x
CVSS 3.1
7.6 HighCVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:H
Weakness
CWE-74
Updated
2026-11-02
OSVBIT-ghost-2026-29053 No score

Ghost Vulnerable to Remote Code Execution via Malicious Themes

Ghost is a Node.js content management system. From version 0.7.2 to 6.19.0, specifically crafted malicious themes can execute arbitrary code on the server running Ghost. This issue has been patched in version 6.19.1.

Record
BIT-ghost-2026-29053
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
ghost
npm
0.7.2 to 6.19.0
6.19.1
ghost
Bitnami
0.7.2 up to 6.19.1
6.19.1
ghost
npm
0.7.2 up to 6.19.1
6.19.1

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
Exploit-DBGhost_CMS 6.19.0 - Remote Code Execution2026-09-02
MetasploitGhost CMS Remote Code Execution2026-03-02
PoC in GitHubAC8999/CVE-2026-290532026-04-21
PoC in GitHubrootxran/CVE-2026-290532026-03-12

History

History
RecordedChangedSources
first indexedCVE List, EUVD, Exploit-DB, GitHub Advisories, Metasploit, NVD, OSV, PoC in GitHub

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2026-29053 is a high vulnerability (CVSS 7.7) in Ghost, published March 3, 2026. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 4.90%, the 92nd percentile. Fixed in ghost 6.19.1.

References

MoveEnter Open